]> git.pld-linux.org Git - packages/Atari800.git/blobdiff - Atari800.spec
- fixed %%if/%%ifarch conflict
[packages/Atari800.git] / Atari800.spec
index 408f8d3f3f250793d966d50776588229a1295bc9..47825f7baf21a10339f6204751002ea4c077bffc 100644 (file)
@@ -1,38 +1,42 @@
 #
 # Conditional build:
 # _with_license_agreement - with unzipped ROM files instead of xf25.zip
+# _without_svgalib       - without SVGA version
 #
 Summary:       Atari 800 Emulator
 Summary(pl):   Emulator Atari 800
 Name:          Atari800
-%define                ver_short       107
-Version:       1.0.7
+Version:       1.2.2
 Release:       1
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
-Source0:       ftp://ftp.sophics.cz/pub/Atari800/src/a800s%{ver_short}.zip
+Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/atari800/atari800-%{version}.tar.gz
 # NOTE: ROMs probably can be redistributed only in original XF25 archive
 Source1:       http://joy.sophics.cz/www/xf25.zip
 Source2:       %{name}-chooser
+Patch0:                %{name}-shm_fix.patch
 URL:           http://atari800.atari.org/
 BuildRequires: unzip
-BuildRequires: svgalib-devel
+%ifarch %{ix86}
+%{!?_without_svgalib:BuildRequires:    svgalib-devel}
+%endif
 BuildRequires: XFree86-devel
 BuildRequires: zlib-devel
+BuildRequires: SDL-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _xbindir        %{_prefix}/X11R6/bin
 
 %description
+This is Atari 800, 800XL, 130XE and 5200 emulator.
+
+%description -l pl
+To jest emulator Atari 800, 800XL, 130XE i 5200.
 
 %package common
 Summary:       Atari 800 Emulator - common files for svgalib and X11 versions
 Summary(pl):   Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Obsoletes:     Atari800
 %{!?_with_license_agreement:Prereq:    unzip}
 
@@ -60,10 +64,8 @@ oraz X11.
 %package svga
 Summary:       Atari 800 Emulator - svgalib version
 Summary(pl):   Emulator Atari 800 - wersja pod svgalib
-Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 License:       GPL
+Group:         Applications/Emulators
 Requires:      %{name}-common = %{version}
 
 %description svga
@@ -81,10 +83,8 @@ svgalib z obs
 %package x11
 Summary:       Atari 800 Emulator - X Window version
 Summary(pl):   Emulator Atari 800 - wersja pod X Window
-Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 License:       GPL
+Group:         Applications/Emulators
 Requires:      %{name}-common = %{version}
 
 %description x11
@@ -99,63 +99,114 @@ To jest emulator Atari 800, 800XL, 130XE i 5200.
 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
 obs³ug± d¼wiêku i joysticka.
 
+%package SDL
+Summary:       Atari 800 Emulator - SDL version
+Summary(pl):   Emulator Atari 800 - wersja pod SDL
+License:       GPL
+Group:         Applications/Emulators
+Requires:      %{name}-common = %{version}
+
+%description SDL
+This is Atari 800, 800XL, 130XE and 5200 emulator.
+
+This package contains Atari800 executable file configured for SDL with
+sound and joystick support.
+
+%description SDL -l pl
+To jest emulator Atari 800, 800XL, 130XE i 5200.
+
+Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
+obs³ug± d¼wiêku i joysticka.
+
 %prep
-%setup -q -c -T -n %{name}-%{version}
-cd ..
-unzip -q %{SOURCE0}
+%setup -q -n atari800-%{version}
+%patch0 -p1
 
 %build
 cd src
 
-%configure svgalib <<EOF
-n
-y
-y
-y
-y
-n
-y
-n
-y
-n
-n
-y
-y
-y
-y
-n
-y
-n
-n
-n
-y
-y
-EOF
+%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
+%ifarch %{ix86}
+
+%configure2_13 --target=svgalib \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --disable-SVGA_SPEEDUP \
+       --enable-USE_CURSORBLOCK \
+       --disable-JOYMOUSE \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO \
+       --disable-BUFFERED_LOG \
+       --enable-SET_LED \
+       --enable-NO_LED_ON_SCREEN
+
 %{__make} \
        CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
        LDFLAGS="%{rpmldflags}"
 mv -f atari800 atari800-svga
 
 %{__make} clean
+%endif
+%endif
+
+%configure2_13 --target=sdl \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO \
+       --disable-BUFFERED_LOG \
+       --enable-SET_LED \
+       --enable-NO_LED_ON_SCREEN
+       
+%{__make} \
+       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include/SDL" \
+       LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
+mv -f atari800 atari800-SDL
+
+%{__make} clean
+
+%configure2_13 --target=x11-shm \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO
 
-%configure x11-shm <<EOF
-n
-y
-y
-y
-y
-n
-n
-n
-y
-y
-y
-y
-y
-y
-n
-n
-EOF
 %{__make} \
        CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
        LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
@@ -168,8 +219,11 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir}} \
        $RPM_BUILD_ROOT{%{_datadir}/atari800,%{_mandir}/man1}
 
-install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
+%ifarch %{ix86}
+%{!?_without_svgalib:install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}}
+%endif
 install src/atari800-x11 $RPM_BUILD_ROOT%{_xbindir}
+install src/atari800-SDL $RPM_BUILD_ROOT%{_xbindir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
 install src/atari800.1 $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
 
@@ -181,7 +235,7 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
 %endif
 
 gzip -9nf DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST \
-       DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt,usage1}
+       DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -199,10 +253,18 @@ unzip -q -L xf25.zip
 %{_mandir}/man1/atari800.1*
 %attr(755,root,root) %{_bindir}/atari800
 
+%ifarch %{ix86}
+%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
 %files svga
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-svga
+%endif
+%endif
 
 %files x11
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_xbindir}/atari800-x11
+
+%files SDL
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_xbindir}/atari800-SDL
This page took 0.072047 seconds and 4 git commands to generate.