]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- updated to 1.1.0
[packages/wine.git] / wine.spec
index 08a6719fa32a2c10827e3b7a59502e75dde5c0a1..1a4da8179cbf93ddc09366a4e6dec632eb820743 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,13 +1,15 @@
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
-%bcond_without arts            # don't build aRts mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
-%bcond_with    d3d9            # build with d3d9 patch
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
+# NOTE:        wineconsole is a bit broken: try wineconsole cmd to see what will happen
+#      As a workaroound use `wineconsole --backend=user cmd' (works fine)
+#      ref: http://bugs.winehq.org/show_bug.cgi?id=8069
+#
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 #   libcups (winspool.dll.so,wineps.dll.so)
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 #   libcups (winspool.dll.so,wineps.dll.so)
 %undefine      with_jack
 %endif
 Summary:       Program that lets you launch Win applications
 %undefine      with_jack
 %endif
 Summary:       Program that lets you launch Win applications
-Summary(es):   Ejecuta programas Windows en Linux
-Summary(pl):   Program pozwalaj±cy uruchamiaæ aplikacje Windows
-Summary(pt_BR):        Executa programas Windows no Linux
+Summary(es.UTF-8):     Ejecuta programas Windows en Linux
+Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
+Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
 Name:          wine
-Version:       0.9.9
+Version:       1.1.0
 Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
-#Source0:      http://dl.sourceforge.net/%{name}/Wine-%{version}.tar.gz
-#Source0:      ftp://ftp.ibiblio.org/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
 Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
 Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: 19538823c101b18feca83e4f06312139
-Source1:       %{name}.init
+# Source0-md5: b2374c4802bbef2f03633e153643b870
+Source1:       %{name}-uninstaller.desktop
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
-Patch2:                %{name}-alsa.patch
-# Oliver Stieber's DirectX 9 support patch (unofficial, published on WWN Issue #271)
-Patch3:                %{name}-d3d9patch.patch
-#PatchX:               %{name}-dga.patch
+Patch2:                %{name}-ncurses.patch
+Patch3:                %{name}-bug9177_workaround.patch
+Patch4:                %{name}-disable-valgrind.patch
+#PatchX:       %{name}-dga.patch
 URL:           http://www.winehq.org/
 URL:           http://www.winehq.org/
+BuildRequires: OpenGL-GLU-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
 %{?with_arts:BuildRequires:    artsc-devel}
-BuildRequires: OpenGL-GLU-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-# BuildRequires:       chpax >= 0.20020901-2
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
@@ -59,27 +58,35 @@ BuildRequires:      flex
 BuildRequires: fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
 BuildRequires: fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
+BuildRequires: giflib-devel
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libtool
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libtool
-BuildRequires: libungif-devel
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: openldap-devel
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
 %{?with_sane:BuildRequires:    sane-backends-devel}
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: xorg-lib-libXi
-BuildRequires: xorg-lib-libXmu
-BuildRequires: xorg-lib-libXrender
-BuildRequires: xorg-lib-libXxf86dga
-BuildRequires: xorg-lib-libXxf86vm
-Requires(post):        /sbin/ldconfig
-Requires(post,preun):  /sbin/chkconfig
+#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXrender-devel
+BuildRequires: xorg-lib-libXxf86dga-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
+Suggests:      binfmt-detector
+# for winelauncher
+Suggests:      xorg-app-xmessage
+# for ntlm_auth
+Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
+Obsoletes:     wine-doc-pdf
+Obsoletes:     wine-drv-arts
 ExclusiveArch: %{ix86}
 ExclusiveArch: %{ix86}
+ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
@@ -89,6 +96,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
 
 
 %define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
 
+%undefine      debuginfocflags
+
 %description
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
 %description
 Wine is a program which allows running Microsoft Windows programs
 (including DOS, Windows 3.x and Win32 executables) on Unix. It
@@ -97,59 +106,59 @@ Windows binary, and a library that implements Windows API calls using
 their Unix or X11 equivalents. The library may also be used for
 porting Win32 code into native Unix executables.
 
 their Unix or X11 equivalents. The library may also be used for
 porting Win32 code into native Unix executables.
 
-%description -l es
+%description -l es.UTF-8
 Ejecuta programas Windows en Linux.
 
 Ejecuta programas Windows en Linux.
 
-%description -l pl
-Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
-dla Microsoft Windows pod systemami uniksowymi. Sk³ada siê on z
-loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
-Microsoft Windows, oraz z biblioteki, która implementuje API Windows
-przy u¿yciu odpowiedników uniksowych oraz z X11. Biblioteka mo¿e byæ
-tak¿e wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
+%description -l pl.UTF-8
+Wine jest programem dzięki któremu można uruchamiać programy napisane
+dla Microsoft Windows pod systemami uniksowymi. Składa się on z
+loadera, który pozwala wczytywać i uruchamiać programy w formacie
+Microsoft Windows, oraz z biblioteki, która implementuje API Windows
+przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
+także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
 
 
-%description -l pt_BR
-O Wine é um programa que permite rodar programas MS-Windows no X11.
+%description -l pt_BR.UTF-8
+O Wine é um programa que permite rodar programas MS-Windows no X11.
 Ele consiste de um carregador de programa, que carrega e executa um
 Ele consiste de um carregador de programa, que carrega e executa um
-binário MS-Windows, e de uma biblioteca de emulação que traduz as
+binário MS-Windows, e de uma biblioteca de emulação que traduz as
 chamadas da API para as equivalentes Unix/X11.
 
 %package devel
 Summary:       Wine - header files
 chamadas da API para as equivalentes Unix/X11.
 
 %package devel
 Summary:       Wine - header files
-Summary(es):   Biblioteca de desarrollo de wine
-Summary(pl):   Wine - pliki nag³owkowe
-Summary(pt_BR):        Biblioteca de desenvolvimento do wine
+Summary(es.UTF-8):     Biblioteca de desarrollo de wine
+Summary(pl.UTF-8):     Wine - pliki nagłowkowe
+Summary(pt_BR.UTF-8):  Biblioteca de desenvolvimento do wine
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 Wine - header files.
 
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 Wine - header files.
 
-%description devel -l es
+%description devel -l es.UTF-8
 Biblioteca de desarrollo de wine.
 
 Biblioteca de desarrollo de wine.
 
-%description devel -l pl
-Wine - pliki nag³ówkowe.
+%description devel -l pl.UTF-8
+Wine - pliki nagłówkowe.
 
 
-%description devel -l pt_BR
-Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
+%description devel -l pt_BR.UTF-8
+Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
 %package programs
 Summary:       Wine - programs
 WINE.
 
 %package programs
 Summary:       Wine - programs
-Summary(pl):   Wine - programy
+Summary(pl.UTF-8):     Wine - programy
 Group:         Applications
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description programs
 Wine - programs.
 
 Group:         Applications
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description programs
 Wine - programs.
 
-%description programs -l pl
+%description programs -l pl.UTF-8
 Wine - programy.
 
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
 Wine - programy.
 
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± Direct3D dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -157,12 +166,12 @@ Requires: OpenGL
 %description dll-d3d
 Direct3D implementation DLLs for Wine (through OpenGL).
 
 %description dll-d3d
 Direct3D implementation DLLs for Wine (through OpenGL).
 
-%description dll-d3d -l pl
-Biblioteki DLL z implementacj± Direct3D dla Wine (poprzez OpenGL).
+%description dll-d3d -l pl.UTF-8
+Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
 
 %package dll-gl
 Summary:       OpenGL implementation DLLs for Wine
 
 %package dll-gl
 Summary:       OpenGL implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± OpenGL dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -170,48 +179,36 @@ Requires: OpenGL
 %description dll-gl
 OpenGL implementation DLLs for Wine.
 
 %description dll-gl
 OpenGL implementation DLLs for Wine.
 
-%description dll-gl -l pl
-Biblioteki DLL z implementacj± OpenGL dla Wine.
+%description dll-gl -l pl.UTF-8
+Biblioteki DLL z implementacją OpenGL dla Wine.
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
-Summary(pl):   Biblioteka DLL z implementacj± TWAIN dla Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją TWAIN dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-twain
 TWAIN implementation DLL for Wine (through SANE).
 
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-twain
 TWAIN implementation DLL for Wine (through SANE).
 
-%description dll-twain -l pl
-Biblioteka DLL z implementacj± TWAIN dla Wine (poprzez SANE).
+%description dll-twain -l pl.UTF-8
+Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl):   Sterownik ALSA dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-alsa
 ALSA driver for WINE mm.dll (multimedia system) implementation.
 
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-alsa
 ALSA driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-alsa -l pl
-Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
-
-%package drv-arts
-Summary:       aRts driver for WINE mm.dll implementation
-Summary(pl):   Sterownik aRts dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-arts
-aRts driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-arts -l pl
-Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-alsa -l pl.UTF-8
+Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %package drv-jack
 Summary:       JACK driver for WINE mm.dll implementation
 
 %package drv-jack
 Summary:       JACK driver for WINE mm.dll implementation
-Summary(pl):   Sterownik JACK-a dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik JACK-a dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      jack-audio-connection-kit
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      jack-audio-connection-kit
@@ -221,28 +218,29 @@ Requires: jack-audio-connection-kit
 %description drv-jack
 JACK driver for WINE mm.dll (multimedia system) implementation.
 
 %description drv-jack
 JACK driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-jack -l pl
-Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
+%description drv-jack -l pl.UTF-8
+Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
 Wine.
 
 %package drv-nas
 Summary:       NAS driver for WINE mm.dll implementation
 Wine.
 
 %package drv-nas
 Summary:       NAS driver for WINE mm.dll implementation
-Summary(pl):   Sterownik NAS dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik NAS dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-nas
 NAS driver for WINE mm.dll (multimedia system) implementation.
 
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-nas
 NAS driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-nas -l pl
-Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-nas -l pl.UTF-8
+Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%{?with_d3d9:%patch3 -p1}
+%patch3 -p1
+%patch4 -p1
 
 # turn off compilation of some tools
 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
 
 # turn off compilation of some tools
 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
@@ -250,6 +248,7 @@ sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
 
 %build
 %{__autoconf}
 
 %build
 %{__autoconf}
+%{__autoheader}
 %configure \
        %{!?debug:--disable-debug} \
        %{!?debug:--disable-trace} \
 %configure \
        %{!?debug:--disable-debug} \
        %{!?debug:--disable-trace} \
@@ -259,7 +258,6 @@ sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
 %{__make} depend
 %{__make}
 %{__make} -C programs
 %{__make} depend
 %{__make}
 %{__make} -C programs
-#%{__make} -C programs/regapi
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -274,22 +272,19 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
 
 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
 install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
 
 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
-#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
 
 
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
+install -d \
        $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
        "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
        $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
        $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
        $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
 
        $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
        "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
        $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
        $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
        $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wine
-
 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
 
 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
 
-cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
+cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
 [mci]
 cdaudio=mcicda.drv
 sequencer=mciseq.drv
 [mci]
 cdaudio=mcicda.drv
 sequencer=mciseq.drv
@@ -317,7 +312,7 @@ fi
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp wcmd"
+programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
 
 BZZZ=`pwd`
 rm -f files.so;                touch files.so
 
 BZZZ=`pwd`
 rm -f files.so;                touch files.so
@@ -325,7 +320,7 @@ rm -f files.programs;       touch files.programs
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
-               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
+               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
                        ;;
                *)
                        echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
                        ;;
                *)
                        echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
@@ -339,29 +334,25 @@ for p in $programs; do
        mv -f files.so. files.so
 done
 
        mv -f files.so. files.so
 done
 
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-/sbin/ldconfig
-/sbin/chkconfig --add wine
-if [ ! -f /var/lock/subsys/wine ]; then
-       echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
-fi
+%post  -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
 
-%preun
-if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/wine ]; then
-               /etc/rc.d/init.d/wine stop >&2
-       fi
+%triggerpostun -- wine < 1:0.9.12-1.9
+rm -f /var/lock/subsys/wine
+if [ -x /sbin/chkconfig ]; then
        /sbin/chkconfig --del wine
 fi
 
        /sbin/chkconfig --del wine
 fi
 
-%postun -p /sbin/ldconfig
-
 %files -f files.so
 %defattr(644,root,root,755)
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README DEVELOPERS-HINTS ChangeLog AUTHORS ANNOUNCE
+%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
@@ -377,7 +368,7 @@ fi
 %attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/winedbg
 %attr(755,root,root) %{_bindir}/wine-kthread
 %attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/winedbg
 %attr(755,root,root) %{_bindir}/wine-kthread
-%attr(755,root,root) %{_bindir}/winelauncher
+#%attr(755,root,root) %{_bindir}/winelauncher
 %attr(755,root,root) %{_bindir}/wineprefixcreate
 %attr(755,root,root) %{_bindir}/wine-preloader
 %attr(755,root,root) %{_bindir}/wine-pthread
 %attr(755,root,root) %{_bindir}/wineprefixcreate
 %attr(755,root,root) %{_bindir}/wine-preloader
 %attr(755,root,root) %{_bindir}/wine-pthread
@@ -388,13 +379,15 @@ fi
 %{_libdir}/wine/*.dll16
 %{_libdir}/wine/*.drv16
 %{_libdir}/wine/*.exe16
 %{_libdir}/wine/*.dll16
 %{_libdir}/wine/*.drv16
 %{_libdir}/wine/*.exe16
-%{_mandir}/man1/wine.*
+%{_libdir}/wine/*.mod16
+%{_mandir}/man1/wine.1*
 %{_mandir}/man1/winedbg.1*
 %{_mandir}/man1/winedbg.1*
-%{_mandir}/man1/wineserver.*
-%attr(754,root,root) /etc/rc.d/init.d/wine
+%{_mandir}/man1/wineprefixcreate.1*
+%{_mandir}/man1/wineserver.1*
 %{_winedir}
 %{_winedir}
-%{_datadir}/fonts/wine
 %{_desktopdir}/wine.desktop
 %{_desktopdir}/wine.desktop
+%{_desktopdir}/wine-uninstaller.desktop
+%{_pixmapsdir}/wine.svg
 
 %files programs -f files.programs
 %defattr(644,root,root,755)
 
 %files programs -f files.programs
 %defattr(644,root,root,755)
@@ -409,12 +402,14 @@ fi
 %attr(755,root,root) %{_bindir}/wineg++
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
 %attr(755,root,root) %{_bindir}/wineg++
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
+%attr(755,root,root) %{_bindir}/winecpp
 #%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
 %{_libdir}/wine/lib*.def
 # no shared variants, so not separated
 %{_libdir}/wine/lib*.def.a
 #%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
 %{_libdir}/wine/lib*.def
 # no shared variants, so not separated
 %{_libdir}/wine/lib*.def.a
+%{_libdir}/wine/libadsiid.a
 %{_libdir}/wine/libdx*.a
 %{_libdir}/wine/libstrmiids.a
 %{_libdir}/wine/libuuid.a
 %{_libdir}/wine/libdx*.a
 %{_libdir}/wine/libstrmiids.a
 %{_libdir}/wine/libuuid.a
@@ -423,6 +418,7 @@ fi
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winedump.1*
 %{_mandir}/man1/winegcc.1*
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winedump.1*
 %{_mandir}/man1/winegcc.1*
+%{_mandir}/man1/wineg++.1*
 %{_mandir}/man1/winemaker.1*
 %{_mandir}/man1/winebuild.1*
 %{_mandir}/man1/wmc.1*
 %{_mandir}/man1/winemaker.1*
 %{_mandir}/man1/winebuild.1*
 %{_mandir}/man1/wmc.1*
@@ -444,6 +440,7 @@ fi
 %if %{with sane}
 %files dll-twain
 %defattr(644,root,root,755)
 %if %{with sane}
 %files dll-twain
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/wine/sane.ds.so
 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
 %endif
 
 %attr(755,root,root) %{_libdir}/wine/twain*.dll.so
 %endif
 
@@ -453,12 +450,6 @@ fi
 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
 %endif
 
 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
 %endif
 
-%if %{with arts}
-%files drv-arts
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
-%endif
-
 %if %{with jack}
 %files drv-jack
 %defattr(644,root,root,755)
 %if %{with jack}
 %files drv-jack
 %defattr(644,root,root,755)
This page took 0.355232 seconds and 4 git commands to generate.