]> git.pld-linux.org Git - packages/sox.git/blobdiff - sox.spec
- updated to 12.17.3
[packages/sox.git] / sox.spec
index 1435b11877cffbc68af30be093c3ba8e1dec3ed0..7612910420306c6c0c276bfdc895e7ac1bfb98c4 100644 (file)
--- a/sox.spec
+++ b/sox.spec
@@ -1,22 +1,31 @@
 #
 # Conditional build:   
 #
 # Conditional build:   
-# bcond_off_alsa - without ALSA support
+# _without_alsa - without ALSA support
 #
 #
+
 Summary:       A general purpose sound file conversion tool
 Summary:       A general purpose sound file conversion tool
+Summary(de):   Mehrzweck-Sounddatei-Konvertierungs-Tool
+Summary(fr):   outil général de conversion de fichiers son
+Summary(pl):   Program do konwersji plików d¼wiêkowych
+Summary(tr):   Genel amaçlý ses dosyasý çevirme aracý
 Name:          sox
 Name:          sox
-Version:       12.17
+Version:       12.17.3
 Release:       1
 Release:       1
-LIcense:       Distributable
+License:       distributable
 Group:         Applications/Sound
 Group(de):     Applikationen/Laut
 Group(pl):     Aplikacje/D¼wiêk
 Group:         Applications/Sound
 Group(de):     Applikationen/Laut
 Group(pl):     Aplikacje/D¼wiêk
-Source0:       http://home.sprynet.com/sprynet/cbagwell/%{name}-%{version}.tar.gz
-Url:           http://home.sprynet.com/sprynet/cbagwell/
-Patch0:                %{name}-12.15-paths.patch
-Patch1:                %{name}-makefile.patch
-Patch2:                %{name}-play.patch
+Source0:       http://prdownloads.sourceforge.net/sox/%{name}-%{version}.tar.gz
+Patch0:                %{name}-play.patch
+Patch1:                %{name}-soundcard.patch
+Patch2:                %{name}-install.patch
+URL:           http://sox.sourceforge.net
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: libgsm-devel
 BuildRequires: libgsm-devel
-%{!?bcond_off_alsa:BuildRequires:      alsa-driver-devel}
+%ifnarch sparc sparc64
+%{!?_without_alsa:BuildRequires:       alsa-driver-devel}
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -28,12 +37,23 @@ simple sound manipulation functions, including sound effects.
 Install the sox package if you'd like to convert sound file formats or
 manipulate some sounds.
 
 Install the sox package if you'd like to convert sound file formats or
 manipulate some sounds.
 
+%description -l pl
+SoX (Sound eXchange) jest konwerterem formatów plików d¼wiêkowych dla
+Linuksa, Uniksa i Dosa. SoX mo¿e wykonywaæ konwersjê miêdzy wieloma
+formatami cyfrowego d¼wiêku. Mo¿e tak¿e dokonywaæ prostych manipulacji
+na d¼wiêku, wliczaj±c w to ró¿ne efekty d¼wiekowe.
+
 %package devel
 %package devel
-Summary:       The SoX sound file format converter libraries.
+Summary:       The SoX sound file format converter libraries
+Summary(pl):   Biblioteka SoX do konwertowania plików d¼wiêkowych
 Group:         Development/Libraries
 Group(de):     Entwicklung/Libraries
 Group:         Development/Libraries
 Group(de):     Entwicklung/Libraries
+Group(es):     Desarrollo/Bibliotecas
 Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
 Group(fr):     Development/Librairies
 Group(pl):     Programowanie/Biblioteki
+Group(pt_BR):  Desenvolvimento/Bibliotecas
+Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
+Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 
 %description devel 
 This package contains the library needed for compiling applications
 
 %description devel 
 This package contains the library needed for compiling applications
@@ -42,6 +62,10 @@ which will use the SoX sound file format converter.
 Install sox-devel if you want to develop applications which will use
 SoX.
 
 Install sox-devel if you want to develop applications which will use
 SoX.
 
+%description devel -l pl
+Ten pakiet zawiera biblioteki potrzebne do kompilacji aplikacji, które
+bêd± wykorzystywa³y konwerter formatów plików d¼wiêkowych SoX.
+
 %prep
 %setup -q 
 %patch0 -p1
 %prep
 %setup -q 
 %patch0 -p1
@@ -49,29 +73,27 @@ SoX.
 %patch2 -p1
 
 %build
 %patch2 -p1
 
 %build
-%configure --with-oss-dsp \
-       %{!?bcond_off_alsa:--with-alsa-dsp}
+aclocal
+autoconf
+%configure \
+       --with-oss-dsp \
+       --with-gsm \
+%ifnarch sparc sparc64
+       %{!?_without_alsa:--with-alsa-dsp}
+%endif
 
 %{__make} PREFIX=%{_prefix}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} PREFIX=%{_prefix}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}/man{1,3}}
 
 %{__make} install install-lib \
 
 %{__make} install install-lib \
-       PREFIX=$RPM_BUILD_ROOT%{_prefix} \
-       MANDIR=$RPM_BUILD_ROOT%{_mandir} \
-       BINDIR=$RPM_BUILD_ROOT%{_bindir} \
-       LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
-       INCDIR=$RPM_BUILD_ROOT%{_includedir} \
-       INSTALL_DIR=$RPM_BUILD_ROOT 
+       DESTDIR=$RPM_BUILD_ROOT
 
 echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
 echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
 echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
 
 
 echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
 echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
 echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
 
-echo .so play.1 >$RPM_BUILD_ROOT%{_mandir}/man1/rec.1
-
 gzip -9nf Changelog README TODO INSTALL
 
 %clean
 gzip -9nf Changelog README TODO INSTALL
 
 %clean
@@ -81,6 +103,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc *.gz monkey.*
 %attr(755,root,root) %{_bindir}/sox
 %defattr(644,root,root,755)
 %doc *.gz monkey.*
 %attr(755,root,root) %{_bindir}/sox
+%attr(755,root,root) %{_bindir}/soxmix
 %attr(755,root,root) %{_bindir}/play   
 %attr(755,root,root) %{_bindir}/rec  
 %attr(755,root,root) %{_bindir}/soxplay
 %attr(755,root,root) %{_bindir}/play   
 %attr(755,root,root) %{_bindir}/rec  
 %attr(755,root,root) %{_bindir}/soxplay
This page took 0.111642 seconds and 4 git commands to generate.