]> git.pld-linux.org Git - packages/ruby.git/blobdiff - ruby.spec
up to 2.3.4
[packages/ruby.git] / ruby.spec
index d3c43d15d7a6f15d264788a387f003b51f8eea79..9f6967f702df017dc6f1099acb2fa3efa3a347da 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
 %bcond_with    bootstrap       # build bootstrap version
 %bcond_with    tests           # build without tests
 
 %bcond_with    bootstrap       # build bootstrap version
 %bcond_with    tests           # build without tests
 
-# prevent some weird build error:
-# readlink: unrecognized option '--library=pthread'
-%define debug 1
-
 %define                rel             0.1
 %define                ruby_version    2.3
 %define                basever         2.3
 %define                rel             0.1
 %define                ruby_version    2.3
 %define                basever         2.3
-%define                patchlevel      3
+%define                patchlevel      4
 %define                pkg_version     %{basever}.%{patchlevel}
 
 %define                ruby_suffix %{!?with_default_ruby:%{ruby_version}}
 %define                pkg_version     %{basever}.%{patchlevel}
 
 %define                ruby_suffix %{!?with_default_ruby:%{ruby_version}}
-%define                doc_version     2_2_5
+%define                doc_version     2_3_4
 
 %define                bigdecimal_ver  1.2.8
 %define                io_console_ver  0.4.5
 
 %define                bigdecimal_ver  1.2.8
 %define                io_console_ver  0.4.5
@@ -55,14 +51,12 @@ Epoch:              1
 License:       (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
 Group:         Development/Languages
 # https://www.ruby-lang.org/en/downloads/
 License:       (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
 Group:         Development/Languages
 # https://www.ruby-lang.org/en/downloads/
-Source0:       https://ftp.ruby-lang.org/pub/ruby/2.2/%{oname}-%{pkg_version}.tar.xz
-# Source0-md5: 0cba3d1b677d2695236ace62ca6d2255
-Source1:       http://www.ruby-doc.org/download/%{oname}-doc-bundle.tar.gz
-# Source1-md5: ad1af0043be98ba1a4f6d0185df63876
+Source0:       https://cache.ruby-lang.org/pub/ruby/%{ruby_version}/%{oname}-%{pkg_version}.tar.xz
+# Source0-md5: ee011c51c0395ec46f072da9beb6b870
 Source2:       http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_stdlib_rdocs.tgz
 Source2:       http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_stdlib_rdocs.tgz
-# Source2-md5: ac3d547e5ea9ef5a89be161cd967a5e8
+# Source2-md5: 480c3f6f8d9311e86c1aa395f7d7bba6
 Source3:       http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_core_rdocs.tgz
 Source3:       http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_core_rdocs.tgz
-# Source3-md5: 12f6b7a5e923fbae0f768d3cf760e88e
+# Source3-md5: 9805d5d4537b73d2af1860e0759421f1
 Source100:     ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{oname}-1.8.7-p330.tar.gz
 # Source100-md5:       50a49edb787211598d08e756e733e42e
 Source4:       rdoc.1
 Source100:     ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{oname}-1.8.7-p330.tar.gz
 # Source100-md5:       50a49edb787211598d08e756e733e42e
 Source4:       rdoc.1
@@ -182,8 +176,6 @@ Summary(pl.UTF-8):  Standardowe moduły i narzędzia dla języka Ruby
 Group:         Development/Languages
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Suggests:      ruby-rubygems
 Group:         Development/Languages
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Suggests:      ruby-rubygems
-Provides:      ruby-bigdecimal = %{bigdecimal_ver}
-Provides:      ruby-io-console = %{io_console_ver}
 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
 Provides:      ruby-modules(ver) = %{ruby_version}
 # FIXME later
 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
 Provides:      ruby-modules(ver) = %{ruby_version}
 # FIXME later
@@ -514,14 +506,52 @@ waitfor() mechanism. Note that if you do use sysread() directly when
 in telnet mode, you should probably pass the output through
 preprocess() to extract telnet command sequences.
 
 in telnet mode, you should probably pass the output through
 preprocess() to extract telnet command sequences.
 
+%package bigdecimal
+Summary:       BigDecimal provides arbitrary-precision floating point decimal arithmetic
+Version:       %{bigdecimal_ver}
+Release:       %{pkg_version}.%{rel}
+Epoch:         0
+License:       GPL+ or Artistic
+Group:         Development/Libraries
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description bigdecimal
+Ruby provides built-in support for arbitrary precision integer
+arithmetic. For example:
+
+42**13 -> 1265437718438866624512
+
+BigDecimal provides similar support for very large or very accurate
+floating point numbers. Decimal arithmetic is also useful for general
+calculation, because it provides the correct answers people
+expect–whereas normal binary floating point arithmetic often
+introduces subtle errors because of the conversion between base 10 and
+base 2.
+
+%package io-console
+Summary:       IO/Console is a simple console utilizing library
+Version:       %{io_console_ver}
+Release:       %{pkg_version}.%{rel}
+Epoch:         0
+Group:         Development/Libraries
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description io-console
+IO/Console provides very simple and portable access to console. It
+doesn't provide higher layer features, such like curses and readline.
+
 %prep
 %prep
-%setup -q -n %{oname}-%{pkg_version} -a1 -a2 -a3 %{?with_bootstrap:-a100}
+%setup -q -n %{oname}-%{pkg_version} -a2 -a3 %{?with_bootstrap:-a100}
 %patch0 -p1
 #%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch0 -p1
 #%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-#%patch5 -p1
+%patch5 -p1
 %patch6 -p1
 #%patch8 -p1
 %patch9 -p1
 %patch6 -p1
 #%patch8 -p1
 %patch9 -p1
@@ -586,9 +616,9 @@ cd ..
        --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
        --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
        --enable-multiarch \
        --with-sitearchhdrdir='$(sitehdrdir)/$(arch)' \
        --with-vendorarchhdrdir='$(vendorhdrdir)/$(arch)' \
        --enable-multiarch \
-       --enable-pthread \
        --enable-shared \
        --disable-install-doc \
        --enable-shared \
        --disable-install-doc \
+       --disable-rpath \
        --disable-rubygems \
        --with-ruby-version='' \
 
        --disable-rubygems \
        --with-ruby-version='' \
 
@@ -964,6 +994,24 @@ rm -rf $RPM_BUILD_ROOT
 %{gem_dir}/gems/net-telnet-%{net_telnet_ver}/lib
 %{gem_dir}/specifications/net-telnet-%{net_telnet_ver}.gemspec
 
 %{gem_dir}/gems/net-telnet-%{net_telnet_ver}/lib
 %{gem_dir}/specifications/net-telnet-%{net_telnet_ver}.gemspec
 
+%files bigdecimal
+%defattr(644,root,root,755)
+%{gem_dir}/gems/bigdecimal-%{bigdecimal_ver}
+%dir %{gem_libdir}/bigdecimal-%{bigdecimal_ver}
+%dir %{gem_libdir}/bigdecimal-%{bigdecimal_ver}/lib
+%attr(755,root,root) %{gem_libdir}/bigdecimal-%{bigdecimal_ver}/lib/bigdecimal.so
+%{ruby_libdir}/bigdecimal
+%{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
+
+%files io-console
+%defattr(644,root,root,755)
+%{gem_dir}/gems/io-console-%{io_console_ver}
+%dir %{gem_libdir}/io-console-%{io_console_ver}
+%dir %{gem_libdir}/io-console-%{io_console_ver}/lib
+%dir %{gem_libdir}/io-console-%{io_console_ver}/lib/io
+%attr(755,root,root) %{gem_libdir}/io-console-%{io_console_ver}/lib/io/console.so
+%{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
+
 %files modules
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/erb%{ruby_suffix}
 %files modules
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/erb%{ruby_suffix}
@@ -1107,6 +1155,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{ruby_archdir}/syslog.so
 %attr(755,root,root) %{ruby_archdir}/zlib.so
 
 %attr(755,root,root) %{ruby_archdir}/syslog.so
 %attr(755,root,root) %{ruby_archdir}/zlib.so
 
+%dir %{ruby_archdir}/cgi
+%attr(755,root,root) %{ruby_archdir}/cgi/escape.so
 %dir %{ruby_archdir}/digest
 %attr(755,root,root) %{ruby_archdir}/digest/*.so
 #%dir %{ruby_archdir}/dl
 %dir %{ruby_archdir}/digest
 %attr(755,root,root) %{ruby_archdir}/digest/*.so
 #%dir %{ruby_archdir}/dl
@@ -1124,25 +1174,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{ruby_archdir}/rbconfig
 %attr(755,root,root) %{ruby_archdir}/rbconfig/sizeof.so
 
 %dir %{ruby_archdir}/rbconfig
 %attr(755,root,root) %{ruby_archdir}/rbconfig/sizeof.so
 
-# bigdecimal
-%{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
-%{gem_dir}/gems/bigdecimal-%{bigdecimal_ver}
-%dir %{gem_libdir}/bigdecimal-%{bigdecimal_ver}
-%dir %{gem_libdir}/bigdecimal-%{bigdecimal_ver}/lib
-%attr(755,root,root) %{gem_libdir}/bigdecimal-%{bigdecimal_ver}/lib/bigdecimal.so
-%{ruby_libdir}/bigdecimal
-
 %dir %{_libdir}/gems
 %dir %{_libdir}/gems/%{oname}
 
 %dir %{_libdir}/gems
 %dir %{_libdir}/gems/%{oname}
 
-# io-console
-%{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
-%{gem_dir}/gems/io-console-%{io_console_ver}
-%dir %{gem_libdir}/io-console-%{io_console_ver}
-%dir %{gem_libdir}/io-console-%{io_console_ver}/lib
-%dir %{gem_libdir}/io-console-%{io_console_ver}/lib/io
-%attr(755,root,root) %{gem_libdir}/io-console-%{io_console_ver}/lib/io/console.so
-
 %{gem_dir}/specifications/psych-%{psych_ver}.gemspec
 %{gem_dir}/gems/psych-%{psych_ver}
 %{ruby_libdir}/psych
 %{gem_dir}/specifications/psych-%{psych_ver}.gemspec
 %{gem_dir}/gems/psych-%{psych_ver}
 %{ruby_libdir}/psych
@@ -1157,13 +1191,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/erb%{ruby_suffix}.1*
 %{_mandir}/man1/ri%{ruby_suffix}.1*
 
 %{_mandir}/man1/erb%{ruby_suffix}.1*
 %{_mandir}/man1/ri%{ruby_suffix}.1*
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %files doc
 %defattr(644,root,root,755)
-%doc ruby-doc-bundle/*
-%{?with_doc:%doc ruby_%{doc_version}_stdlib}
-%{?with_doc:%doc ruby_%{doc_version}_core}
+%doc ruby_%{doc_version}_stdlib
+%doc ruby_%{doc_version}_core
 
 
-%if %{with doc}
 %files doc-ri
 %defattr(644,root,root,755)
 %{ruby_ridir}/*
 %files doc-ri
 %defattr(644,root,root,755)
 %{ruby_ridir}/*
This page took 0.035655 seconds and 4 git commands to generate.