]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
uuid is no longer optional
[packages/qemu.git] / qemu.spec
index 41563e984d934ee01d2897bd75ba9d577e1ee6b2..51c8a7a322ecf305531719a1f45f867d77955d86 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
-%bcond_without glx             # OpenGL/GLX support
+%bcond_without gl              # Don't require gl deps
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
@@ -22,6 +22,7 @@
 %bcond_without usbredir        # usb network redirection support
 %bcond_without system_seabios  # system seabios binary
 %bcond_without snappy          # snappy compression library
 %bcond_without usbredir        # usb network redirection support
 %bcond_without system_seabios  # system seabios binary
 %bcond_without snappy          # snappy compression library
+%bcond_without user_static     # build linux-user static packages
 %bcond_with    lttng           # lttng-ust trace backend support
 %bcond_with    systemtap       # SystemTap/dtrace trace backend support
 
 %bcond_with    lttng           # lttng-ust trace backend support
 %bcond_with    systemtap       # SystemTap/dtrace trace backend support
 
 %undefine with_gtk3
 %endif
 
 %undefine with_gtk3
 %endif
 
+%ifarch x32
+%undefine      with_xen
+%endif
+
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.2.0
+Version:       2.10.1
 Release:       1
 Release:       1
-License:       GPL v2+
+License:       GPL v2
 Group:         Applications/Emulators
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: f7a5e2da22d057eb838a91da7aff43c8
+Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
+# Source0-md5: 0c4d98038480c5c19a95990eb8d04a51
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -55,30 +60,32 @@ Source12:   99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
+Patch3:                %{name}-user-execve.patch
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
-# Proof of concept, for reference, do not remove
-Patch400:      %{name}-kde_virtual_workspaces_hack.patch
+Patch6:                x32.patch
 URL:           http://www.qemu-project.org/
 URL:           http://www.qemu-project.org/
-%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
+%{?with_gl:BuildRequires:      OpenGL-GLX-devel}
+%{?with_gl:BuildRequires:      OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
 %{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
-BuildRequires: bcc
+BuildRequires: bcc >= 0.16.21-2
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
+BuildRequires: bzip2-devel
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
-BuildRequires: glib2-devel >= 1:2.12
+BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel > 2.10.0
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel > 2.10.0
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
-BuildRequires: libfdt-devel
+%{?with_gl:BuildRequires:      libepoxy-devel}
+BuildRequires: libfdt-devel >= 1.4.2
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
 BuildRequires: libjpeg-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
 BuildRequires: libjpeg-devel
@@ -92,9 +99,11 @@ BuildRequires:       libuuid-devel
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
-%{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
+%{?with_smartcard:BuildRequires:       nss-devel >= 1:3.12.8}
+BuildRequires: numactl-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pixman-devel >= 0.21.8
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.644
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.644
@@ -124,6 +133,12 @@ BuildRequires:     gtk+2-devel >= 2:2.18.0
 BuildRequires: gtk+3-devel >= 3.0.0
 %{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 BuildRequires: gtk+3-devel >= 3.0.0
 %{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
+%if %{with user_static}
+BuildRequires: glib2-static
+BuildRequires: glibc-static
+BuildRequires: pcre-static
+BuildRequires: zlib-static
+%endif
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
@@ -134,7 +149,7 @@ Requires:   %{name}-system-m68k = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
 Requires:      %{name}-system-moxie = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
 Requires:      %{name}-system-moxie = %{version}-%{release}
-Requires:      %{name}-system-or32 = %{version}-%{release}
+Requires:      %{name}-system-or1k = %{version}-%{release}
 Requires:      %{name}-system-ppc = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-ppc = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
@@ -151,10 +166,12 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %if %{with sdl} \
 Requires:      SDL2 \
 %endif \
 %if %{with sdl} \
 Requires:      SDL2 \
 %endif \
+Requires:      libfdt >= 1.4.2 \
 %if %{with seccomp} \
 Requires:      libseccomp >= 2.1.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
 %if %{with seccomp} \
 Requires:      libseccomp >= 2.1.0 \
 %endif \
 Requires:      libusb >= 1.0.13 \
+Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
@@ -167,8 +184,9 @@ Requires:   gtk+3 >= 3.0.0 \
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
-# some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
+# don't strip/chrpath anything in there; these are boot images, roms etc
+%define                _noautostrip    .*%{_datadir}/qemu/.*
+%define                _noautochrpath  .*%{_datadir}/qemu/.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -212,7 +230,7 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      glib2 >= 1:2.12
+Requires:      glib2 >= 1:2.22
 %{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
 Requires:      systemd-units >= 38
 %{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
 Requires:      systemd-units >= 38
@@ -270,6 +288,19 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
 
 
 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
 
+%package user-static
+Summary:       QEMU user mode emulation of qemu targets static build
+Group:         Development/Tools
+Requires(post,postun): systemd-units >= 38
+Requires:      systemd-units >= 38
+
+%description user-static
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the user mode emulation of qemu targets built as
+static binaries
+
 %package system-aarch64
 Summary:       QEMU system emulator for AArch64
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AArch64
 %package system-aarch64
 Summary:       QEMU system emulator for AArch64
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AArch64
@@ -449,21 +480,22 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem Moxie.
 
 
 Ten pakiet zawiera emulator systemu z procesorem Moxie.
 
-%package system-or32
+%package system-or1k
 Summary:       QEMU system emulator for OpenRISC
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem OpenRISC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
 Summary:       QEMU system emulator for OpenRISC
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem OpenRISC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
-Obsoletes:     qemu-kvm-system-or32
+Obsoletes:     qemu-kvm-system-or1k
+Obsoletes:     qemu-system-or32
 
 
-%description system-or32
+%description system-or1k
 QEMU is a generic and open source processor emulator which achieves a
 good emulation speed by using dynamic translation.
 
 This package provides the system emulator with OpenRISC CPU.
 
 QEMU is a generic and open source processor emulator which achieves a
 good emulation speed by using dynamic translation.
 
 This package provides the system emulator with OpenRISC CPU.
 
-%description system-or32 -l pl.UTF-8
+%description system-or1k -l pl.UTF-8
 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
@@ -631,7 +663,7 @@ Summary:    QEMU guest agent
 Summary(pl.UTF-8):     Agent gościa QEMU
 Group:         Daemons
 Requires(post,preun,postun):   systemd-units >= 38
 Summary(pl.UTF-8):     Agent gościa QEMU
 Group:         Daemons
 Requires(post,preun,postun):   systemd-units >= 38
-Requires:      glib2 >= 1:2.12
+Requires:      glib2 >= 1:2.22
 Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-guest-agent
 
 Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-guest-agent
 
@@ -725,23 +757,44 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-
-%{__mv} libcacard libcacard-use-system-lib
+%patch6 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
-./configure \
-       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
-       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
+
+build() {
+       local target=$1
+       shift
+
+       install -d build-$target
+       cd build-$target
+
+       ../configure \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
        --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --libdir=%{_libdir} \
        --libexecdir=%{_libexecdir} \
        --sysconfdir=%{_sysconfdir} \
+       --localstatedir=%{_localstatedir} \
+       --interp-prefix=%{_libdir}/qemu/lib-%%M \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
+       --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
+       --enable-kvm \
+       "$@"
+
+       %{__make} \
+               V=1 \
+               %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
+
+       cd ..
+}
+
+build dynamic \
+       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
+       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
        --enable-attr \
        %{__enable_disable bluetooth bluez} \
        %{__enable_disable brlapi} \
        --enable-attr \
        %{__enable_disable bluetooth bluez} \
        %{__enable_disable brlapi} \
@@ -752,44 +805,57 @@ ln -s ../error.h qapi/error.h
        --enable-fdt \
        %{__enable_disable glusterfs} \
        %{__enable_disable iscsi libiscsi} \
        --enable-fdt \
        %{__enable_disable glusterfs} \
        %{__enable_disable iscsi libiscsi} \
-       %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        --enable-tpm \
-       --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}"
        %{__enable_disable usbredir usb-redir} \
        %{__enable_disable usbredir usb-redir} \
-       --enable-uuid \
        --enable-vde \
        --enable-virtfs \
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
        --enable-vde \
        --enable-virtfs \
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
        %{!?with_vte:--disable-vte} \
        %{!?with_vte:--disable-vte} \
-       --enable-kvm \
        %{__enable_disable xen} \
        --enable-modules \
        --disable-netmap \
        %{__enable_disable libnfs} \
        --enable-lzo \
        %{__enable_disable snappy} \
        %{__enable_disable xen} \
        --enable-modules \
        --disable-netmap \
        %{__enable_disable libnfs} \
        --enable-lzo \
        %{__enable_disable snappy} \
-       --enable-quorum \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
-       --interp-prefix=%{_libdir}/qemu/lib-%%M \
 %if %{without gtk2} && %{without gtk3}
        --disable-gtk
 %else
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
 %if %{without gtk2} && %{without gtk3}
        --disable-gtk
 %else
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
-%{__make} \
-       V=1 \
-       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
+%if %{with user_static}
+build static \
+       --disable-brlapi \
+       --disable-cap-ng \
+       --disable-curl \
+       --disable-curses \
+       --disable-gcrypt \
+       --disable-gnutls \
+       --disable-gtk \
+       --disable-guest-agent \
+       --disable-guest-agent-msi \
+       --disable-libnfs \
+       --disable-nettle \
+       --disable-pie \
+       --disable-sdl \
+       --disable-spice \
+       --disable-tcmalloc \
+       --disable-tools \
+       --enable-user \
+       --disable-system \
+       --static
+
+%endif
 
 # rebuild patched vesa tables with additional widescreen modes.
 %{__make} -C roms/vgabios stdvga-bios
 
 # rebuild patched vesa tables with additional widescreen modes.
 %{__make} -C roms/vgabios stdvga-bios
@@ -799,13 +865,27 @@ ln -s ../error.h qapi/error.h
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
-       $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
+       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
-%{__make} install \
+%if %{with user_static}
+%{__make} -C build-static install \
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# Give all QEMU user emulators a -static suffix
+for src in $RPM_BUILD_ROOT%{_bindir}/qemu-*; do
+       mv $src $src-static
+done
+
+%endif
+
+%{__make} -C build-dynamic install \
        %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT
 
        %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT
 
+echo "#allow br0" > $RPM_BUILD_ROOT/etc/qemu/bridge.conf
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
@@ -814,8 +894,7 @@ EOF
 
 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
 
 
 install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
 
-%ifarch %{ix86} %{x8664}
-install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
+%ifarch %{ix86} %{x8664} x32
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
@@ -833,30 +912,60 @@ install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
+# Install binfmt
 for i in dummy \
 for i in dummy \
-%ifnarch %{ix86} %{x8664}
+%ifnarch %{ix86} %{x8664} x32
        qemu-i386 \
 %endif
        qemu-i386 \
 %endif
-%ifnarch arm
+%ifnarch alpha
+       qemu-alpha \
+%endif
+%ifnarch %{arm}
        qemu-arm \
 %endif
        qemu-arm \
 %endif
-%ifnarch ppc ppc64
-       qemu-ppc \
+       qemu-armeb \
+       qemu-cris \
+       qemu-microblaze qemu-microblazeel \
+%ifnarch mips64
+       qemu-mips64 \
+%ifnarch mips
+       qemu-mips \
+%endif
+%endif
+%ifnarch mips64el
+       qemu-mips64el \
+%ifnarch mipsel
+       qemu-mipsel \
+%endif
+%endif
+%ifnarch m68k
+       qemu-m68k \
+%endif
+%ifnarch ppc ppc64 ppc64le
+       qemu-ppc qemu-ppc64abi32 qemu-ppc64 \
 %endif
 %ifnarch sparc sparc64
 %endif
 %ifnarch sparc sparc64
-       qemu-sparc \
+       qemu-sparc qemu-sparc32plus qemu-sparc64 \
+%endif
+%ifnarch s390 s390x
+       qemu-s390x \
 %endif
 %ifnarch sh4
        qemu-sh4 \
 %endif
 %endif
 %ifnarch sh4
        qemu-sh4 \
 %endif
+       qemu-sh4eb \
 ; do
        test $i = dummy && continue
 ; do
        test $i = dummy && continue
-       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
+       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-dynamic.conf
+
+       %if %{with user_static}
+       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
+       %{__sed} -i -e "s/$i/$i-static/" $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i-static.conf
+       %endif
 done < %{SOURCE2}
 
 # packaged as %doc
 done < %{SOURCE2}
 
 # packaged as %doc
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
 
 # install patched vesa tables with additional widescreen modes.
 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
 # install patched vesa tables with additional widescreen modes.
 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
@@ -914,6 +1023,12 @@ fi
 %postun user
 %systemd_service_restart systemd-binfmt.service
 
 %postun user
 %systemd_service_restart systemd-binfmt.service
 
+%post user-static
+%systemd_service_restart systemd-binfmt.service
+
+%postun user-static
+%systemd_service_restart systemd-binfmt.service
+
 %post guest-agent
 %systemd_reload
 
 %post guest-agent
 %systemd_reload
 
@@ -928,17 +1043,21 @@ fi
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html qmp-commands.txt
+%doc LICENSE README
+%doc build-dynamic/qemu-doc.html
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
+%dir /etc/qemu
+%attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
-%dir %{_sysconfdir}/qemu
+%attr(755,root,root) %{_bindir}/ivshmem-client
+%attr(755,root,root) %{_bindir}/ivshmem-server
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
@@ -949,21 +1068,22 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
-%{_datadir}/%{name}/trace-events
+%{_datadir}/%{name}/trace-events-all
 
 # various bios images
 # all should be probably moved to the right system subpackage
 
 # various bios images
 # all should be probably moved to the right system subpackage
-%{_datadir}/%{name}/QEMU,cgthree.bin
-%{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/bamboo.dtb
 %{_datadir}/%{name}/bamboo.dtb
+%{_datadir}/%{name}/efi-e1000e.rom
 %{_datadir}/%{name}/efi-e1000.rom
 %{_datadir}/%{name}/efi-eepro100.rom
 %{_datadir}/%{name}/efi-ne2k_pci.rom
 %{_datadir}/%{name}/efi-pcnet.rom
 %{_datadir}/%{name}/efi-rtl8139.rom
 %{_datadir}/%{name}/efi-virtio.rom
 %{_datadir}/%{name}/efi-e1000.rom
 %{_datadir}/%{name}/efi-eepro100.rom
 %{_datadir}/%{name}/efi-ne2k_pci.rom
 %{_datadir}/%{name}/efi-pcnet.rom
 %{_datadir}/%{name}/efi-rtl8139.rom
 %{_datadir}/%{name}/efi-virtio.rom
+%{_datadir}/%{name}/efi-vmxnet3.rom
 %{_datadir}/%{name}/kvmvapic.bin
 %{_datadir}/%{name}/linuxboot.bin
 %{_datadir}/%{name}/kvmvapic.bin
 %{_datadir}/%{name}/linuxboot.bin
+%{_datadir}/%{name}/linuxboot_dma.bin
 %{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
 %{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
@@ -977,20 +1097,27 @@ fi
 %{_datadir}/%{name}/pxe-pcnet.rom
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
 %{_datadir}/%{name}/pxe-pcnet.rom
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/QEMU,cgthree.bin
 %{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/qemu_logo_no_text.svg
+%{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/s390-ccw.img
 %{_datadir}/%{name}/s390-ccw.img
-%{_datadir}/%{name}/s390-zipl.rom
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/sgabios.bin
+%{_datadir}/%{name}/skiboot.lid
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
-%{_datadir}/%{name}/vgabios.bin
 
 %dir %{_libdir}/%{name}
 
 
 %dir %{_libdir}/%{name}
 
+# modules without too many external dependencies
+%attr(755,root,root) %{_libdir}/%{name}/block-dmg-bz2.so
+%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so
+
 %files img
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-img
 %files img
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-img
@@ -998,7 +1125,7 @@ fi
 
 %files user
 %defattr(644,root,root,755)
 
 %files user
 %defattr(644,root,root,755)
-/usr/lib/binfmt.d/qemu-*.conf
+/usr/lib/binfmt.d/qemu-*-dynamic.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
 %attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
@@ -1015,7 +1142,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-mips64el
 %attr(755,root,root) %{_bindir}/qemu-mipsn32
 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
 %attr(755,root,root) %{_bindir}/qemu-mips64el
 %attr(755,root,root) %{_bindir}/qemu-mipsn32
 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
-%attr(755,root,root) %{_bindir}/qemu-or32
+%attr(755,root,root) %{_bindir}/qemu-or1k
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
@@ -1026,9 +1153,42 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
-%attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
+%if %{with user_static}
+%files user-static
+%defattr(644,root,root,755)
+/usr/lib/binfmt.d/qemu-*-static.conf
+%attr(755,root,root) %{_bindir}/qemu-aarch64-static
+%attr(755,root,root) %{_bindir}/qemu-alpha-static
+%attr(755,root,root) %{_bindir}/qemu-arm-static
+%attr(755,root,root) %{_bindir}/qemu-armeb-static
+%attr(755,root,root) %{_bindir}/qemu-cris-static
+%attr(755,root,root) %{_bindir}/qemu-i386-static
+%attr(755,root,root) %{_bindir}/qemu-m68k-static
+%attr(755,root,root) %{_bindir}/qemu-microblaze-static
+%attr(755,root,root) %{_bindir}/qemu-microblazeel-static
+%attr(755,root,root) %{_bindir}/qemu-mips-static
+%attr(755,root,root) %{_bindir}/qemu-mips64-static
+%attr(755,root,root) %{_bindir}/qemu-mips64el-static
+%attr(755,root,root) %{_bindir}/qemu-mipsel-static
+%attr(755,root,root) %{_bindir}/qemu-mipsn32-static
+%attr(755,root,root) %{_bindir}/qemu-mipsn32el-static
+%attr(755,root,root) %{_bindir}/qemu-or1k-static
+%attr(755,root,root) %{_bindir}/qemu-ppc-static
+%attr(755,root,root) %{_bindir}/qemu-ppc64-static
+%attr(755,root,root) %{_bindir}/qemu-ppc64abi32-static
+%attr(755,root,root) %{_bindir}/qemu-ppc64le-static
+%attr(755,root,root) %{_bindir}/qemu-s390x-static
+%attr(755,root,root) %{_bindir}/qemu-sh4-static
+%attr(755,root,root) %{_bindir}/qemu-sh4eb-static
+%attr(755,root,root) %{_bindir}/qemu-sparc-static
+%attr(755,root,root) %{_bindir}/qemu-sparc32plus-static
+%attr(755,root,root) %{_bindir}/qemu-sparc64-static
+%attr(755,root,root) %{_bindir}/qemu-tilegx-static
+%attr(755,root,root) %{_bindir}/qemu-x86_64-static
+%endif
+
 %files system-aarch64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-aarch64
 %files system-aarch64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-aarch64
@@ -1069,9 +1229,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-moxie
 
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-moxie
 
-%files system-or32
+%files system-or1k
 %defattr(644,root,root,755)
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-or32
+%attr(755,root,root) %{_bindir}/qemu-system-or1k
 
 %files system-ppc
 %defattr(644,root,root,755)
 
 %files system-ppc
 %defattr(644,root,root,755)
@@ -1079,11 +1239,13 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
 #%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
 #%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+%{_datadir}/%{name}/qemu_vga.ndrv
 %{_datadir}/%{name}/u-boot.e500
 
 %files system-s390x
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-s390x
 %{_datadir}/%{name}/u-boot.e500
 
 %files system-s390x
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-s390x
+%{_datadir}/%{name}/s390-netboot.img
 
 %files system-sh4
 %defattr(644,root,root,755)
 
 %files system-sh4
 %defattr(644,root,root,755)
@@ -1107,15 +1269,13 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
-%attr(755,root,root) %{_bindir}/kvm_stat
 %endif
 %{_datadir}/%{name}/bios.bin
 %{_datadir}/%{name}/bios-256k.bin
 %{_datadir}/%{name}/acpi-dsdt.aml
 %endif
 %{_datadir}/%{name}/bios.bin
 %{_datadir}/%{name}/bios-256k.bin
 %{_datadir}/%{name}/acpi-dsdt.aml
-%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -1127,6 +1287,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man8/qemu-ga.8*
 
 %files module-block-curl
 %defattr(644,root,root,755)
 
 %files module-block-curl
 %defattr(644,root,root,755)
This page took 0.052789 seconds and 4 git commands to generate.