]> git.pld-linux.org Git - packages/php-pecl-crack.git/blobdiff - php-pecl-crack.spec
- release 5 (by relup.sh)
[packages/php-pecl-crack.git] / php-pecl-crack.spec
index a8dd0befc5c5f9a4d9b29831ec052c8bbd23b194..de36be949fdc4d1f4c330772cee775f171916e32 100644 (file)
@@ -1,23 +1,26 @@
-%define                _modname        crack
-%define                _status         beta
-Summary:       %{_modname} - checks if password is vulnerable to dictionary attacks
-Summary(pl.UTF-8):     %{_modname} - sprawdzanie czy hasło jest podatne na ataki słownikowe
-Name:          php-pecl-%{_modname}
+# TODO
+# - use system cracklib
+%define                modname crack
+%define                status          beta
+Summary:       %{modname} - checks if password is vulnerable to dictionary attacks
+Summary(pl.UTF-8):     %{modname} - sprawdzanie czy hasło jest podatne na ataki słownikowe
+Name:          php-pecl-%{modname}
 Version:       0.4
 Version:       0.4
-Release:       1
+Release:       5
 License:       PHP
 Group:         Development/Languages/PHP
 License:       PHP
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 7cfe9df99f546cf6bd55b535d71e3b1f
 Patch0:                %{name}-m4_fixes.patch
 # Source0-md5: 7cfe9df99f546cf6bd55b535d71e3b1f
 Patch0:                %{name}-m4_fixes.patch
+Patch1:                fix-pecl-bug-5765.patch
 URL:           http://pecl.php.net/package/crack/
 URL:           http://pecl.php.net/package/crack/
-BuildRequires: cracklib-devel
+#BuildRequires:        cracklib-devel
 BuildRequires: php-devel >= 3:5.0.0
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?requires_php_extension}
 Obsoletes:     php-crack
 Requires:      php-common >= 4:5.0.4
 BuildRequires: php-devel >= 3:5.0.0
 BuildRequires: rpmbuild(macros) >= 1.344
 %{?requires_php_extension}
 Obsoletes:     php-crack
 Requires:      php-common >= 4:5.0.4
-Obsoletes:     php-pear-%{_modname}
+Obsoletes:     php-pear-%{modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -26,7 +29,7 @@ libraries that come standard on most Unix-like distributions. This
 allows you to check passwords against dictionaries of words to ensure
 some minimal level of password security.
 
 allows you to check passwords against dictionaries of words to ensure
 some minimal level of password security.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 Ten pakiet dostarcza interfejsu do bibliotek cracklib (libcrack),
 
 %description -l pl.UTF-8
 Ten pakiet dostarcza interfejsu do bibliotek cracklib (libcrack),
@@ -34,14 +37,15 @@ dostarczanych z większością dystrybucji uniksopodobnych. Pozwala to na
 porównanie haseł względem słowników celem zapewnienia minimalnego
 poziomu bezpieczeństwa.
 
 porównanie haseł względem słowników celem zapewnienia minimalnego
 poziomu bezpieczeństwa.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
 
 %prep
-%setup -q -c
-%patch0 -p0
+%setup -qc
+mv %{modname}-%{version}/* .
+%patch0 -p1
+%patch1 -p1
 
 %build
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
 phpize
 %configure
 %{__make}
@@ -50,10 +54,10 @@ phpize
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
 EOF
 
 %clean
@@ -69,6 +73,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc CREDITS EXPERIMENTAL
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.030904 seconds and 4 git commands to generate.