]> git.pld-linux.org Git - packages/opal.git/blobdiff - opal.spec
- added build.patch (build sections works, hooray!)
[packages/opal.git] / opal.spec
index cfcaec60294cfaa059d19e4bc1066ba32948880d..40472a08c40524fc231665317fa22ffdcb3e0f5f 100644 (file)
--- a/opal.spec
+++ b/opal.spec
+# TODO:
+#      fix static libname (libopal_s.a)
+#      check why:
+#              checking PTLIB has expat... no
+#              checking PTLIB has vxml... no
+#              checking PTLIB has ipv6... no
+#              checking PTLIB has ldap... no
+#      ... and check plugin configuration:
+#                              GSM :  yes (internal)
+#                           H.263+ :  
+#                           H.264  :  no
+#                          THEORA  :  no
+#                    MPEG4 Part 2  :  no
+#                     SpanDSP FAX  :  no
+#                            CAPI  :  no
+#           Quicknet xJACK support :  no
+#
+# Don't touch this! strip removes all symbols from library
+%define                no_install_post_strip           1
+#
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
-Summary(pl):   Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
+Summary(pl.UTF-8):     Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
 Name:          opal
 Name:          opal
-Version:       2.1.3
-Release:       0.2
+Version:       3.4.2
+Release:       0.1
 License:       MPL
 Group:         Libraries
 License:       MPL
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/sourceforge/openh323/%{name}-Phobos_rc1-src-tar.gz
-# Source0-md5: a2b03f4f24b5d9cfc157eed7c82d87d7
-#Source0:      http://www.ekiga.org/downloads/beta2/sources/%{name}-%{version}.tar.gz
-#Patch0:               %{name}-opaldir.patch
+Source0:       http://ftp.gnome.org/pub/gnome/sources/opal/3.4/%{name}-%{version}.tar.bz2
+# Source0-md5: a1d11099fa00d77a79dcfe513872e8dc
+#Source0:      http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
+Patch0:                %{name}-libname.patch
+Patch1:                %{name}-mak_files.patch
+Patch2:                %{name}-ac.patch
+Patch3:                %{name}-build.patch
 URL:           http://www.openh323.org/
 URL:           http://www.openh323.org/
-BuildRequires: pwlib-devel >= 1.9.3-1
-BuildRequires: speex-devel >= 1:1.1.5
+BuildRequires: SDL-devel
+BuildRequires: automake
+BuildRequires: autoconf
 BuildRequires: libstdc++-devel
 BuildRequires: libstdc++-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: ptlib-devel
+BuildRequires: sed >= 4.0
+BuildRequires: speex-devel >= 1:1.1.5
 %requires_eq   pwlib
 %requires_eq   pwlib
-Obsoletes:     openh323
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The OpenH323 project aims to create a full featured, interoperable,
+The OPAL project aims to create a full featured, interoperable,
 Open Source implementation of the ITU H.323 teleconferencing protocol
 that can be used by personal developers and commercial users without
 charge.
 
 Open Source implementation of the ITU H.323 teleconferencing protocol
 that can be used by personal developers and commercial users without
 charge.
 
-%description -l pl
-Celem projektu OpenH323 jest stworzenie w pe³ni funkcjonalnej i
-wyposa¿onej implementacji protoko³u telekonferencyjnego ITU H.323,
-który mo¿e byæ u¿ywany przez u¿ytkowników prywatnych i komercyjnych
-bez op³at.
+%description -l pl.UTF-8
+Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
+wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
+który może być używany przez użytkowników prywatnych i komercyjnych
+bez opłat.
 
 %package devel
 Summary:       Opal development files
 
 %package devel
 Summary:       Opal development files
-Summary(pl):   Pliki dla developerów Opal
+Summary(pl.UTF-8):     Pliki dla developerów Opal
 Group:         Development/Libraries
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
 Requires:      pwlib-devel
 Requires:      libstdc++-devel
 Requires:      pwlib-devel
-Obsoletes:     openh323-devel
 
 %description devel
 Header files and libraries for developing applications that use
 
 %description devel
 Header files and libraries for developing applications that use
-Opal.
+OPAL.
 
 
-%description devel -l pl
-Pliki nag³ówkowe i biblioteki konieczne do rozwoju aplikacji
-u¿ywaj±cych Opal.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
+używających OPAL.
 
 
-#%package static
-#Summary:      Opal static libraries
-#Summary(pl):  Biblioteki statyczne Opal
-#Group:                Development/Libraries
-#Requires:     %{name}-devel = %{version}
-#Obsoletes:    openh323-static
+%package static
+Summary:       OPAL static libraries
+Summary(pl.UTF-8):     Biblioteki statyczne OPAL
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
 
-#%description static
-#OpenH323 static libraries.
+%description static
+OPAL static libraries.
 
 
-#%description static -l pl
-#Biblioteki statyczne OpenH323.
+%description static -l pl.UTF-8
+Biblioteki statyczne OPAL.
 
 %prep
 
 %prep
-%setup -q -n %{name}_Phobos_rc1
-#%patch0 -p1
+%setup -q
+#patch0 -p1
+#patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
-#OPALDESTDIR=%{_prefix}; export OPALDIR
-#OPENH323_BUILD="yes"; export OPENH323_BUILD
-#cp -f /usr/share/automake/config.sub .
+OPALDIR=`pwd`; export OPALDIR
+OPAL_BUILD="yes"; export OPAL_BUILD
+%{__aclocal}
 %{__autoconf}
 %{__autoconf}
-%configure 
-#      --disable-iax
-#touch .asnparser.version
+%configure
 
 
-%{__make}
+%{__make} %{?debug:debug}%{!?debug:opt} \
+       CC="%{__cc}" \
+       CPLUS="%{__cxx}" \
+       OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
 
 
-#%{__make} %{?debug:debug}%{!?debug:opt} \
-#              CC="%{__cc}" CPLUS=%{__cxx} \
-#              PWLIB_MAKE=%{_datadir}/pwlib \
-#              ASNPARSER=%{_bindir}/asnparser \
-#              OPTCCFLAGS="%{rpmcflags}"
-
-#%%{__make} -C samples/simple %{?debug:debugshared}%{!?debug:optshared} \
-#              CC="%{__cc}" CPLUS=%{__cxx} \
-#              OPTCCFLAGS="%{rpmcflags}"
+%{__cp} -a */libopal* .
+%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
+       CC="%{__cc}" \
+       CPLUS=%{__cxx} \
+       CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
+       LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-#install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/openh323,%{_bindir},%{_datadir}/misc}
+install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/opal,%{_bindir},%{_datadir}/%{name}}
 
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
 
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
-#using cp as install won't preserve links
-#cp -d lib/lib* $RPM_BUILD_ROOT%{_libdir}
-#install include/*.h $RPM_BUILD_ROOT%{_includedir}/openh323
-#install version.h $RPM_BUILD_ROOT%{_includedir}/openh323
-#install samples/simple/obj_*/simph323 $RPM_BUILD_ROOT%{_bindir}
-
-#sed -e's@\$(OPALDIR)/include@&/opal@' < opal_inc.mak \
-#      > $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc1.mak
+# using cp as install won't preserve links
+cp -d lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
+install version.h $RPM_BUILD_ROOT%{_includedir}/opal
+install samples/simple/obj_*/simpleopal $RPM_BUILD_ROOT%{_bindir}
+sed -i -e 's@\$(OPALDIR)/include@&/opal@' \
+       -e 's@\$(OPALDIR)/lib@\$(OPALDIR)/%{_lib}@' $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc.mak
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -109,16 +134,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-#%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
 
 %files devel
 %defattr(644,root,root,755)
-#%doc *.txt
 %attr(755,root,root) %{_libdir}/*.so
 %{_includedir}/*
 %{_datadir}/%{name}
 
 %attr(755,root,root) %{_libdir}/*.so
 %{_includedir}/*
 %{_datadir}/%{name}
 
-#%files static
-#%defattr(644,root,root,755)
-#%{_libdir}/*.a
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/*.a
This page took 0.124954 seconds and 4 git commands to generate.