]> git.pld-linux.org Git - packages/lin_tape.git/blobdiff - lin_tape.spec
- fix insecure permission on /proc files (build fails on 3.17)
[packages/lin_tape.git] / lin_tape.spec
index f5e96a2320efbfa619bdd925a067431d656c22e0..06eba4a3cedd24a6a83c2b0b3d067a1767a83035 100644 (file)
@@ -2,22 +2,41 @@
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_with    verbose         # verbose build (V=1)
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_with    verbose         # verbose build (V=1)
-#
-%define                rel     22
+
+%if "%{_alt_kernel}" != "%{nil}"
+%if 0%{?build_kernels:1}
+%{error:alt_kernel and build_kernels are mutually exclusive}
+exit 1
+%endif
+%global                _build_kernels          %{alt_kernel}
+%else
+%global                _build_kernels          %{?build_kernels:,%{?build_kernels}}
+%endif
+
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+
+%define                kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
+%define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
+%define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
+
+%define                rel     1
 %define                pname   lin_tape
 Summary:       IBM Tape SCSI Device Driver for Linux
 Name:          %{pname}%{_alt_kernel}
 %define                pname   lin_tape
 Summary:       IBM Tape SCSI Device Driver for Linux
 Name:          %{pname}%{_alt_kernel}
-Version:       1.76.0
-Release:       %{rel}
+Version:       2.9.1
+Release:       %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL v2/LGPL
 Group:         Base/Kernel
 Source0:       %{pname}-%{version}.tgz
 License:       GPL v2/LGPL
 Group:         Base/Kernel
 Source0:       %{pname}-%{version}.tgz
-# Source0-md5: 7f5a9c0899ffc861f94de3fe216f0caf
+# Source0-md5: 305d2922f942a73f0f0b30fa49b92dd5
 Patch0:                use-module-dir.patch
 Patch0:                use-module-dir.patch
+Patch1:                linux-3.10.patch
+Patch2:                insecure-perms.patch
 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
 URL:           http://www.ibm.com/support/fixcentral/
 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
 URL:           http://www.ibm.com/support/fixcentral/
-%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
-BuildRequires: rpmbuild(macros) >= 1.379
+BuildRequires: rpmbuild(macros) >= 1.678
+%{?with_dist_kernel:%{expand:%kbrs}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -25,24 +44,46 @@ The IBM Tape Device Driver, lin_tape, product is a device driver that
 provides attachment for the IBM TotalStorage and System Storage tape
 devices to Linux compatible platforms.
 
 provides attachment for the IBM TotalStorage and System Storage tape
 devices to Linux compatible platforms.
 
-%package -n kernel%{_alt_kernel}-scsi-lin_tape
-Summary:       IBM Tape SCSI Device Driver for Linux
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel
-Requires(postun):      %releq_kernel
-%endif
+%define        kernel_pkg()\
+%package -n kernel%{_alt_kernel}-scsi-lin_tape\
+Summary:       IBM Tape SCSI Device Driver for Linux\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+Requires(post,postun): /sbin/depmod\
+%if %{with dist_kernel}\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+%endif\
+\
+%description -n kernel%{_alt_kernel}-scsi-lin_tape\
+The IBM Tape Device Driver is a device driver that provides attachment\
+for the IBM TotalStorage and System Storage tape devices to Linux\
+compatible platforms.\
+\
+%post  -n kernel%{_alt_kernel}-scsi-lin_tape\
+%depmod %{_kernel_ver}\
+\
+%postun        -n kernel%{_alt_kernel}-scsi-lin_tape\
+%depmod %{_kernel_ver}\
+\
+%files -n kernel%{_alt_kernel}-scsi-lin_tape\
+%defattr(644,root,root,755)\
+%doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe\
+/lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
+%{nil}
+
+%define build_kernel_pkg()\
+%build_kernel_modules -m lin_tape\
+%install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
+%{nil}
 
 
-%description -n kernel%{_alt_kernel}-scsi-lin_tape
-The IBM Tape Device Driver is a device driver that provides attachment
-for the IBM TotalStorage and System Storage tape devices to Linux
-compatible platforms.
+%{expand:%kpkg}
 
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
 
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 %ifarch %ix86 ia64
 proc="Intel"
 %endif
 %ifarch %ix86 ia64
 proc="Intel"
 %endif
@@ -63,23 +104,13 @@ proc="zSeries"
 %{__cp} -af Makefile.GPL Makefile
 
 %build
 %{__cp} -af Makefile.GPL Makefile
 
 %build
-%build_kernel_modules -m lin_tape
+%{expand:%bkpkg}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT
 
 
-%install_kernel_modules -m lin_tape -d kernel/drivers/scsi
+cp -a installed/* $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
-
-%post  -n kernel%{_alt_kernel}-scsi-lin_tape
-%depmod %{_kernel_ver}
-
-%postun        -n kernel%{_alt_kernel}-scsi-lin_tape
-%depmod %{_kernel_ver}
-
-%files -n kernel%{_alt_kernel}-scsi-lin_tape
-%defattr(644,root,root,755)
-%doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe
-/lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*
This page took 0.086072 seconds and 4 git commands to generate.