]> git.pld-linux.org Git - packages/kf5-sonnet.git/blobdiff - kf5-sonnet.spec
- Up to 5.67.0.
[packages/kf5-sonnet.git] / kf5-sonnet.spec
index cfab67148d3211e4be6a0c40dc0bf665df268300..26271141008087d4eca84d7351657adc0e685ea0 100644 (file)
@@ -1,27 +1,31 @@
 # TODO:
 # - fix build with aspell
 # TODO:
 # - fix build with aspell
-%define                kdeframever     5.39
-%define                qtver           5.3.2
+%define                kdeframever     5.67
+%define                qtver           5.10.0
 %define                kfname          sonnet
 
 Summary:       Multi-language spell checker
 %define                kfname          sonnet
 
 Summary:       Multi-language spell checker
+Summary(pl.UTF-8):     Wielojęzyczne narzędzie do sprawdzania pisowni
 Name:          kf5-%{kfname}
 Name:          kf5-%{kfname}
-Version:       5.39.0
+Version:       5.67.0
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
 Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: a1f3ae89feb7e344c51b5288d12796fa
+# Source0-md5: 37f09137396721abad617571464b9d9a
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= %{qtver}
 BuildRequires: Qt5Test-devel >= %{qtver}
 BuildRequires: Qt5Widgets-devel >= %{qtver}
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Gui-devel >= %{qtver}
 BuildRequires: Qt5Test-devel >= %{qtver}
 BuildRequires: Qt5Widgets-devel >= %{qtver}
+BuildRequires: aspell
 BuildRequires: aspell-devel
 BuildRequires: aspell-devel
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.5
 BuildRequires: hspell-devel
 BuildRequires: hunspell-devel
 BuildRequires: hspell-devel
 BuildRequires: hunspell-devel
-BuildRequires: kf5-extra-cmake-modules >= 1.4.0
+BuildRequires: kf5-extra-cmake-modules >= 5.56
+BuildRequires: libvoikko-devel
+BuildRequires: ninja
 BuildRequires: qt5-linguist >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
 BuildRequires: qt5-linguist >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
@@ -35,7 +39,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Sonnet is a plugin-based spell checking library for Qt-based
 applications. It supports several different plugins, including HSpell,
 %description
 Sonnet is a plugin-based spell checking library for Qt-based
 applications. It supports several different plugins, including HSpell,
-Enchant, ASpell and HUNSPELL.
+ASpell and HUNSPELL.
 
 It also supports automated language detection, based on a combination
 of different algorithms.
 
 It also supports automated language detection, based on a combination
 of different algorithms.
@@ -43,6 +47,17 @@ of different algorithms.
 The simplest way to use Sonnet in your application is to use the
 SpellCheckDecorator class on your QTextEdit.
 
 The simplest way to use Sonnet in your application is to use the
 SpellCheckDecorator class on your QTextEdit.
 
+%description -l pl.UTF-8
+Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
+aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
+HSpell, ASpell i HUNSPELL.
+
+Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
+algorytmów.
+
+Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
+SpellCheckDecorator w obiekcie QTextEdit.
+
 %package devel
 Summary:       Header files for %{kfname} development
 Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
 %package devel
 Summary:       Header files for %{kfname} development
 Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
@@ -61,24 +76,22 @@ Pliki nagłówkowe dla programistów używających %{kfname}.
 %build
 install -d build
 cd build
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 
 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files -f %{kfname}5_qt.lang
 %defattr(644,root,root,755)
 
 %files -f %{kfname}5_qt.lang
 %defattr(644,root,root,755)
@@ -90,12 +103,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
 %dir %{qt5dir}/plugins/kf5/sonnet
 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
 %dir %{qt5dir}/plugins/kf5/sonnet
-#%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
-%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
-%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
-%dir %{_datadir}/kf5/sonnet
-%{_datadir}/kf5/sonnet/trigrams.map
-/etc/xdg/sonnet.categories
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
+%attr(755,root,root) %{qt5dir}/plugins/designer/sonnetui5widgets.so
+%{_datadir}/qlogging-categories5/sonnet.categories
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.036394 seconds and 4 git commands to generate.