]> git.pld-linux.org Git - packages/gai.git/blobdiff - gai.spec
- unified bcond name: gl -> opengl
[packages/gai.git] / gai.spec
index 5c4c57c6d5494e3e506c34ff245ff49a3c904f04..e0463629e3fe5b25c574df4cc51e7dc6b7e86ba0 100644 (file)
--- a/gai.spec
+++ b/gai.spec
@@ -1,29 +1,33 @@
 #
 # Conditional build:
 #
 # Conditional build:
-%bcond_without gl      # without OpenGL support
 %bcond_without gnome   # without GNOME support
 %bcond_without gnome   # without GNOME support
+%bcond_without opengl  # without OpenGL support
 %bcond_without rox     # without ROX support
 %bcond_without sdl     # without SDL support
 #
 Summary:       General Applet Interface library
 %bcond_without rox     # without ROX support
 %bcond_without sdl     # without SDL support
 #
 Summary:       General Applet Interface library
-Summary(pl):   Ogólna biblioteka interfejsu apletu
+Summary(pl.UTF-8):     Ogólna biblioteka interfejsu apletu
 Name:          gai
 Name:          gai
-Version:       0.5.4
+Version:       0.5.8
 Release:       1
 License:       LGPL
 Group:         X11/Libraries
 Release:       1
 License:       LGPL
 Group:         X11/Libraries
-Source0:       http://dl.sourceforge.net/gai/%{name}-%{version}.tar.bz2
-# Source0-md5: 06b67eb1466bc94459ee6fce88d446d0
+Source0:       http://dl.sourceforge.net/sourceforge/gai/%{name}-%{version}.tar.bz2
+# Source0-md5: 29d90cb37fe5341009b27ffd09f871cb
 Patch0:                %{name}-opt.patch
 Patch0:                %{name}-opt.patch
+Patch1:                %{name}-libdir.patch
 URL:           http://gai.sourceforge.net/
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2}
 BuildRequires: autoconf >= 2.53
 URL:           http://gai.sourceforge.net/
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2}
 BuildRequires: autoconf >= 2.53
-%{?with_gl:BuildRequires:      gtkglext-devel >= 1.0}
+%{?with_opengl:BuildRequires:  gtkglext-devel >= 1.0}
 %{?with_gnome:BuildRequires:   gnome-panel-devel >= 2.4.0}
 %{?with_gnome:BuildRequires:   gnome-panel-devel >= 2.4.0}
-BuildRequires: gtk+2-devel >= 2.0
+BuildRequires: gtk+2-devel >= 1:2.0
 BuildRequires: pkgconfig
 %{?with_rox:BuildRequires:     rox >= 2.1}
 BuildRequires: pkgconfig
 %{?with_rox:BuildRequires:     rox >= 2.1}
+%{?with_rox:BuildRequires:     which}
 BuildRequires: zlib-devel
 BuildRequires: zlib-devel
+%{?with_gnome:Provides:        gai(gnome) = %{version}-%{release}}
+%{?with_rox:Provides:  gai(rox) = %{version}-%{release}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
@@ -33,46 +37,57 @@ This library is intended to simplify the development and use of
 dockapps. With this library the programmer can focus on what the
 applet shall do, not on the interface.
 
 dockapps. With this library the programmer can focus on what the
 applet shall do, not on the interface.
 
-%description -l pl
-Zamiarem tej biblioteki jest uproszczenie tworzenia i u¿ywania
-apletów. Przy pomocy tej biblioteki programista mo¿e siê skupiæ na tym
-co aplet powinien robiæ a nie na jego interfejsie.
+%description -l pl.UTF-8
+Zamiarem tej biblioteki jest uproszczenie tworzenia i używania
+apletów. Przy pomocy tej biblioteki programista może się skupić na tym
+co aplet powinien robić a nie na jego interfejsie.
 
 %package devel
 Summary:       Development files for the GAI
 
 %package devel
 Summary:       Development files for the GAI
-Summary(pl):   Pliki rozwojowe dla GAI
+Summary(pl.UTF-8):     Pliki rozwojowe dla GAI
 Group:         X11/Development/Libraries
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-%{?with_gl:Requires:   gtkglext-devel >= 1.0}
-%{?with_gnome:Requires:        gnome-panel-devel >= 2.4.0}
+Requires:      %{name} = %{version}-%{release}
+%if %{with gnome}
+Requires:      gnome-panel-devel >= 2.4.0
+Requires:      gai(gnome) = %{version}-%{release}
+Provides:      gai-devel(gnome) = %{version}-%{release}
+%endif
+%{?with_opengl:Requires:       gtkglext-devel >= 1.0}
+%if %{with rox}
+Requires:      gai(rox) = %{version}-%{release}
+Provides:      gai-devel(rox) = %{version}-%{release}
+%endif
 Requires:      gtk+2-devel >= 2.0
 
 %description devel
 Header files required for development using GAI.
 
 Requires:      gtk+2-devel >= 2.0
 
 %description devel
 Header files required for development using GAI.
 
-%description devel -l pl
-Pliki nag³ówkowe wymagane do tworzenia programów z u¿yciem GAI.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe wymagane do tworzenia programów z użyciem GAI.
 
 %prep
 %setup -q 
 %patch0 -p1
 
 %prep
 %setup -q 
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__autoconf}
 %configure \
 
 %build
 %{__autoconf}
 %configure \
-       %{!?with_gl:--disable-gl} \
+       %{!?with_opengl:--disable-gl} \
        %{!?with_gnome:--disable-gnome} \
        %{!?with_rox:--disable-rox} \
        %{!?with_sdl:--disable-sdl}
 
 %{__make} \
        %{!?with_gnome:--disable-gnome} \
        %{!?with_rox:--disable-rox} \
        %{!?with_sdl:--disable-sdl}
 
 %{__make} \
-       OPT="%{rpmcflags}"
+       OPT="%{rpmcflags} -fPIC"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       PREFIX=$RPM_BUILD_ROOT%{_prefix}
+       DESTDIR=$RPM_BUILD_ROOT \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_libdir}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
This page took 0.053796 seconds and 4 git commands to generate.