]> git.pld-linux.org Git - packages/bird.git/blobdiff - bird.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/bird.git] / bird.spec
index b02508b9e0705563b371c6c037cf94a96bc2f6ad..569725a27589e55835632117c229f9b5886754e3 100644 (file)
--- a/bird.spec
+++ b/bird.spec
@@ -1,6 +1,6 @@
 
 
-%bcond_without ipv6    # disable IPv6 support (and building bird-ipv6 package) 
-%bcond_without ipv4    # disable IPv4 support (and building bird-ipv4 package)
+%bcond_without ipv6    # disable IPv6 support (and building bird-ipv6 package) 
+%bcond_without ipv4    # disable IPv4 support (and building bird-ipv4 package)
 
 # TODO:
 #      - trigger to clean up after old bird package (stop, chkconfig --del)
 
 # TODO:
 #      - trigger to clean up after old bird package (stop, chkconfig --del)
@@ -8,21 +8,23 @@
 Summary:       Routing daemon
 Summary(pl):   Demon dynamicznego routingu
 Name:          bird
 Summary:       Routing daemon
 Summary(pl):   Demon dynamicznego routingu
 Name:          bird
-Version:       1.0.9
-Release:       0.3
+Version:       1.0.11
+Release:       0.1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
 License:       GPL
 Group:         Networking/Daemons
 Source0:       ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
-# Source0-md5: 6a1d94b8a33b80e754ea4f9cc0ac1ff3
+# Source0-md5: 9f9dfe2af0bde45a0adbbd0ebc36f249
 Source1:       %{name}-ipv4.init
 Source2:       %{name}-ipv4.sysconfig
 Source3:       %{name}-ipv6.init
 Source4:       %{name}-ipv6.sysconfig
 Source1:       %{name}-ipv4.init
 Source2:       %{name}-ipv4.sysconfig
 Source3:       %{name}-ipv6.init
 Source4:       %{name}-ipv6.sysconfig
-Patch0:                %{name}-posix.patch
-Patch1:                %{name}-flex.patch
+Patch0:                %{name}-flex.patch
+Patch1:                %{name}-64bit.patch
 URL:           http://bird.network.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 URL:           http://bird.network.cz/
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: bison
+BuildRequires: flex
 BuildRequires: readline-devel >= 4.2
 PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
 BuildRequires: readline-devel >= 4.2
 PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
@@ -65,7 +67,7 @@ UNIX-like systems (but not necessarily limited to them) with full
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
-%description -l pl ipv4
+%description ipv4 -l pl
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
 pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
 protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
 pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
 protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
@@ -91,7 +93,7 @@ UNIX-like systems (but not necessarily limited to them) with full
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
 support of all modern routing protocols, easy to use configuration
 interface and powerful route filtering language.
 
-%description -l pl ipv6
+%description ipv6 -l pl
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
 pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
 protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
 Projekt BIRD ma na celu utworzenie daemona dynamicznego routingu
 pracuj±cego na systemach UNIX z pe³nym wsparciem dla nowoczesnych
 protoko³ów routingu, ³atwym interfejsem konfiguracji i jêzykiem
@@ -166,7 +168,7 @@ if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/%{name}-ipv4 ]; then
                /etc/rc.d/init.d/%{name}-ipv4 stop >&2
        fi
        if [ -f /var/lock/subsys/%{name}-ipv4 ]; then
                /etc/rc.d/init.d/%{name}-ipv4 stop >&2
        fi
-        /sbin/chkconfig --del %{name}-ipv4 >&2
+       /sbin/chkconfig --del %{name}-ipv4 >&2
 fi
 
 %post ipv6
 fi
 
 %post ipv6
@@ -183,7 +185,7 @@ if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/%{name}-ipv6 ]; then
                /etc/rc.d/init.d/%{name}-ipv6 stop >&2
        fi
        if [ -f /var/lock/subsys/%{name}-ipv6 ]; then
                /etc/rc.d/init.d/%{name}-ipv6 stop >&2
        fi
-        /sbin/chkconfig --del %{name}-ipv6 >&2
+       /sbin/chkconfig --del %{name}-ipv6 >&2
 fi
 
 %files
 fi
 
 %files
@@ -196,8 +198,8 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird
 %attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird
 %attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
-%attr(754,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/bird-ipv4
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/bird.conf
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
 %endif
 
 %if %{with ipv6}
 %endif
 
 %if %{with ipv6}
@@ -205,7 +207,7 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird-6
 %attr(755,root,root) %{_sbindir}/birdc-6
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird-6
 %attr(755,root,root) %{_sbindir}/birdc-6
-%attr(754,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/bird-ipv6
-%attr(754,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rc.d/init.d/bird-ipv6
-#%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/bird-6.conf
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rc.d/init.d/bird-ipv6
+#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird-6.conf
 %endif
 %endif
This page took 0.106815 seconds and 4 git commands to generate.