]> git.pld-linux.org Git - packages/apache1-mod_fastcgi.git/blobdiff - apache1-mod_fastcgi.spec
- updated for apache 2.0
[packages/apache1-mod_fastcgi.git] / apache1-mod_fastcgi.spec
index 93cdf626924ec9def23deed061f17cab382cc591..24f13c45e96cd208e07d6cfc614eab0be39295a9 100644 (file)
@@ -1,14 +1,20 @@
+%define        apxs    /usr/sbin/apxs
 Summary:       Support for the FastCGI protocol for apache webserver
 Summary:       Support for the FastCGI protocol for apache webserver
+Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
+Summary(ru):   FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
+Summary(uk):   FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
 Name:          apache-mod_fastcgi
 Name:          apache-mod_fastcgi
-Version:       2.2.10
-Release:       2
-Copyright:     Open Market
+Version:       2.4.0
+Release:       1
+License:       distributable
 Group:         Networking/Daemons
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
+Source0:       http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
+# Source0-md5: e4f5b1b185db4774021163dd0fcd2c56
+Source1:       70_mod_fastcgi.conf
 URL:           http://www.FastCGI.com/
 URL:           http://www.FastCGI.com/
+BuildRequires: %{apxs}
 BuildRequires: apache-devel
 BuildRequires: apache-devel
+Requires(post,preun):  %{apxs}
 Requires:      apache >= 1.3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 Requires:      apache >= 1.3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -21,44 +27,59 @@ FastCGI is a language independent, scalable, open extension to CGI
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
+%description -l pl
+To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
+niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
+du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
+
+%description -l ru
+FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
+×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
+ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
+
+óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
+
+%description -l uk
+FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
+×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
+ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
+
+û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
+
 %prep
 %prep
-%setup -q -n mod_fastcgi_%{version}
+%setup -q -n mod_fastcgi-%{version}
 
 %build
 
 %build
-apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
-strip mod_fastcgi.so
+mv Makefile.AP2 Makefile
+make top_dir=/usr/lib/apache INCLUDES=-I/usr/include/apache
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
-
-install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
-
+libtool --mode=install install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_libexecdir},%{_htmldocdir}}
+libtool --mode=install install mod_fastcgi.la $RPM_BUILD_ROOT%{_libexecdir}
 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
+install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/
 
 
-gzip -9nf docs/LICENSE.TERMS CHANGES
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 
 %post
-%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
 if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+        /etc/rc.d/init.d/httpd restart 1>&2
 else
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+        echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
 fi
 fi
-
 %preun
 if [ "$1" = "0" ]; then
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+        if [ -f /var/lock/subsys/httpd ]; then
+                /etc/rc.d/init.d/httpd restart 1>&2
+        fi
 fi
 fi
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %files
 %defattr(644,root,root,755)
-%doc docs/*.gz *.gz
-%doc %{_htmldocdir}
+%doc docs/LICENSE.TERMS CHANGES
+%doc %{_htmldocdir}/*
 %attr(755,root,root) %{_libexecdir}/*
 %attr(755,root,root) %{_libexecdir}/*
+%config %{_sysconfdir}/httpd/httpd.conf/*.conf
This page took 0.097444 seconds and 4 git commands to generate.