]> git.pld-linux.org Git - packages/CodeIgniter.git/blobdiff - CodeIgniter.spec
use virtual names for php deps
[packages/CodeIgniter.git] / CodeIgniter.spec
index 2cc6e6bd69929ab109d5c968b506c00fd0afb8a7..dfffabf4853450411aea66d98d4aa5711f42fdb8 100644 (file)
@@ -2,12 +2,12 @@
 %include       /usr/lib/rpm/macros.php
 Summary:       A powerful PHP framework with a very small footprint
 Name:          CodeIgniter
 %include       /usr/lib/rpm/macros.php
 Summary:       A powerful PHP framework with a very small footprint
 Name:          CodeIgniter
-Version:       2.0.2
-Release:       0.7
+Version:       2.1.2
+Release:       0.9
 License:       other
 Group:         Development/Languages/PHP
 Source0:       http://www.codeigniter.com/download_files/reactor/%{name}_%{version}.zip
 License:       other
 Group:         Development/Languages/PHP
 Source0:       http://www.codeigniter.com/download_files/reactor/%{name}_%{version}.zip
-# Source0-md5: e75bab8cf27d2fb2483c5bb61b85a524
+# Source0-md5: c7a2980dff2774c97bd38bfbf450d8d5
 Source1:       INSTALL-PLD.txt
 Source2:       codeigniter-install
 URL:           http://codeigniter.com/
 Source1:       INSTALL-PLD.txt
 Source2:       codeigniter-install
 URL:           http://codeigniter.com/
@@ -15,16 +15,16 @@ BuildRequires:      rpm-php-pearprov >= 4.3
 BuildRequires: rpmbuild(macros) >= 1.461
 BuildRequires: sed >= 4.0
 BuildRequires: unzip
 BuildRequires: rpmbuild(macros) >= 1.461
 BuildRequires: sed >= 4.0
 BuildRequires: unzip
-Requires:      php-common >= 4:%{php_min_version}
-Requires:      php-ctype
-Requires:      php-date
-Requires:      php-hash
-Requires:      php-mbstring
-Requires:      php-mysql
-Requires:      php-pcre
-Requires:      php-session
-Requires:      php-simplexml
-Requires:      php-spl
+Requires:      php(core) >= %{php_min_version}
+Requires:      php(ctype)
+Requires:      php(date)
+Requires:      php(hash)
+Requires:      php(mbstring)
+Requires:      php(mysql)
+Requires:      php(pcre)
+Requires:      php(session)
+Requires:      php(simplexml)
+Requires:      php(spl)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -38,6 +38,13 @@ real world of shared hosting accounts and clients with deadlines, and
 if you're tired of ponderously large and thoroughly undocumented
 frameworks.
 
 if you're tired of ponderously large and thoroughly undocumented
 frameworks.
 
+%package doc
+Summary:       CodeIgniter documentation
+Group:         Development/Languages/PHP
+
+%description doc
+CodeIgniter documentation.
+
 %prep
 %setup -q -n %{name}_%{version}
 %{__sed} -i 's,\$application_folder.*=.*,$application_folder = "PLEASE SET TO CORRECT PATH";,' index.php
 %prep
 %setup -q -n %{name}_%{version}
 %{__sed} -i 's,\$application_folder.*=.*,$application_folder = "PLEASE SET TO CORRECT PATH";,' index.php
@@ -45,16 +52,19 @@ frameworks.
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT%{_appdir}
 install -d $RPM_BUILD_ROOT%{_appdir}
-install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
-
 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
 cp -r user_guide/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
 cp -r user_guide/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
-install %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
 install -d $RPM_BUILD_ROOT%{_bindir}
 
 install -d $RPM_BUILD_ROOT%{_bindir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
+install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
+
+find $RPM_BUILD_ROOT%{_datadir}/%{name} -name index.html -delete
+
+rm -rf $RPM_BUILD_ROOT%{_appdir}/application/{cache,core,helpers,hooks,libraries}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -66,6 +76,42 @@ EOF
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc %{_docdir}/%{name}-%{version}
 %attr(755,root,root) %{_bindir}/codeigniter-install
 %attr(755,root,root) %{_bindir}/codeigniter-install
-%{_appdir}
+
+%dir %{_appdir}
+%dir %{_appdir}/application
+%dir %{_appdir}/application/config
+%dir %{_appdir}/application/controllers
+%dir %{_appdir}/application/errors
+%dir %{_appdir}/application/language
+%dir %{_appdir}/application/views
+%dir %{_appdir}/system
+%dir %{_appdir}/system/core
+%dir %{_appdir}/system/database
+%dir %{_appdir}/system/database/drivers
+%dir %{_appdir}/system/fonts
+%dir %{_appdir}/system/helpers
+%dir %{_appdir}/system/language
+%dir %{_appdir}/system/libraries
+
+%{_appdir}/index.php
+%{_appdir}/application/.htaccess
+%{_appdir}/system/.htaccess
+
+%{_appdir}/application/config/*
+%{_appdir}/application/controllers/*
+%{_appdir}/application/errors/*
+%{_appdir}/application/language/*
+%{_appdir}/application/views/*
+
+%{_appdir}/system/core/*
+%{_appdir}/system/database/DB*.php
+%{_appdir}/system/database/drivers/*
+%{_appdir}/system/fonts/*
+%{_appdir}/system/helpers/*
+%{_appdir}/system/language/*
+%{_appdir}/system/libraries/*
+
+%files doc
+%defattr(644,root,root,755)
+%doc %{_docdir}/%{name}-%{version}
This page took 0.414472 seconds and 4 git commands to generate.