]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
f7d60a884bf175bb6fc8bfdbb47ada641aa6ff4a
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.31 $ $Date: 2001-06-29 06:30:30 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        4.0.2
9 Release:        1
10 License:        BSD-like
11 Group:          Applications/Shells
12 Group(de):      Applikationen/Shells
13 Group(pl):      Aplikacje/Pow³oki
14 URL:            http://www.zsh.org/
15 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-tinfo.patch
18 Patch2:         %{name}-addons.patch
19 Patch3:         %{name}-paths.patch
20 Prereq:         grep
21 Prereq:         fileutils
22 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
23 BuildRequires:  ncurses-devel >= 5.1
24 BuildRequires:  glibc-static
25 BuildRequires:  ncurses-static
26 BuildRequires:  texinfo
27 BuildRequires:  autoconf
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _bindir         /bin
31
32 %description
33 zsh is an enhanced version of the Bourne shell with csh additions and
34 most features of ksh, bash, and tcsh.
35
36 %description -l pl
37 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
38 wiêkszo¶æ cech ksh, bash i tcsh.
39
40 %package static
41 Summary:        Statically linked Enhanced bourne shell
42 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
43 Group:          Applications/Shells
44 Group(de):      Applikationen/Shells
45 Group(pl):      Aplikacje/Pow³oki
46 Requires:       %{name} = %{version}
47
48 %description static
49 zsh is an enhanced version of the Bourne shell with csh additions and
50 most features of ksh, bash, and tcsh.
51
52 %description -l pl static
53 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
54 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
55 linkowany.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63
64 %build
65 autoconf
66
67 %configure
68 %{__make}
69 mv -f Src/zsh Src/zsh.static
70
71 %configure \
72         --enable-maildir-support
73 %{__make}
74
75 (cd Doc; makeinfo zsh.texi)
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir}}
80
81 %{__make} install DESTDIR=$RPM_BUILD_ROOT
82
83 install Src/zsh.static  $RPM_BUILD_ROOT%{_bindir}
84 install Doc/zsh.info*   $RPM_BUILD_ROOT%{_infodir}
85
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
87 echo    ". /etc/profile"                > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
88 echo -e "PS1='[%n@%m %~]%(!.#.%\$) '\nbindkey -e >/dev/null 2>&1" > \
89                                           $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
90                                         
91 rm -f Etc/Makefile*
92 gzip -9nf Etc/* README LICENCE ChangeLog META-FAQ
93
94 %post
95 if [ ! -f /etc/shells ]; then
96         echo "%{_bindir}/zsh" >> /etc/shells
97 else
98         grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
99 fi
100 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
101
102 %preun
103 if [ "$1" = "0" ]; then
104         grep -v '^%{_bindir}/zsh$' /etc/shells > /etc/shells.new
105         mv -f /etc/shells.new /etc/shells
106 fi
107
108 %postun
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
110
111 %post static
112 if [ ! -f /etc/shells ]; then
113         echo "%{_bindir}/zsh.static" >> /etc/shells
114 else
115         grep -q '^%{_bindir}/zsh\.static$' /etc/shells || echo "%{_bindir}/zsh.static" >> /etc/shells
116 fi
117
118 %preun static
119 if [ "$1" = "0" ]; then
120         grep -v '^%{_bindir}/zsh\.static$' /etc/shells > /etc/shells.new
121         mv -f /etc/shells.new /etc/shells
122 fi
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %files
128 %defattr(644,root,root,755)
129 %doc *.gz Etc/* Util Functions
130 %attr(755,root,root) %{_bindir}/zsh
131 %config %{_sysconfdir}/*
132 %dir %{_libdir}/zsh
133 %dir %{_libdir}/zsh/%{version}
134 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
135 %{_infodir}/zsh.info*
136 %{_mandir}/man1/zsh*.1*
137
138 %files static
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.09208 seconds and 3 git commands to generate.