]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
73239a35f59b24948fe9b5906cc3eabfe7cf6c4d
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.12 $ $Date: 2000-05-24 16:50:47 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.7
9 %define dev_ver pre-4
10 Release:        3
11 License:        GPL
12 Group:          Shells
13 Group(pl):      Pow³oki
14 Source0:        ftp://ftp.zsh.org/pub/zsh/development/%{name}-%{version}-%{dev_ver}.tar.gz
15 Patch0:         zsh-info.patch
16 Patch1:         zsh-DESTDIR.patch
17 Patch2:         zsh-config2.patch
18 Prereq:         grep
19 Prereq:         gawk
20 Prereq:         sed
21 BuildRequires:  ncurses-devel
22 BuildRequires:  glibc-static
23 BuildRequires:  ncurses-static
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _exec_prefix            /
27
28 %description
29 zsh is an enhanced version of the Bourne shell with csh additions and
30 most features of ksh, bash, and tcsh.
31
32 %description -l pl
33 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
34 wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
35
36 %package static
37 Summary:        Statcly linked Enhanced bourne shell
38 Summary(pl):    Statycznie linkowany Zaawansowany bourne shell 
39 Group:          Shells
40 Group(pl):      Pow³oki
41 Requires:       %{name} = %{version}
42
43 %description static
44 zsh is an enhanced version of the Bourne shell with csh additions and
45 most features of ksh, bash, and tcsh.
46
47 %description -l pl static
48 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
49 wiêkszo¶æ cech pow³ok ksh, bash i tcsh. W tym pakiecie jest statycznie
50 linkowany zsh.
51
52 %prep
53 %setup -q -n %{name}-%{version}-%{dev_ver}
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 #autoconf
59 #LDFLAGS="-static -s"; export LDFLAGS
60 #%configure
61 #make
62 #
63 #mv zsh zsh.static
64
65 LDFLAGS="-s"; export LDFLAGS
66 %configure
67 patch -p1 < %{PATCH2}
68 make
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 make install DESTDIR=$RPM_BUILD_ROOT
74
75 # install zsh.static $RPM_BUILD_ROOT%{_bindir}
76
77 install -d $RPM_BUILD_ROOT%{_sysconfdir}
78 touch   $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
79
80 rm Etc/Makefile*
81 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
82           Etc/* README ChangeLog META-FAQ
83
84 %post
85 if [ ! -f /etc/shells ]; then
86         echo "/bin/zsh" > /etc/shells
87 else
88         if ! grep '^/bin/zsh$' /etc/shells > /dev/null; then
89                 echo "/bin/zsh" >> /etc/shells
90         fi
91 fi
92
93 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
94
95 %postun
96 if [ "$1" = "0" ]; then
97         grep -v /bin/zsh /etc/shells > /etc/shells.new
98         mv /etc/shells.new /etc/shells
99 fi
100
101 # /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
102
103 #%post static
104 #if [ ! -f /etc/shells ]; then
105 #       echo "/bin/zsh.static" > /etc/shells
106 #else
107 #       grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
108 #fi
109 #
110 #%postun static
111 #if [ ! -x /bin/zsh.static ]; then
112 #       grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
113 #       mv /etc/shells.rpm /etc/shells
114 #fi
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
122 %dir %{_libdir}/zsh/%{version}-%{dev_ver}
123 %config %{_sysconfdir}/*
124
125 %attr(755,root,root) %{_bindir}/zsh
126 %attr(755,root,root) %{_libdir}/zsh/%{version}-%{dev_ver}/*
127 %{_mandir}/man1/zsh*.1.gz
128
129 #%files static
130 #%defattr(644,root,root,755)
131 #%attr(755,root,root) %{_bindir}/zsh.static
This page took 0.091163 seconds and 3 git commands to generate.