]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
61a0a4cf2e3d1c7aa85ab22401a7e62aff9ac6b6
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.8 $ $Date: 2000-04-17 06:51:03 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.6
9 %define dev_ver dev-22
10 Release:        3
11 License:        GPL
12 Group:          Shells
13 Group(pl):      Pow³oki
14 Source0:        ftp://ftp.zsh.org/pub/zsh/development/%{name}-%{version}-%{dev_ver}.tar.gz
15 Patch0:         zsh-info.patch
16 Patch1:         zsh-DESTDIR.patch
17 Patch2:         zsh-config2.patch
18 # Prereq:       /usr/sbin/fix-info-dir
19 Prereq:         grep
20 Prereq:         gawk
21 Prereq:         sed
22 BuildRequires:  ncurses-devel
23 BuildRequires:  glibc-static
24 BuildRequires:  ncurses-static
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _exec_prefix            /
28
29 %description
30 zsh is an enhanced version of the Bourne shell with csh additions and most
31 features of ksh, bash, and tcsh.
32
33 %description -l pl
34 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
35 wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
36
37 #%package static
38 #Summary:       Statcly linked Enhanced bourne shell
39 #Summary(pl):   Statycznie linkowany Zaawansowany bourne shell
40 #Group:         Shells
41 #Group(pl):     Pow³oki
42 #Requires:      %{name} = %{version}
43 #
44 #%description static
45 #zsh is an enhanced version of the Bourne shell with csh additions and most
46 #features of ksh, bash, and tcsh.
47 #
48 #%description -l pl static
49 #zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
50 #wiêkszo¶æ cech pow³ok ksh, bash i tcsh. W tym pakiecie jest statycznie
51 #linkowany zsh.
52
53 %prep
54 %setup -q -n %{name}-%{version}-%{dev_ver}
55 %patch0 -p1
56 %patch1 -p1
57
58 %build
59 #autoconf
60 #LDFLAGS="-static -s"; export LDFLAGS
61 #%configure
62 #make
63 #
64 #mv zsh zsh.static
65
66 LDFLAGS="-s"; export LDFLAGS
67 %configure
68 patch -p1 < %{PATCH2}
69 make
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 make install DESTDIR=$RPM_BUILD_ROOT
75
76 # install zsh.static $RPM_BUILD_ROOT%{_bindir}
77
78 install -d $RPM_BUILD_ROOT%{_sysconfdir}
79 touch   $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
80
81 rm Etc/Makefile*
82 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
83           Etc/* README ChangeLog META-FAQ
84
85 %post
86 if [ ! -f /etc/shells ]; then
87         echo "/bin/zsh" > /etc/shells
88 else
89         if ! grep '^/bin/zsh$' /etc/shells > /dev/null; then
90                 echo "/bin/zsh" >> /etc/shells
91         fi
92 fi
93
94 # /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
95
96 %postun
97 if [ "$1" = "0" ]; then
98         grep -v /bin/zsh /etc/shells > /etc/shells.new
99         mv /etc/shells.new /etc/shells
100 fi
101
102 # /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
103
104 #%post static
105 #if [ ! -f /etc/shells ]; then
106 #       echo "/bin/zsh.static" > /etc/shells
107 #else
108 #       grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
109 #fi
110 #
111 #%postun static
112 #if [ ! -x /bin/zsh.static ]; then
113 #       grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
114 #       mv /etc/shells.rpm /etc/shells
115 #fi
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
123 %dir %{_libdir}/zsh/%{version}-%{dev_ver}
124 %config %{_sysconfdir}/*
125
126 %attr(755,root,root) %{_bindir}/zsh
127 %attr(755,root,root) %{_libdir}/zsh/%{version}-%{dev_ver}/*
128 %{_mandir}/man1/zsh*.1.gz
129
130 #%files static
131 #%defattr(644,root,root,755)
132 #%attr(755,root,root) %{_bindir}/zsh.static
This page took 0.09007 seconds and 3 git commands to generate.