]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
30da0bb3b612531e946160fc57488a7f32357429
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.13 $ $Date: 2000-05-31 13:51:43 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.7
9 Release:        1
10 License:        GPL
11 Group:          Shells
12 Group(pl):      Pow³oki
13 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
14 Source1:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}-doc.tar.gz
15 Patch0:         zsh-info.patch
16 Patch1:         zsh-DESTDIR.patch
17 Patch2:         zsh-sys_capability.patch
18 Patch3:         zsh-cap_get_proc.patch
19 Patch4:         zsh-tinfo.patch
20 Patch5:         zsh-addons.patch
21 Prereq:         grep
22 Prereq:         gawk
23 Prereq:         sed
24 BuildRequires:  ncurses-devel
25 BuildRequires:  glibc-static
26 BuildRequires:  ncurses-static
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _exec_prefix            /
30
31 %description
32 zsh is an enhanced version of the Bourne shell with csh additions and
33 most features of ksh, bash, and tcsh.
34
35 %description -l pl
36 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
37 wiêkszo¶æ cech ksh, bash i tcsh.
38
39 %package static
40 Summary:        Statically linked Enhanced bourne shell
41 Summary(pl):     Zaawansowany bourne SHell - linkowany statycznie
42 Group:          Shells
43 Group(pl):      Pow³oki
44 Requires:       %{name} = %{version}
45
46 %description static
47 zsh is an enhanced version of the Bourne shell with csh additions and
48 most features of ksh, bash, and tcsh.
49
50 %description -l pl static
51 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
52 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
53 linkowany.
54
55 %package doc-html
56 Summary:                HTML documentation for zsh      
57 Group:          Shells
58
59 %description doc-html
60 HTML documentation for zsh.
61
62 %package doc-ps
63 Summary:                Postscript version of zsh documentation
64 Group:          Shells
65
66 %description doc-ps
67 Postscript version of zsh documentation.
68
69 %package doc-dvi
70 Summary:                DVI version of zsh documentation
71 Group:          Shells
72
73 %description doc-dvi 
74 DVI version of zsh documentation.
75
76 %prep
77 %setup -q
78 %setup -q -b 1 -D
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82 %patch3 -p1
83 %patch4 -p1
84 %patch5 -p1
85
86 %build
87 autoconf
88
89 LDFLAGS="-static -s"; export LDFLAGS
90 %configure
91 make
92 mv Src/zsh Src/zsh.static
93
94 LDFLAGS="-s"; export LDFLAGS
95 %configure --enable-maildir-support
96 make
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 make install DESTDIR=$RPM_BUILD_ROOT
101
102 install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}
103
104 install -d $RPM_BUILD_ROOT%{_infodir}
105 install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
106
107 install -d $RPM_BUILD_ROOT%{_sysconfdir}
108 touch   $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
109
110 rm Etc/Makefile*
111 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
112           Etc/* README ChangeLog META-FAQ \
113                 $RPM_BUILD_ROOT/%{_infodir}/zsh.info*
114
115 %post
116 if [ ! -f /etc/shells ]; then
117         echo "/bin/zsh" > /etc/shells
118 else
119         if ! grep '^/bin/zsh$' /etc/shells > /dev/null; then
120                 echo "/bin/zsh" >> /etc/shells
121         fi
122 fi
123
124 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
125
126 %postun
127 if [ "$1" = "0" ]; then
128         grep -v /bin/zsh /etc/shells > /etc/shells.new
129         mv /etc/shells.new /etc/shells
130 fi
131
132 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
133
134 %post static
135 if [ ! -f /etc/shells ]; then
136         echo "/bin/zsh.static" > /etc/shells
137 else
138         grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
139 fi
140
141 %postun static
142 if [ ! -x /bin/zsh.static ]; then
143         grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
144         mv /etc/shells.rpm /etc/shells
145 fi
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
153 %doc %{_infodir}/zsh.info*
154 %dir %{_libdir}/zsh/%{version}
155 %config %{_sysconfdir}/*
156
157 %attr(755,root,root) %{_bindir}/zsh
158 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
159 %{_mandir}/man1/zsh*.1.gz
160
161 %files static
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/zsh.static
164
165 %files doc-html
166 %defattr(644,root,root,755)
167 %doc Doc/*html
168
169 %files doc-ps
170 %defattr(644,root,root,755)
171 %doc Doc/*ps
172
173 %files doc-dvi
174 %defattr(644,root,root,755)
175 %doc Doc/*dvi
This page took 0.0801190000000001 seconds and 3 git commands to generate.