]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
2fc5d7f783c2c370176bbd42be50c46117b43a50
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.7 $ $Date: 2000-04-13 19:17:29 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.6
9 %define dev_ver dev-22
10 Release:        3
11 Copyright:      GPL
12 Group:          Shells
13 Group(pl):      Pow³oki
14 Source0: ftp://ftp.zsh.org/pub/zsh/development/%{name}-%{version}-%{dev_ver}.tar.gz
15 Patch0:         zsh-info.patch
16 Patch1:         zsh-DESTDIR.patch
17 Patch2:         zsh-config2.patch
18 # Prereq:               /usr/sbin/fix-info-dir
19 Prereq:         grep
20 Prereq:         gawk
21 Prereq:         sed
22 BuildRequires:  ncurses-devel
23 BuildRequires:  glibc-static
24 BuildRequires:  ncurses-static
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _exec_prefix            /
28
29 %description
30 zsh is an enhanced version of the Bourne shell with csh additions and most
31 features of ksh, bash, and tcsh.
32
33 %description -l pl
34 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
35 wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
36
37 #%package static
38 #Summary:       Statcly linked Enhanced bourne shell
39 #Summary(pl):   Statycznie linkowany Zaawansowany bourne shell
40 #Group:         Shells
41 #Group(pl):     Pow³oki
42 #Requires:      %{name} = %{version}
43 #
44 #%description static
45 #zsh is an enhanced version of the Bourne shell with csh additions and most
46 #features of ksh, bash, and tcsh.
47 #
48 #%description -l pl static
49 #zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
50 #wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
51 #
52 #W tym pakiecie jest statycznie linkowany zsh.
53
54 %prep
55 %setup -q -n %{name}-%{version}-%{dev_ver}
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 #autoconf
61 #LDFLAGS="-static -s"; export LDFLAGS
62 #%configure
63 #make
64 #
65 #mv zsh zsh.static
66
67 LDFLAGS="-s"; export LDFLAGS
68 %configure
69 patch -p1 < %{PATCH2}
70 make
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 make install DESTDIR=$RPM_BUILD_ROOT
76
77 # install zsh.static $RPM_BUILD_ROOT%{_bindir}
78
79 install -d $RPM_BUILD_ROOT/etc
80 touch   $RPM_BUILD_ROOT/etc/{zlogout,zprofile,zshrc,zlogin,zshenv}
81
82 rm Etc/Makefile*
83 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
84           Etc/* README ChangeLog META-FAQ
85
86 %post
87 if [ ! -f /etc/shells ]; then
88         echo "/bin/zsh" > /etc/shells
89 else
90         if ! grep '^/bin/zsh$' /etc/shells > /dev/null; then
91                 echo "/bin/zsh" >> /etc/shells
92         fi
93 fi
94
95 # /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
96
97 %postun
98 if [ "$1" = "0" ]; then
99         grep -v /bin/zsh /etc/shells > /etc/shells.new
100         mv /etc/shells.new /etc/shells
101 fi
102
103 # /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
104
105 #%post static
106 #if [ ! -f /etc/shells ]; then
107 #       echo "/bin/zsh.static" > /etc/shells
108 #else
109 #       grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
110 #fi
111 #
112 #%postun static
113 #if [ ! -x /bin/zsh.static ]; then
114 #       grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
115 #       mv /etc/shells.rpm /etc/shells
116 #fi
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
124 %dir %{_libdir}/zsh/%{version}-%{dev_ver}
125 %config /etc/*
126
127 %attr(755,root,root) %{_bindir}/zsh
128 %attr(755,root,root) %{_libdir}/zsh/%{version}-%{dev_ver}/*
129 %{_mandir}/man1/zsh*.1.gz
130
131 #%files static
132 #%defattr(644,root,root,755)
133 #%attr(755,root,root) %{_bindir}/zsh.static
This page took 0.483641 seconds and 3 git commands to generate.