]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
2.1.11 with updates from 2.1.12-staging branch to build with kernel 6.3
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     2
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.1.11
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  2a7b9d2a487a02d373404c48719488ed
38 Patch0:         initdir.patch
39 Patch1:         am.patch
40 Patch2:         no-Werror.patch
41 Patch3:         staging.patch
42 URL:            https://zfsonlinux.org/
43 BuildRequires:  autoconf >= 2.50
44 BuildRequires:  automake
45 BuildRequires:  libtool
46 BuildRequires:  rpmbuild(macros) >= 1.714
47 %if %{with kernel}
48 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
49 %endif
50 %if %{with userspace}
51 # only for mmap_libaio test command
52 #BuildRequires: libaio-devel
53 BuildRequires:  libblkid-devel
54 BuildRequires:  libselinux-devel
55 BuildRequires:  libtirpc-devel
56 BuildRequires:  libuuid-devel
57 BuildRequires:  openssl-devel
58 BuildRequires:  pam-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  udev-devel
61 BuildRequires:  zlib-devel
62 %if %{with python2}
63 BuildRequires:  python-cffi
64 BuildRequires:  python-modules >= 1:2.6
65 BuildRequires:  python-setuptools
66 %endif
67 %if %{with python3}
68 BuildRequires:  python3-cffi
69 BuildRequires:  python3-modules >= 1:3.4
70 BuildRequires:  python3-setuptools
71 %endif
72 %if %{with python2} || %{with python3}
73 BuildRequires:  rpm-pythonprov
74 %endif
75 %endif
76 Requires:       %{pname}-libs = %{version}-%{release}
77 Obsoletes:      spl < 0.7.9-2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         dracutlibdir    %{_prefix}/lib/dracut
81
82 %description
83 ZFS is an advanced file system and volume manager which was originally
84 developed for Solaris and is now maintained by the Illumos community.
85
86 ZFS on Linux, which is also known as ZoL, is currently feature
87 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
88 ZPL layers.
89
90 %description -l pl.UTF-8
91 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
92 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
93
94 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
95 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
96 SPA, DMU, ZVOL i ZPL.
97
98 %package libs
99 Summary:        ZFS on Linux libraries
100 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
101 License:        CDDL
102 Group:          Libraries
103 Requires(post,postun):  /sbin/ldconfig
104
105 %description libs
106 ZFS on Linux libraries.
107
108 %description libs -l pl.UTF-8
109 Biblioteki ZFS-a dla Linuksa.
110
111 %package devel
112 Summary:        Header files for ZFS libraries
113 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
114 License:        CDDL
115 Group:          Development/Libraries
116 Requires:       %{pname}-libs = %{version}-%{release}
117 Requires:       libselinux-devel
118 Requires:       libtirpc-devel
119 Requires:       libuuid-devel
120 Requires:       zlib-devel
121
122 %description devel
123 Header files for ZFS libraries.
124
125 %description devel -l pl.UTF-8
126 Pliki nagłówkowe bibliotek ZFS-a.
127
128 %package static
129 Summary:        Static ZFS libraries
130 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
131 License:        CDDL
132 Group:          Development/Libraries
133 Requires:       %{pname}-devel = %{version}-%{release}
134
135 %description static
136 Static ZFS libraries.
137
138 %description static -l pl.UTF-8
139 Statyczne biblioteki ZFS-a.
140
141 %package -n dracut-zfs
142 Summary:        ZFS support for Dracut
143 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
144 Group:          Applications/System
145 Requires:       %{pname} = %{version}-%{release}
146 Requires:       dracut
147
148 %description -n dracut-zfs
149 ZFS support for Dracut.
150
151 %description -n dracut-zfs -l pl.UTF-8
152 Obsługa ZFS-a dla Dracuta.
153
154 %package -n pam-pam_zfs_key
155 Summary:        PAM module to unlock ZFS datasets for user
156 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
157 Group:          Libraries
158 Requires:       %{pname}-libs = %{version}-%{release}
159 Requires:       pam
160
161 %description -n pam-pam_zfs_key
162 PAM module to unlock ZFS datasets for user.
163
164 %description -n pam-pam_zfs_key -l pl.UTF-8
165 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
166
167 %package -n python-pyzfs
168 Summary:        Python 2 wrapper for libzfs_core C library
169 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
170 License:        Apache v2.0
171 Group:          Libraries/Python
172 Requires:       %{pname}-libs = %{version}-%{release}
173
174 %description -n python-pyzfs
175 Python 2 wrapper for libzfs_core C library.
176
177 %description -n python-pyzfs -l pl.UTF-8
178 Interfejs Pythona 2 do biblioteki C libzfs_core.
179
180 %package -n python3-pyzfs
181 Summary:        Python 3 wrapper for libzfs_core C library
182 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
183 License:        Apache v2.0
184 Group:          Libraries/Python
185 Requires:       %{pname}-libs = %{version}-%{release}
186
187 %description -n python3-pyzfs
188 Python 3 wrapper for libzfs_core C library.
189
190 %description -n python3-pyzfs -l pl.UTF-8
191 Interfejs Pythona 3 do biblioteki C libzfs_core.
192
193 %package -n kernel-zfs-common-devel
194 Summary:        ZFS Linux kernel headers
195 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
196 Group:          Development/Building
197 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
198
199 %description -n kernel-zfs-common-devel
200 ZFS Linux kernel headers common for all PLD kernel versions.
201
202 %description -n kernel-zfs-common-devel -l pl.UTF-8
203 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
204 wersji jąder PLD.
205
206 %define kernel_pkg()\
207 %package -n kernel%{_alt_kernel}-zfs\
208 Summary:        ZFS Linux kernel modules\
209 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
210 Release:        %{rel}@%{_kernel_ver_str}\
211 Group:          Base/Kernel\
212 Requires(post,postun):  /sbin/depmod\
213 %requires_releq_kernel\
214 Requires(postun):       %releq_kernel\
215 \
216 %description -n kernel%{_alt_kernel}-zfs\
217 ZFS Linux kernel modules.\
218 \
219 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
220 ZFS - moduły jądra Linuksa.\
221 \
222 %package -n kernel%{_alt_kernel}-zfs-devel\
223 Summary:        ZFS Linux kernel headers\
224 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
225 Release:        %{rel}@%{_kernel_ver_str}\
226 Group:          Development/Building\
227 Requires:       kernel%{_alt_kernel}-headers\
228 Requires:       kernel-zfs-common-devel\
229 Obsoletes:      kernel-spl-devel < 0.7.9-2\
230 \
231 %description -n kernel%{_alt_kernel}-zfs-devel\
232 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
233 version %{_kernel_ver}.\
234 \
235 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
236 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
237 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
238 \
239 %files -n kernel%{_alt_kernel}-zfs\
240 %defattr(644,root,root,755)\
241 %dir /lib/modules/%{_kernel_ver}/misc/lua\
242 /lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
243 %dir /lib/modules/%{_kernel_ver}/misc/avl\
244 /lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
245 %dir /lib/modules/%{_kernel_ver}/misc/icp\
246 /lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
247 %dir /lib/modules/%{_kernel_ver}/misc/nvpair\
248 /lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
249 %dir /lib/modules/%{_kernel_ver}/misc/spl\
250 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
251 %dir /lib/modules/%{_kernel_ver}/misc/unicode\
252 /lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
253 %dir /lib/modules/%{_kernel_ver}/misc/zcommon\
254 /lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
255 %dir /lib/modules/%{_kernel_ver}/misc/zfs\
256 /lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
257 %dir /lib/modules/%{_kernel_ver}/misc/zstd\
258 /lib/modules/%{_kernel_ver}/misc/zstd/zzstd.ko*\
259 \
260 %files -n kernel%{_alt_kernel}-zfs-devel\
261 %defattr(644,root,root,755)\
262 /usr/src/zfs-%{version}/%{_kernel_ver}\
263 \
264 %post   -n kernel%{_alt_kernel}-zfs\
265 %depmod %{_kernel_ver}\
266 \
267 %postun -n kernel%{_alt_kernel}-zfs\
268 %depmod %{_kernel_ver}\
269 %{nil}
270
271 %define build_kernel_pkg()\
272 %configure \\\
273         --disable-silent-rules \\\
274         --with-config="kernel" \\\
275         --with-linux=%{_kernelsrcdir}\\\
276         --with-linux-obj=%{_kernelsrcdir}\
277 \
278 %{__make} clean\
279 %{__make} %{?with_verbose:V=1}\
280 p=`pwd`\
281 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
282 %{nil}
283
284 %{?with_kernel:%{expand:%create_kernel_packages}}
285
286 %prep
287 %setup -q -n %{pname}-%{version}
288 %patch0 -p1
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292
293 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
294       cmd/arc_summary/arc_summary3
295
296 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
297       cmd/arcstat/arcstat.in \
298       cmd/dbufstat/dbufstat.in
299
300 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
301       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
302       contrib/dracut/90zfs/module-setup.sh.in \
303       scripts/zimport.sh \
304       scripts/zloop.sh
305
306 %build
307 %{__libtoolize}
308 %{__aclocal} -I config
309 %{__autoconf}
310 %{__autoheader}
311 %{__automake}
312 %{?with_kernel:%{expand:%build_kernel_packages}}
313
314 %if %{with userspace}
315 %configure \
316         --disable-silent-rules \
317         --enable-pam \
318         --enable-systemd \
319         --with-config="user" \
320         --with-linux=%{_kernelsrcdir} \
321         --with-pammoduledir=/%{_lib}/security \
322         --with-systemdunitdir=%{systemdunitdir} \
323         --with-systemdpresetdir=/etc/systemd/system-preset \
324         --with-systemdmodulesloaddir=/etc/modules-load.d \
325         --with-systemdgeneratordir=/lib/systemd/system-generators \
326         --with-udevdir=/lib/udev
327
328 %{__make} \
329         %{?with_verbose:V=1}
330
331 %if %{with python2}
332 cd contrib/pyzfs
333 %py_build
334 cd ../..
335 %endif
336
337 %if %{with python3}
338 cd contrib/pyzfs
339 %py3_build
340 cd ../..
341 %endif
342 %endif
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346
347 %if %{with kernel}
348 install -d $RPM_BUILD_ROOT
349 cp -a installed/* $RPM_BUILD_ROOT
350 # Drop unneeded spl compat links
351 %{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
352 %endif
353
354 %if %{with userspace}
355 %{__make} install \
356         DESTDIR=$RPM_BUILD_ROOT \
357         DEFAULT_INIT_DIR=/etc/rc.d/init.d
358
359 %if %{with python2}
360 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
361 cd contrib/pyzfs
362 %py_install
363
364 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
365 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
366
367 %py_postclean
368 cd ../..
369 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
370 %endif
371
372 %if %{with python3}
373 cd contrib/pyzfs
374 %py3_install
375 cd ../..
376 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
377 %endif
378
379 # Debian specific stuff
380 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
381
382 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
383 # Ubuntu PAM config framework file
384 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
385
386 # Package these? These are integration tests of the implementation.
387 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
388 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
389 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
390 %endif
391
392 %clean
393 rm -rf $RPM_BUILD_ROOT
394
395 %post   libs -p /sbin/ldconfig
396 %postun libs -p /sbin/ldconfig
397
398 %if %{with userspace}
399 %files
400 %defattr(644,root,root,755)
401 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
402 %attr(755,root,root) /sbin/mount.zfs
403 %attr(755,root,root) %{_bindir}/arc_summary
404 %attr(755,root,root) %{_bindir}/arcstat
405 %attr(755,root,root) %{_bindir}/dbufstat
406 %attr(755,root,root) %{_bindir}/zvol_wait
407 %attr(755,root,root) %{_sbindir}/fsck.zfs
408 %attr(755,root,root) %{_sbindir}/zdb
409 %attr(755,root,root) %{_sbindir}/zed
410 %attr(755,root,root) %{_sbindir}/zfs
411 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
412 %attr(755,root,root) %{_sbindir}/zgenhostid
413 %attr(755,root,root) %{_sbindir}/zhack
414 %attr(755,root,root) %{_sbindir}/zinject
415 %attr(755,root,root) %{_sbindir}/zpool
416 %attr(755,root,root) %{_sbindir}/zstream
417 %attr(755,root,root) %{_sbindir}/zstreamdump
418 %attr(755,root,root) %{_sbindir}/ztest
419 %dir %{_sysconfdir}/zfs
420 # package *.example as %doc? (they cannot act as default configuration)
421 %{_sysconfdir}/zfs/vdev_id.conf.*.example
422 %dir %{_sysconfdir}/zfs/zed.d
423 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
424 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
425 %dir %{_sysconfdir}/zfs/zpool.d
426 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
427 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
428 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
429 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
430 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
431 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
432 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
433 /etc/zfs/zfs-functions
434 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
435 # for zpool iostat/status -c smart
436 #/ets/sudoers.d/zfs
437 /etc/systemd/system-preset/50-zfs.preset
438 /lib/systemd/system-generators/zfs-mount-generator
439 %{systemdunitdir}/zfs.target
440 %{systemdunitdir}/zfs-import.service
441 %{systemdunitdir}/zfs-import.target
442 %{systemdunitdir}/zfs-import-cache.service
443 %{systemdunitdir}/zfs-import-scan.service
444 %{systemdunitdir}/zfs-load-key.service
445 %{systemdunitdir}/zfs-mount.service
446 %{systemdunitdir}/zfs-scrub@.service
447 %{systemdunitdir}/zfs-scrub-monthly@.timer
448 %{systemdunitdir}/zfs-scrub-weekly@.timer
449 %{systemdunitdir}/zfs-share.service
450 %{systemdunitdir}/zfs-volume-wait.service
451 %{systemdunitdir}/zfs-volumes.target
452 %{systemdunitdir}/zfs-zed.service
453 %attr(755,root,root) /lib/udev/vdev_id
454 %attr(755,root,root) /lib/udev/zvol_id
455 /lib/udev/rules.d/60-zvol.rules
456 /lib/udev/rules.d/69-vdev.rules
457 /lib/udev/rules.d/90-zfs.rules
458 %dir %{_libexecdir}/zfs
459 %dir %{_libexecdir}/zfs/zed.d
460 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
461 %dir %{_libexecdir}/zfs/zpool.d
462 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
463 %dir %{_datadir}/zfs
464 %attr(755,root,root) %{_datadir}/zfs/*.sh
465 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
466 %{_datadir}/zfs/compatibility.d
467 %{_mandir}/man1/arcstat.1*
468 %{_mandir}/man1/zhack.1*
469 %{_mandir}/man1/ztest.1*
470 %{_mandir}/man1/zvol_wait.1*
471 %{_mandir}/man4/spl.4*
472 %{_mandir}/man4/zfs.4*
473 %{_mandir}/man5/vdev_id.conf.5*
474 %{_mandir}/man7/zfsconcepts.7*
475 %{_mandir}/man7/zfsprops.7*
476 %{_mandir}/man7/zpool-features.7*
477 %{_mandir}/man7/zpoolconcepts.7*
478 %{_mandir}/man7/zpoolprops.7*
479 %{_mandir}/man8/fsck.zfs.8*
480 %{_mandir}/man8/mount.zfs.8*
481 %{_mandir}/man8/vdev_id.8*
482 %{_mandir}/man8/zdb.8*
483 %{_mandir}/man8/zed.8*
484 %{_mandir}/man8/zfs.8*
485 %{_mandir}/man8/zfs-allow.8*
486 %{_mandir}/man8/zfs-bookmark.8*
487 %{_mandir}/man8/zfs-change-key.8*
488 %{_mandir}/man8/zfs-clone.8*
489 %{_mandir}/man8/zfs-create.8*
490 %{_mandir}/man8/zfs-destroy.8*
491 %{_mandir}/man8/zfs-diff.8*
492 %{_mandir}/man8/zfs-get.8*
493 %{_mandir}/man8/zfs-groupspace.8*
494 %{_mandir}/man8/zfs-hold.8*
495 %{_mandir}/man8/zfs-inherit.8*
496 %{_mandir}/man8/zfs-jail.8*
497 %{_mandir}/man8/zfs-list.8*
498 %{_mandir}/man8/zfs-load-key.8*
499 %{_mandir}/man8/zfs-mount.8*
500 %{_mandir}/man8/zfs-mount-generator.8*
501 %{_mandir}/man8/zfs-program.8*
502 %{_mandir}/man8/zfs-project.8*
503 %{_mandir}/man8/zfs-projectspace.8*
504 %{_mandir}/man8/zfs-promote.8*
505 %{_mandir}/man8/zfs-receive.8*
506 %{_mandir}/man8/zfs-recv.8*
507 %{_mandir}/man8/zfs-redact.8*
508 %{_mandir}/man8/zfs-release.8*
509 %{_mandir}/man8/zfs-rename.8*
510 %{_mandir}/man8/zfs-rollback.8*
511 %{_mandir}/man8/zfs-send.8*
512 %{_mandir}/man8/zfs-set.8*
513 %{_mandir}/man8/zfs-share.8*
514 %{_mandir}/man8/zfs-snapshot.8*
515 %{_mandir}/man8/zfs-unallow.8*
516 %{_mandir}/man8/zfs-unjail.8*
517 %{_mandir}/man8/zfs-unload-key.8*
518 %{_mandir}/man8/zfs-unmount.8*
519 %{_mandir}/man8/zfs-upgrade.8*
520 %{_mandir}/man8/zfs-userspace.8*
521 %{_mandir}/man8/zfs-wait.8*
522 %{_mandir}/man8/zfs_ids_to_path.8*
523 %{_mandir}/man8/zgenhostid.8*
524 %{_mandir}/man8/zinject.8*
525 %{_mandir}/man8/zpool.8*
526 %{_mandir}/man8/zpool-add.8*
527 %{_mandir}/man8/zpool-attach.8*
528 %{_mandir}/man8/zpool-checkpoint.8*
529 %{_mandir}/man8/zpool-clear.8*
530 %{_mandir}/man8/zpool-create.8*
531 %{_mandir}/man8/zpool-destroy.8*
532 %{_mandir}/man8/zpool-detach.8*
533 %{_mandir}/man8/zpool-events.8*
534 %{_mandir}/man8/zpool-export.8*
535 %{_mandir}/man8/zpool-get.8*
536 %{_mandir}/man8/zpool-history.8*
537 %{_mandir}/man8/zpool-import.8*
538 %{_mandir}/man8/zpool-initialize.8*
539 %{_mandir}/man8/zpool-iostat.8*
540 %{_mandir}/man8/zpool-labelclear.8*
541 %{_mandir}/man8/zpool-list.8*
542 %{_mandir}/man8/zpool-offline.8*
543 %{_mandir}/man8/zpool-online.8*
544 %{_mandir}/man8/zpool-reguid.8*
545 %{_mandir}/man8/zpool-remove.8*
546 %{_mandir}/man8/zpool-reopen.8*
547 %{_mandir}/man8/zpool-replace.8*
548 %{_mandir}/man8/zpool-resilver.8*
549 %{_mandir}/man8/zpool-scrub.8*
550 %{_mandir}/man8/zpool-set.8*
551 %{_mandir}/man8/zpool-split.8*
552 %{_mandir}/man8/zpool-status.8*
553 %{_mandir}/man8/zpool-sync.8*
554 %{_mandir}/man8/zpool-trim.8*
555 %{_mandir}/man8/zpool-upgrade.8*
556 %{_mandir}/man8/zpool-wait.8*
557 %{_mandir}/man8/zpool_influxdb.8*
558 %{_mandir}/man8/zstream.8*
559 %{_mandir}/man8/zstreamdump.8*
560
561 %files libs
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
565 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
567 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
569 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
571 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
573 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
575
576 %files devel
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libnvpair.so
579 %attr(755,root,root) %{_libdir}/libuutil.so
580 %attr(755,root,root) %{_libdir}/libzfs.so
581 %attr(755,root,root) %{_libdir}/libzfs_core.so
582 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
583 %attr(755,root,root) %{_libdir}/libzpool.so
584 %{_libdir}/libnvpair.la
585 %{_libdir}/libuutil.la
586 %{_libdir}/libzfs.la
587 %{_libdir}/libzfs_core.la
588 %{_libdir}/libzfsbootenv.la
589 %{_libdir}/libzpool.la
590 %{_includedir}/libspl
591 %{_includedir}/libzfs
592 %{_pkgconfigdir}/libzfs.pc
593 %{_pkgconfigdir}/libzfs_core.pc
594 %{_pkgconfigdir}/libzfsbootenv.pc
595
596 %files static
597 %defattr(644,root,root,755)
598 %{_libdir}/libnvpair.a
599 %{_libdir}/libuutil.a
600 %{_libdir}/libzfs.a
601 %{_libdir}/libzfs_core.a
602 %{_libdir}/libzfsbootenv.a
603 %{_libdir}/libzpool.a
604
605 %files -n dracut-zfs
606 %defattr(644,root,root,755)
607 %doc contrib/dracut/README.dracut.markdown
608 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
609 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
610 %dir %{dracutlibdir}/modules.d/90zfs
611 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
612 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
613 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
614 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
615 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
616 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
617 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
618 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
619 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
620 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
621 %{dracutlibdir}/modules.d/90zfs/zfs-nonroot-necessities.service
622 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
623 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
624 %{_mandir}/man7/dracut.zfs.7*
625
626 %files -n pam-pam_zfs_key
627 %defattr(644,root,root,755)
628 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
629
630 %if %{with python2}
631 %files -n python-pyzfs
632 %defattr(644,root,root,755)
633 %doc contrib/pyzfs/README
634 %{py_sitescriptdir}/libzfs_core
635 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
636 %endif
637
638 %if %{with python3}
639 %files -n python3-pyzfs
640 %defattr(644,root,root,755)
641 %doc contrib/pyzfs/README
642 %{py3_sitescriptdir}/libzfs_core
643 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
644 %endif
645 %endif
646
647 %if %{with kernel}
648 %files -n kernel-zfs-common-devel
649 %defattr(644,root,root,755)
650 %dir /usr/src/zfs-%{version}
651 /usr/src/zfs-%{version}/include
652 /usr/src/zfs-%{version}/zfs.release
653 /usr/src/zfs-%{version}/zfs_config.h
654 %endif
This page took 0.103528 seconds and 3 git commands to generate.