]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
- do not regenerate configure script (or fix autoconf cause it's broken)
[packages/zabbix.git] / zabbix.spec
1 #
2 # Conditional build:
3 %bcond_with pgsql       # enable postgresql support (by default use mysql)
4
5 %define _beta   beta10
6 Summary:        zabbix - network monitoring software
7 Summary(pl):    zabbix - oprogramowanie do monitorowania sieci
8 Name:           zabbix
9 Version:        1.0
10 Release:        0.%{_beta}.0.1
11 License:        GPL v2+
12 Group:          Networking/Admin
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
14 # Source0-md5:  6d1fd1c4e8166ceffa730060583d4014
15 Source1:        %{name}-agent.inetd
16 Source2:        %{name}-trapper.inetd
17 URL:            http://zabbix.sourceforge.net/
18 %{!?with_pgsql:BuildRequires:   mysql-devel}
19 %{?with_pgsql:BuildRequires:    postgresql-devel}
20 BuildRequires:  net-snmp-devel
21 BuildRequires:  openssl-devel >= 0.9.7c
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _sysconfdir     /etc/%{name}
25
26 %description
27 zabbix is software that monitors numerous parameters of a network and
28 the servers on that network. zabbix is a useful tool for monitoring
29 the health and integrity of servers. zabbix uses a flexible
30 notification mechanism that allows users to configure email based
31 alerts for virtually any event. All monitored parameters are stored in
32 a database. zabbix offers excellent reporting and data visualisation
33 features based on the stored data. zabbix supports both polling and
34 trapping. All zabbix reports and statistics, as well as configuration
35 parameters, are accessed through a web-based front end.
36
37 %description -l pl
38 zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
39 serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
40 dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
41 powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
42 poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
43 parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
44 przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
45 zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
46 wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
47 interfejs oparty o WWW.
48
49 %package frontend-php
50 Summary:        PHP frontend for zabbix
51 Summary(pl):    Interfejs PHP dla zabbiksa
52 Group:          Networking/Admin
53 Requires:       apache
54 Requires:       php
55
56 %description frontend-php
57 This package provides web based (PHP) frontend for zabbix.
58
59 %description frontend-php -l pl
60 Ten pakiet dostarcza napisany w PHP frontend dla zabbiksa.
61
62 %package agent-inetd
63 Summary:        inetd agent for zabbix
64 Summary(pl):    Wersja inetd agenta zabbiksa
65 Group:          Networking/Admin
66 Requires:       %{name}
67 Requires:       inetdaemon
68 Obsoletes:      %{name}-agent-standalone
69
70 %description agent-inetd
71 This package provides inetd version of zabbix agent.
72
73 %description agent-inetd -l pl
74 Ten pakiet dostarcza agenta zabbiksa dla inetd.
75
76 %package agent-standalone
77 Summary:        Standalone agent for zabbix
78 Summary(pl):    Wersja wolnostoj±ca agenta zabbiksa
79 Group:          Networking/Admin
80 Requires:       %{name}
81 Obsoletes:      %{name}-agent-inetd
82
83 %description agent-standalone
84 This package provides standalone version of zabbix agent.
85
86 %description agent-standalone -l pl
87 Ten pakiet dostarcza wolnostoj±cej wersji agenta zabbiksa.
88
89 %package suckerd
90 Summary:        sucker daemon for zabbix
91 Group:          Networking/Admin
92 Requires:       %{name}
93 %{!?with_pgsql:Requires:        mysql}
94 %{?with_pgsql:Requires: postgresql}
95
96 %description suckerd
97 This package provides the sucker daemon for zabbix.
98
99 %package trapper-inetd
100 Summary:        inetd trapper for zabbix
101 Summary(pl):    Wersja inetd programu pu³apkuj±cego zabbiksa
102 Group:          Networking/Admin
103 Requires:       %{name}
104 Requires:       inetdaemon
105 Obsoletes:      %{name}-trapper-standalone
106
107 %description trapper-inetd
108 This package provides inetd version of zabbix trapper.
109
110 %package trapper-standalone
111 Summary:        Standalone trapper for zabbix
112 Summary(pl):    Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
113 Group:          Networking/Admin
114 Requires:       %{name}
115 Obsoletes:      %{name}-trapper-inetd
116
117 %description trapper-standalone
118 This package provides standalone version of zabbix trapper.
119
120 %package sender
121 Summary:        zabbix's sender
122 Summary(pl):    Program zawiadamiaj±cy zabbiksa
123 Group:          Networking/Admin
124
125 %description sender
126 This package provides the zabbix sender.
127
128 %prep
129 %setup -q -n %{name}-%{version}%{_beta}
130
131 %build
132 %configure \
133         %{!?with_pgsql:--with-mysql} \
134         %{?with_pgsql:--with-pgsql} \
135         --with-net-snmp
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd,%{_sbindir},/home/services/html/zabbix}
142
143 install bin/zabbix_* $RPM_BUILD_ROOT%{_sbindir}
144 install misc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}
145 cp -r frontends/php/* $RPM_BUILD_ROOT/home/services/html/zabbix
146
147 install %SOURCE1 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-agent
148 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %pre
154 if [ -z "`/usr/bin/getgid zabbix`" ]; then
155         /usr/sbin/groupadd zabbix
156 fi
157 if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
158         /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
159 fi
160
161 %postun
162 if [ "$1" = "0" ]; then
163         /usr/sbin/userdel zabbix
164         /usr/sbin/groupdel zabbix
165 fi
166
167 %post agent-inetd
168 if [ -f /var/lock/subsys/rc-inetd ]; then
169         /etc/rc.d/init.d/rc-inetd reload
170 else
171         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
172 fi
173
174 %postun agent-inetd
175 if [ -f /var/lock/subsys/rc-inetd ]; then
176         /etc/rc.d/init.d/rc-inetd reload
177 fi
178
179 %post trapper-inetd
180 if [ -f /var/lock/subsys/rc-inetd ]; then
181         /etc/rc.d/init.d/rc-inetd reload
182 else
183         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
184 fi
185
186 %postun trapper-inetd
187 if [ -f /var/lock/subsys/rc-inetd ]; then
188         /etc/rc.d/init.d/rc-inetd reload
189 fi
190
191 %files
192 %defattr(644,root,root,755)
193 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
194 %attr(750,root,zabbix) %dir %{_sysconfdir}
195
196 %files frontend-php
197 %defattr(644,root,root,755)
198 /home/services/html/zabbix
199
200 %files agent-inetd
201 %defattr(644,root,root,755)
202 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent.conf
203 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-agent
204 %attr(755,root,root) %{_sbindir}/zabbix_agent
205
206 %files agent-standalone
207 %defattr(644,root,root,755)
208 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
209 %attr(755,root,root) %{_sbindir}/zabbix_agentd
210
211 %files suckerd
212 %defattr(644,root,root,755)
213 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_suckerd.conf
214 %attr(755,root,root) %{_sbindir}/zabbix_suckerd
215
216 %files trapper-inetd
217 %defattr(644,root,root,755)
218 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapper.conf
219 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-trapper
220 %attr(755,root,root) %{_sbindir}/zabbix_trapper
221
222 %files trapper-standalone
223 %defattr(644,root,root,755)
224 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapperd.conf
225 %attr(755,root,root) %{_sbindir}/zabbix_trapperd
226
227 %files sender
228 %defattr(644,root,root,755)
229 %attr(755,root,root) %{_sbindir}/zabbix_sender
This page took 0.074792 seconds and 4 git commands to generate.