]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
- added some more descriptions
[packages/zabbix.git] / zabbix.spec
1 #
2 # Conditional build:
3 # _with_pgsql - enable postgresql support (by default use mysql)
4 #
5 %define _beta   beta8
6 Summary:        zabbix - network monitoring software
7 Summary(pl):    zabbix - oprogramowanie do monitorowania sieci
8 Name:           zabbix
9 Version:        1.0
10 Release:        0.%{_beta}.0.1
11 License:        GPL v2+
12 Group:          Networking/Admin
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
14 # Source0-md5:  ed691c777df63aa6081dde750f10e733
15 Source1:        %{name}-agent.inetd
16 Source2:        %{name}-trapper.inetd
17 URL:            http://zabbix.sourceforge.net/
18 %{!?_with_pgsql:BuildRequires:  mysql-devel}
19 %{?_with_pgsql:BuildRequires:   postgresql-devel}
20 BuildRequires:  ucd-snmp-devel
21 BuildRequires:  openssl-devel >= 0.9.6j
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _sysconfdir     /etc/%{name}
25
26 %description
27 zabbix is software that monitors numerous parameters of a network and
28 the servers on that network. zabbix is a useful tool for monitoring
29 the health and integrity of servers. zabbix uses a flexible
30 notification mechanism that allows users to configure email based
31 alerts for virtually any event. All monitored parameters are stored in
32 a database. zabbix offers excellent reporting and data visualisation
33 features based on the stored data. zabbix supports both polling and
34 trapping. All zabbix reports and statistics, as well as configuration
35 parameters, are accessed through a web-based front end.
36
37 %description -l pl
38 zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
39 serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
40 dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
41 powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
42 poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
43 parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
44 przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
45 zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
46 wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
47 interfejs oparty o WWW.
48
49 %package frontend-php
50 Summary:        PHP frontend for zabbix
51 Summary(pl):    Interfejs PHP dla zabbiksa
52 Group:          Networking/Admin
53 Requires:       apache
54 Requires:       php
55
56 %description frontend-php
57 This package provides web based (PHP) frontend for zabbix.
58
59 %description -l pl frontend-php
60 Ten pakiet dostarcza napisany w PHP frontend dla zabbiksa.
61
62 %package agent-inetd
63 Summary:        inetd agent for zabbix
64 Summary(pl):    Wersja inetd agenta zabbiksa
65 Group:          Networking/Admin
66 Requires:       %{name}
67 Requires:       inetdaemon
68 Obsoletes:      %{name}-agent-standalone
69
70 %description agent-inetd
71 This package provides inetd version of zabbix agent.
72
73 %description -l pl agent-inetd
74 Ten pakiet dostarcza agenta zabbiksa dla inetd.
75
76 %package agent-standalone
77 Summary:        Standalone agent for zabbix
78 Summary(pl):    Wersja wolnostoj±ca agenta zabbiksa
79 Group:          Networking/Admin
80 Requires:       %{name}
81 Obsoletes:      %{name}-agent-inetd
82
83 %description  agent-standalone
84 This package provides standalone version of zabbix agent.
85
86 %description  agent-standalone
87 Ten pakiet dostarcza wolnostoj±cej wersji agenta zabbiksa.
88
89 %package suckerd
90 Summary:        sucker daemon for zabbix
91 Group:          Networking/Admin
92 Requires:       %{name}
93 %{!?_with_pgsql:Requires:       mysql}
94 %{?_with_pgsql:Requires:        postgresql}
95
96 %description suckerd
97 blah
98
99 %package trapper-inetd
100 Summary:        inetd trapper for zabbix
101 Summary(pl):    Wersja inetd programu pu³apkuj±cego zabbiksa
102 Group:          Networking/Admin
103 Requires:       %{name}
104 Requires:       inetdaemon
105 Obsoletes:      %{name}-trapper-standalone
106
107 %package trapper-standalone
108 Summary:        Standalone trapper for zabbix
109 Summary(pl):    Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
110 Group:          Networking/Admin
111 Requires:       %{name}
112 Obsoletes:      %{name}-trapper-inetd
113
114 %description trapper-standalone
115 blah
116
117 %package sender
118 Summary:        zabbix's sender
119 Summary(pl):    Program zawiadamiaj±cy zabbiksa
120 Group:          Networking/Admin
121
122 %description sender
123 blah
124
125 %prep
126 %setup -q -n %{name}-%{version}%{_beta}
127
128 %build
129 rm -f missing
130 %{__aclocal}
131 %{__autoconf}
132 %configure \
133         %{!?_with_pgsql:--with-mysql} \
134         %{?_with_pgsql:--with-pgsql}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd,%{_sbindir},/home/services/html/zabbix}
141
142 install bin/zabbix_* $RPM_BUILD_ROOT%{_sbindir}
143 install misc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}
144 cp -r frontends/php/* $RPM_BUILD_ROOT/home/services/html/zabbix
145
146 install %SOURCE1 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-agent
147 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %pre
153 if [ -z "`/usr/bin/getgid zabbix`" ]; then
154         /usr/sbin/groupadd zabbix
155 fi
156 if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
157         /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
158 fi
159
160 %postun
161 if [ "$1" = "0" ]; then
162         /usr/sbin/userdel zabbix
163         /usr/sbin/groupdel zabbix
164 fi
165
166 %post agent-inetd
167 if [ -f /var/lock/subsys/rc-inetd ]; then
168         /etc/rc.d/init.d/rc-inetd reload
169 else
170         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
171 fi
172
173 %postun agent-inetd
174 if [ -f /var/lock/subsys/rc-inetd ]; then
175         /etc/rc.d/init.d/rc-inetd reload
176 fi
177
178 %post trapper-inetd
179 if [ -f /var/lock/subsys/rc-inetd ]; then
180         /etc/rc.d/init.d/rc-inetd reload
181 else
182         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
183 fi
184
185 %postun trapper-inetd
186 if [ -f /var/lock/subsys/rc-inetd ]; then
187         /etc/rc.d/init.d/rc-inetd reload
188 fi
189
190 %files
191 %defattr(644,root,root,755)
192 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
193 %attr(750,root,zabbix) %dir %{_sysconfdir}
194
195 %files frontend-php
196 %defattr(644,root,root,755)
197 /home/services/html/zabbix
198
199 %files agent-inetd
200 %defattr(644,root,root,755)
201 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent.conf
202 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-agent
203 %attr(755,root,root) %{_sbindir}/zabbix_agent
204
205 %files agent-standalone
206 %defattr(644,root,root,755)
207 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
208 %attr(755,root,root) %{_sbindir}/zabbix_agentd
209
210 %files suckerd
211 %defattr(644,root,root,755)
212 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_suckerd.conf
213 %attr(755,root,root) %{_sbindir}/zabbix_suckerd
214
215 %files trapper-inetd
216 %defattr(644,root,root,755)
217 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapper.conf
218 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-trapper
219 %attr(755,root,root) %{_sbindir}/zabbix_trapper
220
221 %files trapper-standalone
222 %defattr(644,root,root,755)
223 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapperd.conf
224 %attr(755,root,root) %{_sbindir}/zabbix_trapperd
225
226 %files sender
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_sbindir}/zabbix_sender
This page took 0.089587 seconds and 4 git commands to generate.