]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
- summary / description
[packages/zabbix.git] / zabbix.spec
1 #
2 # Conditional build:
3 # _with_pgsql - enable postgresql support (by default use mysql)
4 #
5 %define _beta   beta8
6 Summary:        zabbix - network monitoring software
7 Summary(pl):    zabbix - oprogramowanie do monitorowania sieci
8 Name:           zabbix
9 Version:        1.0
10 Release:        0.%{_beta}.0.1
11 License:        GPL v2+
12 Group:          Networking/Admin
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
14 # Source0-md5:  ed691c777df63aa6081dde750f10e733
15 Source1:        %{name}-agent.inetd
16 Source2:        %{name}-trapper.inetd
17 URL:            http://zabbix.sourceforge.net/
18 %{!?_with_pgsql:BuildRequires:  mysql-devel}
19 %{?_with_pgsql:BuildRequires:   postgresql-devel}
20 BuildRequires:  ucd-snmp-devel
21 BuildRequires:  openssl-devel >= 0.9.6j
22 #PreReq:        -
23 #Requires       -
24 #Requires(pre,post):    -
25 #Requires(preun):       -
26 #Requires(postun):      -
27 #Provides:      -
28 #Obsoletes:     -
29 #Conflicts:     -
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define _sysconfdir     /etc/%{name}
33
34 %description
35
36 ZABBIX is software that monitors numerous parameters of a network and
37 the servers on that network. ZABBIX is a useful tool for monitoring
38 the health and integrity of servers. ZABBIX uses a flexible
39 notification mechanism that allows users to configure email based
40 alerts for virtually any event. All monitored parameters are stored in
41 a database. ZABBIX offers excellent reporting and data visualisation
42 features based on the stored data. ZABBIX supports both polling and
43 trapping. All ZABBIX reports and statistics, as well as configuration
44 parameters, are accessed through a web-based front end.
45
46 %description
47
48 zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
49 serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
50 dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
51 powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
52 poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
53 parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
54 przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
55 zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
56 wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
57 interfejs oparty o WWW.
58
59 %package frontend-php
60 Summary:        PHP frontend for zabbix
61 Summary(pl):    Interfejs PHP dla zabbiksa
62 Group:          Networking/Admin
63 Requires:       apache
64 Requires:       php
65
66 %description frontend-php
67 blah
68
69 %package agent-inetd
70 Summary:        inetd agent for zabbix
71 Summary(pl):    Wersja inetd agenta zabbiksa
72 Group:          Networking/Admin
73 Requires:       %{name}
74 Requires:       inetdaemon
75 Obsoletes:      %{name}-agent-standalone
76
77 %description agent-inetd
78 blah
79
80 %package agent-standalone
81 Summary:        Standalone agent for zabbix
82 Summary(pl):    Wersja wolnostoj±ca agenta zabbiksa
83 Group:          Networking/Admin
84 Requires:       %{name}
85 Obsoletes:      %{name}-agent-inetd
86
87 %description agent-standalone
88 blah
89
90 %package suckerd
91 Summary:        sucker daemon for zabbix
92 Group:          Networking/Admin
93 Requires:       %{name}
94 %{!?_with_pgsql:Requires:       mysql}
95 %{?_with_pgsql:Requires:        postgresql}
96
97 %description suckerd
98 blah
99
100 %package trapper-inetd
101 Summary:        inetd trapper for zabbix
102 Summary(pl):    Wersja inetd programu pu³apkuj±cego zabbiksa
103 Group:          Networking/Admin
104 Requires:       %{name}
105 Requires:       inetdaemon
106 Obsoletes:      %{name}-trapper-standalone
107
108 %description trapper-inetd
109 blah
110
111 %package trapper-standalone
112 Summary:        Standalone trapper for zabbix
113 Summary(pl):    Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
114 Group:          Networking/Admin
115 Requires:       %{name}
116 Obsoletes:      %{name}-trapper-inetd
117
118 %description trapper-standalone
119 blah
120
121 %package sender
122 Summary:        zabbix's sender
123 Summary(pl):    Program zawiadamiaj±cy zabbiksa
124 Group:          Networking/Admin
125
126 %description sender
127 blah
128
129 %prep
130 %setup -q -n %{name}-%{version}%{_beta}
131
132 %build
133 rm -f missing
134 %{__aclocal}
135 %{__autoconf}
136 %configure \
137         %{!?_with_pgsql:--with-mysql} \
138         %{?_with_pgsql:--with-pgsql}
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd,%{_sbindir},/home/services/html/zabbix}
145
146 install bin/zabbix_* $RPM_BUILD_ROOT%{_sbindir}
147 install misc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}
148 cp -r frontends/php/* $RPM_BUILD_ROOT/home/services/html/zabbix
149
150 install %SOURCE1 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-agent
151 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %pre
157 if [ -z "`/usr/bin/getgid zabbix`" ]; then
158         /usr/sbin/groupadd zabbix
159 fi
160 if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
161         /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
162 fi
163
164 %postun
165 if [ "$1" = "0" ]; then
166         /usr/sbin/userdel zabbix
167         /usr/sbin/groupdel zabbix
168 fi
169
170 %post agent-inetd
171 if [ -f /var/lock/subsys/rc-inetd ]; then
172         /etc/rc.d/init.d/rc-inetd reload
173 else
174         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
175 fi
176
177 %postun agent-inetd
178 if [ -f /var/lock/subsys/rc-inetd ]; then
179         /etc/rc.d/init.d/rc-inetd reload
180 fi
181
182 %post trapper-inetd
183 if [ -f /var/lock/subsys/rc-inetd ]; then
184         /etc/rc.d/init.d/rc-inetd reload
185 else
186         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
187 fi
188
189 %postun trapper-inetd
190 if [ -f /var/lock/subsys/rc-inetd ]; then
191         /etc/rc.d/init.d/rc-inetd reload
192 fi
193
194 %files
195 %defattr(644,root,root,755)
196 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
197 %attr(750,root,zabbix) %dir %{_sysconfdir}
198
199 %files frontend-php
200 %defattr(644,root,root,755)
201 /home/services/html/zabbix
202
203 %files agent-inetd
204 %defattr(644,root,root,755)
205 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent.conf
206 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-agent
207 %attr(755,root,root) %{_sbindir}/zabbix_agent
208
209 %files agent-standalone
210 %defattr(644,root,root,755)
211 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
212 %attr(755,root,root) %{_sbindir}/zabbix_agentd
213
214 %files suckerd
215 %defattr(644,root,root,755)
216 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_suckerd.conf
217 %attr(755,root,root) %{_sbindir}/zabbix_suckerd
218
219 %files trapper-inetd
220 %defattr(644,root,root,755)
221 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapper.conf
222 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-trapper
223 %attr(755,root,root) %{_sbindir}/zabbix_trapper
224
225 %files trapper-standalone
226 %defattr(644,root,root,755)
227 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapperd.conf
228 %attr(755,root,root) %{_sbindir}/zabbix_trapperd
229
230 %files sender
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_sbindir}/zabbix_sender
This page took 0.073958 seconds and 4 git commands to generate.