]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
dd7f25371e91c5e556ebe295ed1b56ff121fe06c
[packages/zabbix.git] / zabbix.spec
1 #
2 # Conditional build:
3 # _with_pgsql - enable postgresql support (by default use mysql)
4 #
5 %define _beta   beta8
6 Summary:        zabbix - network monitoring software
7 Summary(pl):    zabbix - oprogramowanie do monitorowania sieci
8 Name:           zabbix
9 Version:        1.0
10 Release:        0.%{_beta}.0.1
11 License:        GPL v2+
12 Group:          Networking/Admin
13 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
14 # Source0-md5:  ed691c777df63aa6081dde750f10e733
15 Source1:        %{name}-agent.inetd
16 Source2:        %{name}-trapper.inetd
17 URL:            http://zabbix.sourceforge.net/
18 %{!?_with_pgsql:BuildRequires:  mysql-devel}
19 %{?_with_pgsql:BuildRequires:   postgresql-devel}
20 BuildRequires:  ucd-snmp-devel
21 BuildRequires:  openssl-devel >= 0.9.6j
22 #PreReq:        -
23 #Requires       -
24 #Requires(pre,post):    -
25 #Requires(preun):       -
26 #Requires(postun):      -
27 #Provides:      -
28 #Obsoletes:     -
29 #Conflicts:     -
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define _sysconfdir     /etc/%{name}
33
34 %description
35 zabbix is software that monitors numerous parameters of a network and
36 the servers on that network. zabbix is a useful tool for monitoring
37 the health and integrity of servers. zabbix uses a flexible
38 notification mechanism that allows users to configure email based
39 alerts for virtually any event. All monitored parameters are stored in
40 a database. zabbix offers excellent reporting and data visualisation
41 features based on the stored data. zabbix supports both polling and
42 trapping. All zabbix reports and statistics, as well as configuration
43 parameters, are accessed through a web-based front end.
44
45 %description -l pl
46 zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
47 serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
48 dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
49 powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
50 poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
51 parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
52 przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
53 zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
54 wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
55 interfejs oparty o WWW.
56
57 %package frontend-php
58 Summary:        PHP frontend for zabbix
59 Summary(pl):    Interfejs PHP dla zabbiksa
60 Group:          Networking/Admin
61 Requires:       apache
62 Requires:       php
63
64 %description frontend-php
65 blah
66
67 %package agent-inetd
68 Summary:        inetd agent for zabbix
69 Summary(pl):    Wersja inetd agenta zabbiksa
70 Group:          Networking/Admin
71 Requires:       %{name}
72 Requires:       inetdaemon
73 Obsoletes:      %{name}-agent-standalone
74
75 %description agent-inetd
76 blah
77
78 %package agent-standalone
79 Summary:        Standalone agent for zabbix
80 Summary(pl):    Wersja wolnostoj±ca agenta zabbiksa
81 Group:          Networking/Admin
82 Requires:       %{name}
83 Obsoletes:      %{name}-agent-inetd
84
85 %description agent-standalone
86 blah
87
88 %package suckerd
89 Summary:        sucker daemon for zabbix
90 Group:          Networking/Admin
91 Requires:       %{name}
92 %{!?_with_pgsql:Requires:       mysql}
93 %{?_with_pgsql:Requires:        postgresql}
94
95 %description suckerd
96 blah
97
98 %package trapper-inetd
99 Summary:        inetd trapper for zabbix
100 Summary(pl):    Wersja inetd programu pu³apkuj±cego zabbiksa
101 Group:          Networking/Admin
102 Requires:       %{name}
103 Requires:       inetdaemon
104 Obsoletes:      %{name}-trapper-standalone
105
106 %description trapper-inetd
107 blah
108
109 %package trapper-standalone
110 Summary:        Standalone trapper for zabbix
111 Summary(pl):    Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
112 Group:          Networking/Admin
113 Requires:       %{name}
114 Obsoletes:      %{name}-trapper-inetd
115
116 %description trapper-standalone
117 blah
118
119 %package sender
120 Summary:        zabbix's sender
121 Summary(pl):    Program zawiadamiaj±cy zabbiksa
122 Group:          Networking/Admin
123
124 %description sender
125 blah
126
127 %prep
128 %setup -q -n %{name}-%{version}%{_beta}
129
130 %build
131 rm -f missing
132 %{__aclocal}
133 %{__autoconf}
134 %configure \
135         %{!?_with_pgsql:--with-mysql} \
136         %{?_with_pgsql:--with-pgsql}
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/sysconfig/rc-inetd,%{_sbindir},/home/services/html/zabbix}
143
144 install bin/zabbix_* $RPM_BUILD_ROOT%{_sbindir}
145 install misc/conf/* $RPM_BUILD_ROOT%{_sysconfdir}
146 cp -r frontends/php/* $RPM_BUILD_ROOT/home/services/html/zabbix
147
148 install %SOURCE1 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-agent
149 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %pre
155 if [ -z "`/usr/bin/getgid zabbix`" ]; then
156         /usr/sbin/groupadd zabbix
157 fi
158 if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
159         /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
160 fi
161
162 %postun
163 if [ "$1" = "0" ]; then
164         /usr/sbin/userdel zabbix
165         /usr/sbin/groupdel zabbix
166 fi
167
168 %post agent-inetd
169 if [ -f /var/lock/subsys/rc-inetd ]; then
170         /etc/rc.d/init.d/rc-inetd reload
171 else
172         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
173 fi
174
175 %postun agent-inetd
176 if [ -f /var/lock/subsys/rc-inetd ]; then
177         /etc/rc.d/init.d/rc-inetd reload
178 fi
179
180 %post trapper-inetd
181 if [ -f /var/lock/subsys/rc-inetd ]; then
182         /etc/rc.d/init.d/rc-inetd reload
183 else
184         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
185 fi
186
187 %postun trapper-inetd
188 if [ -f /var/lock/subsys/rc-inetd ]; then
189         /etc/rc.d/init.d/rc-inetd reload
190 fi
191
192 %files
193 %defattr(644,root,root,755)
194 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
195 %attr(750,root,zabbix) %dir %{_sysconfdir}
196
197 %files frontend-php
198 %defattr(644,root,root,755)
199 /home/services/html/zabbix
200
201 %files agent-inetd
202 %defattr(644,root,root,755)
203 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agent.conf
204 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-agent
205 %attr(755,root,root) %{_sbindir}/zabbix_agent
206
207 %files agent-standalone
208 %defattr(644,root,root,755)
209 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
210 %attr(755,root,root) %{_sbindir}/zabbix_agentd
211
212 %files suckerd
213 %defattr(644,root,root,755)
214 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_suckerd.conf
215 %attr(755,root,root) %{_sbindir}/zabbix_suckerd
216
217 %files trapper-inetd
218 %defattr(644,root,root,755)
219 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapper.conf
220 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/rc-inetd/zabbix-trapper
221 %attr(755,root,root) %{_sbindir}/zabbix_trapper
222
223 %files trapper-standalone
224 %defattr(644,root,root,755)
225 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_trapperd.conf
226 %attr(755,root,root) %{_sbindir}/zabbix_trapperd
227
228 %files sender
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_sbindir}/zabbix_sender
This page took 0.062938 seconds and 2 git commands to generate.