]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
a45cd2b9d5d6f02243259fcccb9d2df5754fc42a
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-agentd, zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  pgsql   # enable PostgreSQL support
6 %bcond_without  sqlite3 # enable sqlite3 support
7 %bcond_without  mysql   # enable MySQL support
8 %bcond_without  java    # disable java support
9
10 %define databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3}
11 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
12
13 %define         php_min_version 5.4.0
14 Summary:        Zabbix - network monitoring software
15 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
16 Name:           zabbix
17 Version:        3.2.3
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
22 # Source0-md5:  b058115f9218b085310cd07bbbeb9cd0
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}_server.service
25 Source3:        %{name}_agentd.service
26 Source4:        %{name}_proxy.service
27 Source5:        %{name}_java.service
28 Source6:        %{name}.tmpfiles
29 Patch0:         config.patch
30 Patch1:         sqlite3_dbname.patch
31 URL:            http://zabbix.sourceforge.net/
32 BuildRequires:  OpenIPMI-devel
33 BuildRequires:  curl-devel
34 BuildRequires:  iksemel-devel
35 %{?with_java:BuildRequires:     jdk}
36 BuildRequires:  libssh2-devel
37 BuildRequires:  libxml2-devel
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 BuildRequires:  net-snmp-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel >= 0.9.7d
42 %{?with_pgsql:BuildRequires:    postgresql-devel}
43 BuildRequires:  rpmbuild(macros) >= 1.671
44 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
45 BuildRequires:  unixODBC-devel
46 Requires:       %{name}-agentd = %{version}-%{release}
47 Requires:       %{name}-frontend-php = %{version}-%{release}
48 Requires:       %{name}-server = %{version}-%{release}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _sysconfdir     /etc/%{name}
52 %define         _appdir         %{_datadir}/%{name}
53 %define         _webapps        /etc/webapps
54 %define         _webapp         %{name}
55
56 %description
57 Zabbix is software that monitors numerous parameters of a network and
58 the servers on that network. It is a useful tool for monitoring the
59 health and integrity of servers. Zabbix uses a flexible notification
60 mechanism that allows users to configure email based alerts for
61 virtually any event. All monitored parameters are stored in a
62 database. Zabbix offers excellent reporting and data visualisation
63 features based on the stored data. Zabbix supports both polling and
64 trapping. All Zabbix reports and statistics, as well as configuration
65 parameters, are accessed through a web-based front end.
66
67 %description -l pl.UTF-8
68 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
69 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
70 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
71 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
72 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
73 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
74 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
75 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
76 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
77
78 %package common
79 Summary:        Common files for Zabbix monitoring software
80 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
81 Group:          Networking/Utilities
82 Requires(postun):       /usr/sbin/groupdel
83 Requires(postun):       /usr/sbin/userdel
84 Requires(pre):  /bin/id
85 Requires(pre):  /usr/bin/getgid
86 Requires(pre):  /usr/sbin/groupadd
87 Requires(pre):  /usr/sbin/useradd
88 Provides:       group(zabbix)
89 Provides:       user(zabbix)
90
91 %description common
92 Common files for Zabbix monitoring software.
93
94 %description common -l pl.UTF-8
95 Wspólne pliki dla oprogramowania monitorującego Zabbix.
96
97 %package agentd
98 Summary:        Zabbix Agent
99 Summary(pl.UTF-8):      Agenta Zabbiksa
100 Group:          Networking/Utilities
101 Requires:       %{name}-common = %{version}-%{release}
102 Requires:       systemd-units >= 38
103 Obsoletes:      zabbix-agent-inetd
104 Obsoletes:      zabbix-agent-standalone
105
106 %description agentd
107 Zabbix agent collects data from the local system for a Zabbix server.
108
109 %description agentd -l pl.UTF-8
110 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
111
112 %package frontend-php
113 Summary:        PHP frontend for Zabbix
114 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
115 Group:          Applications/WWW
116 Requires:       php(bcmath)
117 Requires:       php(core) >= %{php_min_version}
118 Requires:       php(ctype)
119 Requires:       php(gd)
120 Requires:       php(gettext)
121 Requires:       php(json)
122 Requires:       php(mbstring)
123 Requires:       php(pcre)
124 Requires:       php(session)
125 Requires:       php(sockets)
126 Requires:       php(xml)
127 Requires:       php(xmlreader)
128 Requires:       php(xmlwriter)
129 Requires:       webapps
130 Requires:       webserver(alias)
131 Requires:       webserver(indexfile)
132 Requires:       webserver(php)
133 Suggests:       php(mysql)
134 Suggests:       php(pgsql)
135 Suggests:       php(sqlite3)
136 # used with sqlite3
137 Suggests:       php(sysvsem)
138
139 %description frontend-php
140 This package provides web based (PHP) frontend for Zabbix.
141
142 %description frontend-php -l pl.UTF-8
143 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
144
145 %package get
146 Summary:        Program retrieving data from Zabbix agent
147 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
148 Group:          Networking/Utilities
149
150 %description get
151 This package provides a program retrieving data from Zabbix agent.
152
153 %description get -l pl.UTF-8
154 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
155
156 %package proxy
157 Summary:        Zabbix proxy
158 Summary(pl.UTF-8):      Proxy do Zabbiksa
159 Group:          Networking/Utilities
160 Requires:       %{name}-common = %{version}-%{release}
161 Requires:       zabbix-proxy(db) = %{version}-%{release}
162 Requires:       systemd-units >= 38
163
164 %description proxy
165 This package provides the Zabbix proxy.
166
167 %description proxy -l pl.UTF-8
168 Ten pakiet zawiera proxy Zabbix.
169
170 %package proxy-mysql
171 Summary:        MySQL support for Zabbix proxy
172 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
173 Group:          Networking/Utilities
174 Provides:       %{name}-proxy(db) = %{version}-%{release}
175 Obsoletes:      %{name}-proxy-postgresql
176 Obsoletes:      %{name}-proxy-sqlite3
177
178 %description proxy-mysql
179 This package provides the Zabbix proxy binary with MySQL support.
180
181 %description proxy-mysql -l pl.UTF-8
182 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
183
184 %package proxy-postgresql
185 Summary:        PostgreSQL support for Zabbix proxy
186 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
187 Group:          Networking/Utilities
188 Provides:       %{name}-proxy(db) = %{version}-%{release}
189 Obsoletes:      %{name}-proxy-mysql
190 Obsoletes:      %{name}-proxy-sqlite3
191
192 %description proxy-postgresql
193 This package provides the Zabbix proxy binary with PostgreSQL support.
194
195 %description proxy-postgresql -l pl.UTF-8
196 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
197
198 %package proxy-sqlite3
199 Summary:        SQLite 3 support for Zabbix proxy
200 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
201 Group:          Networking/Utilities
202 Provides:       %{name}-proxy(db) = %{version}-%{release}
203 Obsoletes:      %{name}-proxy-mysql
204 Obsoletes:      %{name}-proxy-postgresql
205
206 %description proxy-sqlite3
207 This package provides the Zabbix proxy binary with SQLite 3 support.
208
209 %description proxy-sqlite3 -l pl.UTF-8
210 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
211
212 %package sender
213 Summary:        Zabbix sender
214 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
215 Group:          Networking/Utilities
216
217 %description sender
218 This package provides the Zabbix sender.
219
220 %description sender -l pl.UTF-8
221 Ten pakiet zawiera program zawiadamiający Zabbiksa.
222
223 %package server
224 Summary:        Zabbix server
225 Summary(pl.UTF-8):      Serwer Zabbiksa
226 Group:          Networking/Utilities
227 Requires:       %{name}-common = %{version}-%{release}
228 Requires:       %{name}-server(db) = %{version}-%{release}
229 Requires:       systemd-units >= 38
230 Obsoletes:      zabbix-suckerd
231 Obsoletes:      zabbix-trapper-inetd
232 Obsoletes:      zabbix-trapper-standalone
233
234 %description server
235 This package provides the Zabbix server.
236
237 %description server -l pl.UTF-8
238 Ten pakiet zawiera serwer Zabbiksa.
239
240 %package server-mysql
241 Summary:        MySQL support for Zabbix server
242 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
243 Group:          Networking/Utilities
244 Provides:       %{name}-server(db) = %{version}-%{release}
245 Obsoletes:      %{name}-server-postgresql
246 Obsoletes:      %{name}-server-sqlite3
247
248 %description server-mysql
249 This package provides the Zabbix server binary for use with MySQL database.
250
251 %description server-mysql -l pl.UTF-8
252 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
253
254 %package server-postgresql
255 Summary:        PostgreSQL support for Zabbix server
256 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
257 Group:          Networking/Utilities
258 Provides:       %{name}-server(db) = %{version}-%{release}
259 Obsoletes:      %{name}-server-mysql
260 Obsoletes:      %{name}-server-sqlite3
261
262 %description server-postgresql
263 This package provides the Zabbix server binary for use with PostgreSQL database.
264
265 %description server-postgresql -l pl.UTF-8
266 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
267
268 %package server-sqlite3
269 Summary:        SQLite 3 support for Zabbix server
270 Summary(pl.UTF-8):      Obsługa SQLite 3 sla serwera Zabbiksa
271 Group:          Networking/Utilities
272 Requires(post): /bin/zcat
273 Provides:       %{name}-server(db) = %{version}-%{release}
274 Obsoletes:      %{name}-server-mysql
275 Obsoletes:      %{name}-server-postgresql
276
277 %description server-sqlite3
278 This package provides the Zabbix server binary for use with SQLite 3 database.
279
280 NOTE: Support for SQLite 3 is EXPERIMENTAL and not recommended.
281
282 %description server-sqlite3 -l pl.UTF-8
283 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych SQLite 3.
284
285 INFO: Wsparcie dla SQLite 3 jest EKSPERYMENTALNE i nie rekomendowane.
286
287 %package java
288 Summary:        Zabbix Java Gateway
289 Group:          Networking/Utilities
290 Requires:       %{name}-common = %{version}-%{release}
291 Requires:       systemd-units >= 38
292
293 %description java
294 This package provides the Zabbix Java Gateway.
295
296 %prep
297 %setup -q
298
299 %patch0 -p1
300 %patch1 -p1
301
302 %build
303
304 configure() {
305         %configure \
306         --enable-agent \
307         --enable-ipv6 \
308         %{__enable_disable java} \
309         --with-jabber \
310         --with-ldap \
311         --with-libcurl \
312         --with-libxml2 \
313         --with-net-snmp \
314         --with-openipmi \
315         --with-openssl \
316         --with-ssh2 \
317         --with-unixodbc \
318         "$@"
319 }
320
321 configure \
322         --disable-server \
323         --disable-proxy 
324
325 %{__make}
326
327 # keep timestamps to prevent unneccessary rebuilds
328 cp -a include/config.h include/config.h.old
329 cp -a include/stamp-h1 include/stamp-h1.old
330
331 for database in %{databases} ; do
332         configure \
333                 --with-$database \
334                 --enable-server \
335                 --enable-proxy
336
337         # restore timestamps
338         touch --reference=include/config.h.old include/config.h
339         touch --reference=include/stamp-h1.old include/stamp-h1
340
341         # clean what needs rebuilding
342         for dir in src/libs/zbxdb* src/libs/zbxserver ; do
343                 %{__make} -C $dir clean
344         done
345
346         touch include/zbxdb.h
347
348         %{__make}
349
350         %{__make} install \
351                 -C src/zabbix_server \
352                 DESTDIR=$PWD/install-${database}
353         %{__make} install \
354                 -C src/zabbix_proxy \
355                 DESTDIR=$PWD/install-${database}
356
357         # prepare dirs for %%doc
358         for dir in upgrades/dbpatches/* ; do
359                 [ -d $dir/${database} ] || continue
360                 mkdir -p install-${database}/upgrade/$(basename $dir)
361                 cp -a $dir/${databases}/* install-${database}/upgrade/$(basename $dir)
362         done
363 done
364
365 %install
366 rm -rf $RPM_BUILD_ROOT
367 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/webapps/%{_webapp},%{_appdir}} \
368         $RPM_BUILD_ROOT{/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
369
370 %{__make} install \
371         DESTDIR=$RPM_BUILD_ROOT \
372         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
373
374 for database in %{databases} ; do
375         cp -p install-$database/%{_sbindir}/zabbix_server \
376                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
377         cp -p install-$database/%{_sbindir}/zabbix_proxy \
378                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
379 done
380
381 if [ -n "$database" ] ; then
382         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
383         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
384 fi
385
386 %if %{with sqlite3}
387 install -d $RPM_BUILD_ROOT/var/lib/zabbix
388 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
389 %endif
390
391 cp -r frontends $RPM_BUILD_ROOT%{_appdir}
392
393 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
394 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
395
396 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
397 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
398 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
399 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
400
401 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
402
403 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
404 ln -s %{_sysconfdir}/frontend $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf
405 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
406
407 %if %{with java}
408 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
409 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
410 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
411 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
412 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
413 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
414
415 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
416 #!/bin/sh
417
418 exec %{_datadir}/zabbix_java/startup.sh "$@"
419 EOF
420
421 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
422 #!/bin/sh
423
424 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
425 EOF
426 %endif
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
432 %webapp_register apache %{_webapp}
433
434 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
435 %webapp_unregister apache %{_webapp}
436
437 %triggerin frontend-php -- apache < 2.2.0, apache-base
438 %webapp_register httpd %{_webapp}
439
440 %triggerun frontend-php -- apache < 2.2.0, apache-base
441 %webapp_unregister httpd %{_webapp}
442
443 %pre common
444 %groupadd -g 111 zabbix
445 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
446
447 %postun common
448 if [ "$1" = "0" ]; then
449         %userremove zabbix
450         %groupremove zabbix
451 fi
452
453 %post server-mysql
454 if [ "$1" = 1 ]; then
455         %banner -e %{name}-server <<-EOF
456         You should create database for Zabbix.
457
458         Running these should be fine in most cases:
459         mysqladmin create zabbix
460         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
461         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
462         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
463 EOF
464 fi
465 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
466
467 %post server-postgresql
468 if [ "$1" = 1 ]; then
469         %banner -e %{name}-server <<-EOF
470         You should create database for Zabbix.
471
472         Running these should be fine in most cases:
473
474         createuser zabbix
475         createdb -O zabbix zabbix
476         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
477         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
478         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
479 EOF
480 fi
481 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
482
483 %post server-sqlite3
484 if [ "$1" = 1 ]; then
485         if [ ! -f /var/lib/zabbix/zabbix.db ] ; then
486                 %banner -e %{name}-server <<-EOF
487                 Creating sqlite3 database for Zabbix in /var/lib/zabbix/zabbix.db
488 EOF
489                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/schema.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
490                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/images.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
491                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/data.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
492                 chown zabbix:zabbix /var/lib/zabbix/zabbix.db && \
493                 chmod 644 /var/lib/zabbix/zabbix.db || :
494         fi
495 fi
496 ln -sf %{_sbindir}/zabbix_server-sqlite3 %{_sbindir}/zabbix_server || :
497
498 %post server
499 %systemd_post zabbix_server.service
500
501 %preun server
502 %systemd_preun zabbix_server.service
503
504 %postun server
505 if [ "$1" = "0" ]; then
506         if [ -L %{_sbindir}/zabbix_server ] ; then
507                 rm -f %{_sbindir}/zabbix_server || :
508         fi
509 fi
510 %systemd_reload
511
512 %post agentd
513 %systemd_post zabbix_agentd.service
514
515 %preun agentd
516 %systemd_preun zabbix_agentd.service
517
518 %postun agentd
519 %systemd_reload
520
521 %post proxy-mysql
522 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
523
524 %post proxy-postgresql
525 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
526
527 %post proxy-sqlite3
528 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
529
530 %post proxy
531 %systemd_post zabbix_proxy.service
532
533 %preun proxy
534 %systemd_preun zabbix_proxy.service
535
536 %postun proxy
537 %systemd_reload
538
539 %post java
540 %systemd_post zabbix_java.service
541
542 %preun java
543 %systemd_preun zabbix_java.service
544
545 %postun java
546 %systemd_reload
547
548 %files
549 %defattr(644,root,root,755)
550 %doc AUTHORS ChangeLog README
551
552 %files common
553 %defattr(644,root,root,755)
554 %doc AUTHORS ChangeLog README
555 %attr(751,root,zabbix) %dir %{_sysconfdir}
556 %attr(751,root,http) %dir %{_sysconfdir}/frontend
557 %dir %{_appdir}
558 %dir %{_appdir}/frontends
559 %dir %attr(770,root,zabbix) /run/zabbix
560 %dir %attr(775,root,zabbix) /var/log/zabbix
561 %{systemdtmpfilesdir}/zabbix.conf
562
563 %files agentd
564 %defattr(644,root,root,755)
565 %doc conf/zabbix_agentd/*.conf
566 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
567 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
568 %attr(755,root,root) %{_sbindir}/zabbix_agentd
569 %{_mandir}/man8/zabbix_agentd*
570 %{systemdunitdir}/zabbix_agentd.service
571
572 %files frontend-php
573 %defattr(644,root,root,755)
574 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
575 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*
576 %{_appdir}/frontends/php
577 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
578 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
579 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
580 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
581
582 %files get
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_bindir}/zabbix_get
585 %{_mandir}/man1/zabbix_get*
586
587 %if %{any_database}
588 %files proxy
589 %defattr(644,root,root,755)
590 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
591 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
592 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
593 %{_mandir}/man8/zabbix_proxy*
594 %{systemdunitdir}/zabbix_proxy.service
595 %endif
596
597 %if %{with mysql}
598 %files proxy-mysql
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
601 %endif
602
603 %if %{with pgsql}
604 %files proxy-postgresql
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
607 %endif
608
609 %if %{with sqlite3}
610 %files proxy-sqlite3
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
613 %endif
614
615 %files sender
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/zabbix_sender
618 %{_mandir}/man1/zabbix_sender*
619
620 %if %{any_database}
621 %files server
622 %defattr(644,root,root,755)
623 %doc upgrades/dbpatches
624 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
625 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
626 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
627 %{_mandir}/man8/zabbix_server*
628 %{systemdunitdir}/zabbix_server.service
629 %endif
630
631 %if %{with mysql}
632 %files server-mysql
633 %defattr(644,root,root,755)
634 %doc database/mysql/*.sql install-mysql/upgrade
635 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
636 %endif
637
638 %if %{with pgsql}
639 %files server-postgresql
640 %defattr(644,root,root,755)
641 %doc database/postgresql/*.sql install-postgresql/upgrade
642 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
643 %endif
644
645 %if %{with sqlite3}
646 %files server-sqlite3
647 %defattr(644,root,root,755)
648 %doc database/sqlite3/*.sql
649 %attr(755,root,root) %{_sbindir}/zabbix_server-sqlite3
650 %dir %attr(771,root,zabbix) /var/lib/zabbix
651 %ghost %attr(644,zabbix,zabbix) /var/lib/zabbix/zabbix.db
652 %endif
653
654 %if %{with java}
655 %files java
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_sbindir}/zabbix_java-start
658 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
659 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
660 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
661 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
662 %dir %{_datadir}/zabbix_java
663 %{_datadir}/zabbix_java/bin
664 %{_datadir}/zabbix_java/lib
665 %{_datadir}/zabbix_java/settings.sh
666 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
667 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
668 %{systemdunitdir}/zabbix_java.service
669 %endif
This page took 0.102496 seconds and 3 git commands to generate.