]> git.pld-linux.org Git - packages/xtables-geoip.git/blob - xtables-geoip.spec
- up to 2012-04 release
[packages/xtables-geoip.git] / xtables-geoip.spec
1 Summary:        GeoIP database files for xt_geoip
2 Name:           xtables-geoip
3 Version:        20120404
4 Release:        1
5 License:        GPL, Open Data License
6 Group:          Networking/Admin
7 URL:            http://www.maxmind.com/
8 Source0:        http://geolite.maxmind.com/download/geoip/database/GeoIPCountryCSV.zip
9 # Source0-md5:  1c4c4042bb337c16422af937e59a71e8
10 Source1:        http://geolite.maxmind.com/download/geoip/database/GeoIPv6.csv.gz
11 # Source1-md5:  eab709d046f8c3a7bde09e7e64407883
12 Source2:        http://geolite.maxmind.com/download/geoip/database/LICENSE.txt
13 # Source2-md5:  a1381bd1aa0a0c91dc31b3f1e847cf4a
14 Source3:        http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=blob_plain;f=geoip/xt_geoip_build
15 # Source3-md5:  9933235c5d9c4c7fbad965d6317f8c2f
16 BuildRequires:  perl-Text-CSV_XS >= 0.69
17 BuildRequires:  perl-base
18 BuildRequires:  rpm >= 4.4.9-56
19 BuildRequires:  unzip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dbdir   /usr/share/xt_geoip
23
24 # no debuginfo to package
25 %define         _enable_debug_packages  0
26
27 %ifarch ppc sparc ppc64 sparc64 sparcv9
28 %define         byteorder       BE
29 %else
30 %define         byteorder       LE
31 %endif
32
33 %description
34 The package contains the GeoIP definition files (which IP addresses
35 belong to which country) that are needed for Xtables-addons's xt_geoip
36 module.
37
38 %prep
39 %setup -qc
40
41 ver=$(stat -c '%y' GeoIPCountryWhois.csv | awk '{print $1}' | tr -d -)
42 if [ "$ver" != %{version} ]; then
43         exit 1
44 fi
45
46 gunzip -c %{SOURCE1} >GeoIPv6.csv
47 cp -p %{SOURCE2} .
48
49 %build
50 %{__perl} %{SOURCE3} GeoIPCountryWhois.csv GeoIPv6.csv | tee ranges.txt
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{dbdir}
55 cp -a %{byteorder} $RPM_BUILD_ROOT%{dbdir}
56
57 %if "%{pld_release}" == "ac"
58 # handle older xtables in ac:
59 # kernel-net-xtables-addons-1.18-15@2.6.27.53_1.amd64
60 # still having old .iv0 names requirement
61 # http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=commitdiff;h=25bf680ead80e505d5073308f151b4007cb5683f
62 # create hardlink, to be most compatible
63 for a in $RPM_BUILD_ROOT%{dbdir}/%{byteorder}/*.iv4; do
64         ln $a ${a%.iv4}.iv0
65 done
66 %endif
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc LICENSE.txt ranges.txt
74 %dir %{dbdir}
75 %{dbdir}/%{byteorder}
This page took 0.077703 seconds and 4 git commands to generate.