]> git.pld-linux.org Git - packages/xtables-geoip.git/blob - xtables-geoip.spec
- up to 20120808
[packages/xtables-geoip.git] / xtables-geoip.spec
1 Summary:        GeoIP database files for xt_geoip
2 Name:           xtables-geoip
3 Version:        20120808
4 Release:        1
5 License:        GPL, Open Data License
6 Group:          Networking/Admin
7 URL:            http://www.maxmind.com/
8 Source0:        http://geolite.maxmind.com/download/geoip/database/GeoIPCountryCSV.zip
9 # Source0-md5:  65f96d32d1aa83c4ceadfc98b778cddf
10 Source1:        http://geolite.maxmind.com/download/geoip/database/GeoIPv6.csv.gz
11 # Source1-md5:  d6e2e96ab35dffd82dd4d64d9e82af9b
12 Source2:        http://geolite.maxmind.com/download/geoip/database/LICENSE.txt
13 # Source2-md5:  a1381bd1aa0a0c91dc31b3f1e847cf4a
14 Source3:        http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=blob_plain;f=geoip/xt_geoip_build
15 # Source3-md5:  76c6959bad03c1ff064aefcb4811cd92
16 BuildRequires:  perl-Text-CSV_XS >= 0.69
17 BuildRequires:  perl-base
18 BuildRequires:  rpm >= 4.4.9-56
19 BuildRequires:  unzip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dbdir   /usr/share/xt_geoip
23
24 # no debuginfo to package
25 %define         _enable_debug_packages  0
26
27 %ifarch ppc sparc ppc64 sparc64 sparcv9
28 %define         byteorder       BE
29 %else
30 %define         byteorder       LE
31 %endif
32
33 %description
34 The package contains the GeoIP definition files (which IP addresses
35 belong to which country) that are needed for Xtables-addons's xt_geoip
36 module.
37
38 %prep
39 %setup -qc
40 gunzip -c %{SOURCE1} > GeoIPv6.csv
41 touch -r %{SOURCE1} GeoIPv6.csv
42
43 ver4=$(stat -c '%y' GeoIPCountryWhois.csv | awk '{print $1}' | tr -d -)
44 ver6=$(stat -c '%y' GeoIPv6.csv | awk '{print $1}' | tr -d -)
45 if [ "$ver4" -gt "$ver6" ]; then
46         ver=$ver4
47 else
48         ver=$ver6
49 fi
50 if [ "$ver" != %{version} ]; then
51         exit 1
52 fi
53
54 cp -p %{SOURCE2} .
55
56 %build
57 %{__perl} %{SOURCE3} GeoIPCountryWhois.csv GeoIPv6.csv | tee ranges.txt
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{dbdir}
62 cp -a %{byteorder} $RPM_BUILD_ROOT%{dbdir}
63
64 %if "%{pld_release}" == "ac"
65 # handle older xtables in ac:
66 # kernel-net-xtables-addons-1.18-15@2.6.27.53_1.amd64
67 # still having old .iv0 names requirement
68 # http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=commitdiff;h=25bf680ead80e505d5073308f151b4007cb5683f
69 # create hardlink, to be most compatible
70 for a in $RPM_BUILD_ROOT%{dbdir}/%{byteorder}/*.iv4; do
71         ln $a ${a%.iv4}.iv0
72 done
73 # kernel-net-xtables-addons-1.18-8@2.6.27.45_1.i686  searches from /var/lib:
74 # Could not open /var/lib/geoip/LE/EE.iv0: No such file or directory
75 install -d $RPM_BUILD_ROOT/var/lib
76 ln -s %{_datadir}/xt_geoip $RPM_BUILD_ROOT/var/lib/geoip
77 %endif
78
79 %if "%{pld_release}" == "ac"
80 %pretrans
81 # this needs to be a symlink
82 if [ -d /var/lib/geoip -a ! -L /var/lib/geoip ]; then
83         mv -f /var/lib/geoip{,.rpmsave}
84         install -d %{dbdir}
85         ln -s %{dbdir} /var/lib/geoip
86 fi
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc LICENSE.txt ranges.txt
95 %dir %{dbdir}
96 %{dbdir}/%{byteorder}
97
98 %if "%{pld_release}" == "ac"
99 /var/lib/geoip
100 %endif
This page took 0.166828 seconds and 4 git commands to generate.