]> git.pld-linux.org Git - packages/xtables-geoip.git/blob - xtables-geoip.spec
- do not just discard dir, convert it to full symlink, or stupid rpm will remove...
[packages/xtables-geoip.git] / xtables-geoip.spec
1 Summary:        GeoIP database files for xt_geoip
2 Name:           xtables-geoip
3 Version:        20120501
4 Release:        3
5 License:        GPL, Open Data License
6 Group:          Networking/Admin
7 URL:            http://www.maxmind.com/
8 Source0:        http://geolite.maxmind.com/download/geoip/database/GeoIPCountryCSV.zip
9 # Source0-md5:  9b2bbd5f39fafa52ade4f339babf394a
10 Source1:        http://geolite.maxmind.com/download/geoip/database/GeoIPv6.csv.gz
11 # Source1-md5:  f8f0130ea32d8e7b7bfc349f751ccee5
12 Source2:        http://geolite.maxmind.com/download/geoip/database/LICENSE.txt
13 # Source2-md5:  a1381bd1aa0a0c91dc31b3f1e847cf4a
14 Source3:        http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=blob_plain;f=geoip/xt_geoip_build
15 # Source3-md5:  9933235c5d9c4c7fbad965d6317f8c2f
16 BuildRequires:  perl-Text-CSV_XS >= 0.69
17 BuildRequires:  perl-base
18 BuildRequires:  rpm >= 4.4.9-56
19 BuildRequires:  unzip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         dbdir   /usr/share/xt_geoip
23
24 # no debuginfo to package
25 %define         _enable_debug_packages  0
26
27 %ifarch ppc sparc ppc64 sparc64 sparcv9
28 %define         byteorder       BE
29 %else
30 %define         byteorder       LE
31 %endif
32
33 %description
34 The package contains the GeoIP definition files (which IP addresses
35 belong to which country) that are needed for Xtables-addons's xt_geoip
36 module.
37
38 %prep
39 %setup -qc
40
41 ver=$(stat -c '%y' GeoIPCountryWhois.csv | awk '{print $1}' | tr -d -)
42 if [ "$ver" != %{version} ]; then
43         exit 1
44 fi
45
46 gunzip -c %{SOURCE1} >GeoIPv6.csv
47 cp -p %{SOURCE2} .
48
49 %build
50 %{__perl} %{SOURCE3} GeoIPCountryWhois.csv GeoIPv6.csv | tee ranges.txt
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{dbdir}
55 cp -a %{byteorder} $RPM_BUILD_ROOT%{dbdir}
56
57 %if "%{pld_release}" == "ac"
58 # handle older xtables in ac:
59 # kernel-net-xtables-addons-1.18-15@2.6.27.53_1.amd64
60 # still having old .iv0 names requirement
61 # http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=commitdiff;h=25bf680ead80e505d5073308f151b4007cb5683f
62 # create hardlink, to be most compatible
63 for a in $RPM_BUILD_ROOT%{dbdir}/%{byteorder}/*.iv4; do
64         ln $a ${a%.iv4}.iv0
65 done
66 # kernel-net-xtables-addons-1.18-8@2.6.27.45_1.i686  searches from /var/lib:
67 # Could not open /var/lib/geoip/LE/EE.iv0: No such file or directory
68 install -d $RPM_BUILD_ROOT/var/lib
69 ln -s %{_datadir}/xt_geoip $RPM_BUILD_ROOT/var/lib/geoip
70 %endif
71
72 %if "%{pld_release}" == "ac"
73 %pretrans
74 # this needs to be a symlink
75 if [ -d /var/lib/geoip -a ! -L /var/lib/geoip ]; then
76         mv -f /var/lib/geoip{,.rpmsave}
77         install -d %{dbdir}
78         ln -s %{dbdir} /var/lib/geoip
79 fi
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc LICENSE.txt ranges.txt
88 %dir %{dbdir}
89 %{dbdir}/%{byteorder}
90
91 %if "%{pld_release}" == "ac"
92 /var/lib/geoip
93 %endif
This page took 0.272105 seconds and 4 git commands to generate.