]> git.pld-linux.org Git - packages/xqilla.git/blob - xqilla.spec
- added patches for compatibility with xerces 3.2
[packages/xqilla.git] / xqilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
6 Summary(pl.UTF-8):      XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
7 Name:           xqilla
8 Version:        2.3.3
9 Release:        2
10 License:        Apache v2.0
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
13 # Source0-md5:  8ece20348687b6529bb934c17067803c
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-soname.patch
16 # https://sourceforge.net/p/xqilla/bugs/48/
17 # https://sourceforge.net/p/xqilla/bugs/48/attachment/patch-src_dom-api_impl_XPathDocumentImpl.cpp
18 Patch2:         %{name}-xerces-1.patch
19 # https://sourceforge.net/p/xqilla/bugs/48/attachment/patch-src_dom-api_impl_XPathNamespaceImpl.cpp
20 Patch3:         %{name}-xerces-2.patch
21 URL:            http://xqilla.sourceforge.net/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake
24 BuildRequires:  faxpp-devel
25 BuildRequires:  flex
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.5
28 BuildRequires:  tidy-devel
29 BuildRequires:  xerces-c-devel >= 3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
34
35 %description -l pl.UTF-8
36 XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
37 Xerces-C.
38
39 %package devel
40 Summary:        Header files for XQilla library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki XQilla
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       faxpp-devel
45 Requires:       libstdc++-devel
46 Requires:       tidy-devel
47 Requires:       xerces-c-devel >= 3
48
49 %description devel
50 Header files for XQilla library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki XQilla.
54
55 %package static
56 Summary:        Static XQilla library
57 Summary(pl.UTF-8):      Statyczna biblioteka XQilla
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static XQilla library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka XQilla.
66
67 %package apidocs
68 Summary:        XQilla API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki XQilla
70 Group:          Documentation
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 API and internal documentation for XQilla library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki XQilla.
80
81 %prep
82 %setup -q -n XQilla-%{version}
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p0
86 %patch3 -p0
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --with-faxpp=/usr \
96         --with-xerces=/usr
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc README TODO
115 %attr(755,root,root) %{_bindir}/xqilla
116 %attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libxqilla.so
122 %{_libdir}/libxqilla.la
123 %{_includedir}/xqilla
124 %{_includedir}/xqc.h
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libxqilla.a
129
130 %if %{with apidocs}
131 %files apidocs
132 %defattr(644,root,root,755)
133 %doc docs/{dom3-api,simple-api,xqc-api,*.html}
134 %endif
This page took 0.036985 seconds and 3 git commands to generate.