]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- updated some extension bconds
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
5 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
6 %bcond_with     hal             # HAL support for configuration (if no udev)
7 %bcond_without  udev            # UDEV support for configuration
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  dmx             # DMX support
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       5.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        10.0
20 %define xorg_xserver_server_xinput_abi          12.2
21
22 %define         rel     1
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.10.4
27 Release:        %{rel}%{?with_multigl:.mgl}
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  94f23d30a77d63e27dd209a57fccfebf
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38 Patch2:         %{name}-fb-size.patch
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 URL:            http://xorg.freedesktop.org/
42 BuildRequires:  Mesa-libGL-devel >= 7.8.1
43 # for glx headers
44 BuildRequires:  OpenGL-GLX-devel
45 %{?with_xselinux:BuildRequires: audit-libs-devel}
46 BuildRequires:  autoconf >= 2.57
47 BuildRequires:  automake
48 BuildRequires:  cpp
49 BuildRequires:  docbook-dtd43-xml
50 #BuildRequires: doxygen >= 1.6.1
51 %if %{with hal} || %{with dbus}
52 BuildRequires:  dbus-devel >= 1.0
53 %endif
54 %{?with_hal:BuildRequires:      hal-devel}
55 BuildRequires:  libdrm-devel >= 2.4.5
56 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
57 BuildRequires:  libtool
58 BuildRequires:  ncurses-devel
59 BuildRequires:  pam-devel
60 BuildRequires:  perl-base
61 BuildRequires:  pixman-devel >= 0.16.0
62 BuildRequires:  pkgconfig >= 1:0.19
63 BuildRequires:  udev-devel >= 1:143
64 BuildRequires:  xmlto >= 0.0.20
65 BuildRequires:  xorg-app-mkfontscale
66 BuildRequires:  xorg-font-font-util >= 1.1
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXau-devel
69 BuildRequires:  xorg-lib-libXaw-devel
70 BuildRequires:  xorg-lib-libXdamage-devel
71 BuildRequires:  xorg-lib-libXdmcp-devel
72 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
73 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
74 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
75 BuildRequires:  xorg-lib-libXmu-devel
76 BuildRequires:  xorg-lib-libXpm-devel
77 BuildRequires:  xorg-lib-libXrender-devel
78 BuildRequires:  xorg-lib-libXres-devel
79 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
80 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
81 BuildRequires:  xorg-lib-libXv-devel
82 BuildRequires:  xorg-lib-libXxf86dga-devel
83 BuildRequires:  xorg-lib-libXxf86misc-devel
84 BuildRequires:  xorg-lib-libXxf86vm-devel
85 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
86 BuildRequires:  xorg-lib-libfontenc-devel
87 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
88 BuildRequires:  xorg-lib-libxkbfile-devel
89 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
90 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
91 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
92 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
93 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
94 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
95 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
96 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
97 BuildRequires:  xorg-proto-fontcacheproto-devel
98 BuildRequires:  xorg-proto-fontsproto-devel
99 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
100 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
101 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
102 BuildRequires:  xorg-proto-printproto-devel
103 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
104 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
105 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
106 BuildRequires:  xorg-proto-resourceproto-devel
107 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
108 BuildRequires:  xorg-proto-videoproto-devel
109 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
110 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
111 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
112 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
113 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
114 BuildRequires:  xorg-proto-xf86miscproto-devel
115 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
116 BuildRequires:  xorg-proto-xineramaproto-devel
117 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
118 BuildRequires:  xorg-sgml-doctools >= 1.5
119 BuildRequires:  xorg-util-util-macros >= 1.10
120 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
121 #BR: xcalibrateproto, tslib (for KDRIVE only)
122 Requires(triggerpostun):        sed >= 4.0
123 Requires:       pixman >= 0.16.0
124 Requires:       xkeyboard-config
125 # for rgb.txt
126 Requires:       xorg-app-rgb >= 0.99.3
127 Requires:       xorg-app-xkbcomp
128 %{?with_hal:Suggests:   hal}
129 Suggests:       udev-acl
130 %{?with_udev:Suggests:  udev-core >= 1:143}
131 Suggests:       xorg-driver-input-evdev
132 # xserver requires fixed and cursor fonts
133 Requires:       xorg-font-font-alias
134 Requires:       xorg-font-font-cursor-misc
135 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
136 Suggests:       dbus-x11 >= 1.0
137 Suggests:       xkeyboard-config
138 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
139 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
140 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
141 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
142 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
143 Obsoletes:      X11-Xserver < 1:7.0.0
144 Obsoletes:      X11-driver-i2c < 1:7.0.0
145 Obsoletes:      X11-modules < 1:7.0.0
146 Obsoletes:      X11-setup < 1:7.0.0
147 Obsoletes:      XFree86-Xserver < 1:7.0.0
148 Obsoletes:      XFree86-modules < 1:7.0.0
149 Obsoletes:      XFree86-setup < 1:7.0.0
150 Obsoletes:      Xserver
151 Obsoletes:      xorg-xserver-server-xorgcfg
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 # avoid self-dependencies on included modules
155 %define         _noautoreq      libscanpci.so libxf1bpp.so
156
157 %if %{with multigl}
158 # executable Xorg provides symbols this library:
159 %define         skip_post_check_so      libglx.so.*
160 %endif
161
162 %description
163 Xorg server is a generally used X server which uses display hardware.
164 It requires proper driver for your display hardware.
165
166 %description -l pl.UTF-8
167 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
168 graficznej. Do działania wymaga odpowiedniego sterownika.
169
170 %package -n xorg-xserver-Xdmx
171 Summary:        Xdmx - distributed multi-head X server
172 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
173 Group:          X11/Servers
174
175 %description -n xorg-xserver-Xdmx
176 Xdmx - distributed multi-head X server.
177
178 %description -n xorg-xserver-Xdmx -l pl.UTF-8
179 Xdmx - rozproszony, wielomonitorowy serwer X.
180
181 %package -n xorg-xserver-Xnest
182 Summary:        Xnest - nested X server
183 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
184 Group:          X11/Servers
185 Obsoletes:      X11-Xnest < 1:7.0.0
186 Obsoletes:      XFree86-Xnest < 1:7.0.0
187 Obsoletes:      Xserver-Xnest
188
189 %description -n xorg-xserver-Xnest
190 Xnest is an X Window System server which runs in an X window. Xnest is
191 a 'nested' window server, actually a client of the real X server,
192 which manages windows and graphics requests for Xnest, while Xnest
193 manages the windows and graphics requests for its own clients.
194
195 %description -n xorg-xserver-Xnest -l pl.UTF-8
196 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
197 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
198 serwer X dla własnych klientów.
199
200 %description -n xorg-xserver-Xnest -l ru.UTF-8
201 Xnest - это сервер X Window System, который работает в окне X. На
202 самом деле это клиент реального X-сервера, который управляет окнами и
203 графическими запросами для Xnest в то время, как Xnest управляет
204 окнами и графическими запросами для своих собственных клиентов.
205
206 %description -n xorg-xserver-Xnest -l uk.UTF-8
207 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
208 клієнт реального X-сервера, який керує вікнами та графічними запитами
209 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
210 своїх власних клієнтів.
211
212 %package -n xorg-xserver-Xephyr
213 Summary:        Xephyr - nested X server
214 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
215 Group:          X11/Servers
216 Requires:       pixman >= 0.16.0
217
218 %description -n xorg-xserver-Xephyr
219 Xephyr is a a kdrive server that outputs to a window on a pre-existing
220 'host' X display. Think Xnest but with support for modern extensions
221 like composite, damage and randr.
222
223 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
224 the host X server, Xephyr is a real X server which uses the host X
225 server window as "framebuffer" via fast SHM XImages.
226
227 It also has support for 'visually' debugging what the server is
228 painting.
229
230 %description -n xorg-xserver-Xephyr -l pl.UTF-8
231 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
232 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
233 wspólczesnych rozszerzeń jak composite, damage i randr.
234
235 %package -n xorg-xserver-Xfbdev
236 Summary:        Xfbdev - Linux framebuffer device X server
237 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
238 Group:          X11/Servers
239
240 %description -n xorg-xserver-Xfbdev
241 Xfbdev is a Linux framebuffer device X server based on the kdrive X
242 server.
243
244 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
245 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
246
247 %package -n xorg-xserver-Xvfb
248 Summary:        Xvfb - virtual framebuffer X server
249 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
250 Group:          X11/Servers
251 # requires fixed and cursor fonts
252 Requires:       xorg-font-font-alias
253 Requires:       xorg-font-font-cursor-misc
254 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
255 Obsoletes:      X11-Xvfb < 1:7.0.0
256 Obsoletes:      XFree86-Xvfb < 1:7.0.0
257
258 %description -n xorg-xserver-Xvfb
259 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
260 capable of running on machines with no display hardware and no
261 physical input devices. Xvfb emulates a dumb framebuffer using virtual
262 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
263 display. Xvfb is normally used for testing servers. Using Xvfb, the
264 mfb or cfb code for any depth can be exercised without using real
265 hardware that supports the desired depths. Xvfb has also been used to
266 test X clients against unusual depths and screen configurations, to do
267 batch processing with Xvfb as a background rendering engine, to do
268 load testing, to help with porting an X server to a new platform, and
269 to provide an unobtrusive way of running applications which really
270 don't need an X server but insist on having one.
271
272 %description -n xorg-xserver-Xvfb -l pl.UTF-8
273 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
274 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
275 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
276 używany do testowania serwerów X, może też być używany do testowania
277 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
278 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
279 serwera X, ale odmawiają uruchomienia bez niego.
280
281 %package -n xorg-xserver-Xvfb-init
282 Summary:        Init scripts for Xvfb
283 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
284 Group:          X11/Servers
285 Requires:       xorg-xserver-Xvfb
286
287 %description -n xorg-xserver-Xvfb-init
288 This package contains init scripts for Xvfb and registers Xvfb as
289 system service.
290
291 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
292 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
293 usługę systemową.
294
295 %package devel
296 Summary:        Header files for X.org server
297 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
298 Group:          X11/Development/Libraries
299 Requires:       libdrm-devel >= 2.4.5
300 Requires:       pixman-devel >= 0.16.0
301 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
302 Requires:       xorg-lib-libxkbfile-devel
303 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.3}
304 Requires:       xorg-proto-fontsproto-devel
305 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
306 Requires:       xorg-proto-kbproto-devel >= 1.0.3
307 Requires:       xorg-proto-randrproto-devel >= 1.3
308 Requires:       xorg-proto-renderproto-devel >= 0.11
309 Requires:       xorg-proto-videoproto-devel
310 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
311 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
312 Requires:       xorg-proto-xineramaproto-devel
313 Requires:       xorg-proto-xproto-devel >= 7.0.17
314 Obsoletes:      X11-Xserver-devel < 1:7.0.0
315 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
316
317 %description devel
318 Header files for X.org server.
319
320 %description devel -l pl.UTF-8
321 Pliki nagłówkowe dla serwera X.org.
322
323 %package source
324 Summary:        X.org server source code
325 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
326 Group:          X11/Development/Libraries
327
328 %description source
329 X.org server source code.
330
331 %description source -l pl.UTF-8
332 Pliki źródłowe dla serwera X.org.
333
334 %package -n xorg-xserver-libdri
335 Summary:        DRI extension library for X.org server
336 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
337 Group:          X11/Servers
338 Requires:       %{name} = %{version}-%{release}
339 Provides:       xorg-xserver-module(dri)
340 %if %{without multigl}
341 Conflicts:      xorg-driver-video-fglrx
342 Conflicts:      xorg-driver-video-nvidia
343 %endif
344
345 %description -n xorg-xserver-libdri
346 DRI extension library for X.org server.
347
348 %description -n xorg-xserver-libdri -l pl.UTF-8
349 Biblioteka rozszerzenia DRI dla serwera X.org.
350
351 %package -n xorg-xserver-libglx
352 Summary:        GLX extension library for X.org server
353 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
354 Group:          X11/Servers
355 Requires:       %{name} = %{version}-%{release}
356 Requires:       xorg-xserver-libdri = %{version}-%{release}
357 # Mesa version glapi tables in glx/ dir come from
358 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
359 Provides:       xorg-xserver-module(glx)
360 Obsoletes:      X11-OpenGL-core < 1:7.0.0
361 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
362 %if %{without multigl}
363 Conflicts:      xorg-driver-video-fglrx
364 Conflicts:      xorg-driver-video-nvidia
365 %endif
366
367 %description -n xorg-xserver-libglx
368 GLX extension library for X.org server.
369
370 %description -n xorg-xserver-libglx -l pl.UTF-8
371 Biblioteka rozszerzenia GLX dla serwera X.org.
372
373 %prep
374 %setup -q -n xorg-server-%{version}
375 %patch0 -p0
376 %patch1 -p1
377 %patch2 -p1
378 %patch3 -p1
379 %patch4 -p1
380
381 # xserver uses pixman-1 API/ABI so put that explictly here
382 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
383
384 %build
385 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
386 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
387         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
388         exit 1
389 fi
390
391 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
392 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
393         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
394         exit 1
395 fi
396
397 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
398 if [ $API != %{xorg_xserver_server_font_abi} ]; then
399         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
400         exit 1
401 fi
402 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
403 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
404         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
405         exit 1
406 fi
407 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
408 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
409         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
410         exit 1
411 fi
412
413 %{__libtoolize}
414 %{__aclocal} -I m4
415 %{__autoconf}
416 %{__autoheader}
417 %{__automake}
418 %configure \
419         --with-os-name="PLD/Linux" \
420         --with-os-vendor="PLD/Team" \
421         --without-fop \
422         %{?with_dbus:--enable-config-dbus} \
423         --enable-config-hal%{!?with_hal:=no} \
424         --enable-config-udev%{!?with_udev:=no} \
425         --enable-aiglx \
426         --enable-builddocs \
427         --enable-dga \
428         %{?with_dmx:--enable-dmx} \
429         --enable-glx-tls \
430         --enable-install-libxf86config \
431         %{?with_record:--enable-record} \
432         --enable-kdrive \
433         %{?with_xcsecurity:--enable-xcsecurity} \
434         --enable-xephyr \
435         %{?with_xf86bigfont:--enable-xf86bigfont} \
436         --enable-xfbdev \
437         %{?with_xselinux:--enable-xselinux} \
438         --enable-glx-tls \
439         --disable-xfake \
440         --enable-secure-rpc \
441         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
442         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
443         --with-xkb-output=/var/lib/xkb
444
445 %{__make}
446
447 %install
448 rm -rf $RPM_BUILD_ROOT
449
450 %{__make} install \
451         DESTDIR=$RPM_BUILD_ROOT
452
453 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
454 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
455 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
456 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
457
458 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
459 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
460
461 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
462
463 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
464
465 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
466 install -d $RPM_BUILD_ROOT/etc/sysconfig
467 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
468 install %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
469
470 %if %{with multigl}
471 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
472 mv -f libglx.so libglx.so.%{version}
473 ln -sf libglx.so.%{version} libglx.so
474 cd -
475 %endif
476
477 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
478 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
479 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
480 %{__make} distclean
481 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
482 find -name '*.h' | xargs chmod a-x
483
484 %clean
485 rm -rf $RPM_BUILD_ROOT
486
487 %if %{with multigl}
488 %post -n xorg-xserver-libglx
489 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
490         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
491 fi
492 %endif
493
494 %triggerpostun -- xorg-xserver-server < 1.5.0
495 if [ -f /etc/X11/xorg.conf ]; then
496         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
497         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
498 %if %{without record}
499         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
500 %endif
501         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
502 fi
503
504 %post -n xorg-xserver-Xvfb-init
505 /sbin/chkconfig --add Xvfb
506 %service Xvfb restart
507
508 %preun -n xorg-xserver-Xvfb-init
509 if [ "$1" = "0" ]; then
510         %service -q Xvfb stop
511         /sbin/chkconfig --del Xvfb
512 fi
513
514 %files
515 %defattr(644,root,root,755)
516 %doc COPYING ChangeLog README
517 %attr(755,root,root) %{_bindir}/X
518 %attr(755,root,root) %{_bindir}/Xorg
519 %attr(4755,root,root) %{_bindir}/Xwrapper
520 %attr(755,root,root) %{_bindir}/cvt
521 %attr(755,root,root) %{_bindir}/gtf
522 %dir %{_libdir}/xorg
523 %{_libdir}/xorg/protocol.txt
524 %dir %{_libdir}/xorg/modules
525 %dir %{_libdir}/xorg/modules/dri
526 %dir %{_libdir}/xorg/modules/drivers
527 %dir %{_libdir}/xorg/modules/extensions
528 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
529 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
530 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
531 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
532 %dir %{_libdir}/xorg/modules/input
533 %dir %{_libdir}/xorg/modules/multimedia
534 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
535 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
536 %dir /var/lib/xkb
537 /var/lib/xkb/README.compiled
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
540 %config(missingok) /etc/security/console.apps/xserver
541 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
542 %dir /etc/X11/xorg.conf.d
543 %dir %{_datadir}/X11/xorg.conf.d
544 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
545 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
546 %{_mandir}/man1/Xorg.1x*
547 %{_mandir}/man1/Xserver.1x*
548 %{_mandir}/man1/cvt.1*
549 %{_mandir}/man1/gtf.1x*
550 %{_mandir}/man4/exa.4*
551 %{_mandir}/man4/fbdevhw.4*
552 %{_mandir}/man5/xorg.conf.5x*
553 %{_mandir}/man5/xorg.conf.d.5x
554
555 %if %{with dmx}
556 %files -n xorg-xserver-Xdmx
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_bindir}/Xdmx
559 %attr(755,root,root) %{_bindir}/dmxaddinput
560 %attr(755,root,root) %{_bindir}/dmxaddscreen
561 %attr(755,root,root) %{_bindir}/dmxinfo
562 %attr(755,root,root) %{_bindir}/dmxreconfig
563 %attr(755,root,root) %{_bindir}/dmxresize
564 %attr(755,root,root) %{_bindir}/dmxrminput
565 %attr(755,root,root) %{_bindir}/dmxrmscreen
566 %attr(755,root,root) %{_bindir}/dmxtodmx
567 %attr(755,root,root) %{_bindir}/dmxwininfo
568 %attr(755,root,root) %{_bindir}/vdltodmx
569 %attr(755,root,root) %{_bindir}/xdmxconfig
570 %{_mandir}/man1/Xdmx.1x*
571 %{_mandir}/man1/dmxtodmx.1x*
572 %{_mandir}/man1/vdltodmx.1x*
573 %{_mandir}/man1/xdmxconfig.1x*
574 %endif
575
576 %files -n xorg-xserver-Xnest
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_bindir}/Xnest
579 %{_mandir}/man1/Xnest.1x*
580
581 %files -n xorg-xserver-Xephyr
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_bindir}/Xephyr
584 %{_mandir}/man1/Xephyr.1x*
585
586 %files -n xorg-xserver-Xfbdev
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_bindir}/Xfbdev
589
590 %files -n xorg-xserver-Xvfb
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/Xvfb
593 %{_mandir}/man1/Xvfb.1x*
594
595 %files -n xorg-xserver-Xvfb-init
596 %defattr(644,root,root,755)
597 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
598 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
599
600 %files devel
601 %defattr(644,root,root,755)
602 %doc doc/xml/Xserver-spec.html
603 %{_includedir}/xorg
604 %{_libdir}/libxf86config.a
605 %{_libdir}/libxf86config.la
606 %{_aclocaldir}/xorg-server.m4
607 %{_pkgconfigdir}/xorg-server.pc
608
609 %files source
610 %defattr(-,root,root,755)
611 %{_usrsrc}/%{name}-%{version}
612
613 %files -n xorg-xserver-libdri
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
616
617 %files -n xorg-xserver-libglx
618 %defattr(644,root,root,755)
619 %if %{with multigl}
620 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
621 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
622 %else
623 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
624 %endif
This page took 0.088846 seconds and 3 git commands to generate.