]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- libxfs1{,-devel} added to Obsoletes for allow upgrade from MDK.
[packages/xfsprogs.git] / xfsprogs.spec
1 # conditional build
2 #  --with static
3 Summary:        Tools for the XFS filesystem
4 Summary(pl):    Narzêdzia do systemu plików XFS
5 Name:           xfsprogs
6 Version:        2.0.1
7 Release:        3
8 License:        GPL
9 Group:          Applications/System
10 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-install-sh.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bash
16 BuildRequires:  e2fsprogs-devel
17 URL:            http://oss.sgi.com/projects/xfs/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      libxfs1
20
21 %description
22 A set of commands to use the XFS filesystem, including mkfs.xfs.
23
24 XFS is a high performance journaling filesystem which originated on
25 the SGI IRIX platform. It is completely multi-threaded, can support
26 large files and large filesystems, extended attributes, variable block
27 sizes, is extent based, and makes extensive use of Btrees
28 (directories, extents, free space) to aid both performance and
29 scalability.
30
31 This implementation is on-disk compatible with the IRIX version of
32 XFS.
33
34 %description -l pl
35 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
36
37 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
38 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
39 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
40 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
41 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
42
43 %package devel
44 Summary:        Header files and libraries to develop XFS software
45 Summary(pl):    Pliki nag³ówkowe i biblioteki
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}
48 Obsoletes:      libxfs1-devel
49
50 %description devel
51 Header files and libraries to develop software which operates on XFS
52 filesystems.
53
54 %description devel -l pl
55 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
56 operuj±cego na systemie plików XFS.
57
58 %package static
59 Summary:        Static XFS software libraries
60 Summary(pl):    Biblioteki statyczne do XFS
61 Group:          Development/Libraries
62
63 %description static
64 Static XFS software libraries.
65
66 %description static -l pl
67 Biblioteki statyczne do XFS.
68
69 %prep
70 %setup  -q
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
76 OPTIMIZER="%{rpmcflags}"
77 export DEBUG OPTIMIZER
78 aclocal
79 autoconf
80 %configure \
81         %{!?_with_static:--enable-shared-uuid=yes} \
82         %{?_with_static:--disable-shared --disable-shared-uuid}
83
84 %{__make} \
85         %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 DIST_ROOT="$RPM_BUILD_ROOT"
91 DIST_INSTALL=`pwd`/install.manifest
92 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
93 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
94 %{?_with_static:cp include/builddefs include/builddefs.tmp}
95 %{?_with_static:sed -e 's/\.lai/.la/' include/builddefs.tmp > include/builddefs}
96 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
97 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
98
99 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
100            fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
101            handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
102            readlink_by_handle.3; do
103                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
104                 echo ".so path_to_handle.3" \
105                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
106 done
107
108 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
109 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
110 ln -sf /lib/libhandle.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libhandle.so
111
112 gzip -9nf doc/{CHANGES,CREDITS,README.*}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc doc/*.gz
123 %attr(755,root,root) /sbin/*
124 %attr(755,root,root) %{_sbindir}/*
125 %{!?_with_static:%attr(755,root,root) /lib/lib*.so*}
126 %{_mandir}/man[185]/*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %{_mandir}/man3/*
131 %{_includedir}/xfs
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/*.a
This page took 0.046595 seconds and 4 git commands to generate.