]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- fixed libhandle.so symlink
[packages/xfsprogs.git] / xfsprogs.spec
1 # conditional build
2 #  --with static
3 Summary:        Tools for the XFS filesystem
4 Summary(pl):    Narzêdzia do systemu plików XFS
5 Name:           xfsprogs
6 Version:        2.1.2
7 Release:        1
8 License:        GPL
9 Group:          Applications/System
10 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-install-sh.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bash
16 BuildRequires:  e2fsprogs-devel
17 URL:            http://oss.sgi.com/projects/xfs/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      libxfs1
20
21 %define         _sbindir        /sbin
22 %define         _bindir         /usr/sbin
23 %define         _libdir         /lib
24 %define         _libexecdir     /usr/lib
25
26 %description
27 A set of commands to use the XFS filesystem, including mkfs.xfs.
28
29 XFS is a high performance journaling filesystem which originated on
30 the SGI IRIX platform. It is completely multi-threaded, can support
31 large files and large filesystems, extended attributes, variable block
32 sizes, is extent based, and makes extensive use of Btrees
33 (directories, extents, free space) to aid both performance and
34 scalability.
35
36 This implementation is on-disk compatible with the IRIX version of
37 XFS.
38
39 %description -l pl
40 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
41
42 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
43 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
44 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
45 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
46 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
47
48 %package devel
49 Summary:        Header files and libraries to develop XFS software
50 Summary(pl):    Pliki nag³ówkowe i biblioteki
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}
53 Obsoletes:      libxfs1-devel
54
55 %description devel
56 Header files and libraries to develop software which operates on XFS
57 filesystems.
58
59 %description devel -l pl
60 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
61 operuj±cego na systemie plików XFS.
62
63 %package static
64 Summary:        Static XFS software libraries
65 Summary(pl):    Biblioteki statyczne do XFS
66 Group:          Development/Libraries
67
68 %description static
69 Static XFS software libraries.
70
71 %description static -l pl
72 Biblioteki statyczne do XFS.
73
74 %prep
75 %setup  -q
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
81 OPTIMIZER="%{rpmcflags}"
82 export DEBUG OPTIMIZER
83 aclocal
84 %{__autoconf}
85 %configure \
86         %{!?_with_static:--enable-shared-uuid=yes} \
87         %{?_with_static:--disable-shared --disable-shared-uuid}
88
89 %{__make} \
90         %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 DIST_ROOT="$RPM_BUILD_ROOT"
96 DIST_INSTALL=`pwd`/install.manifest
97 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
98 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
99 %{?_with_static:cp include/builddefs include/builddefs.tmp}
100 %{?_with_static:sed -e 's/\.lai/.la/' include/builddefs.tmp > include/builddefs}
101 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
102 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
103
104 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
105            fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
106            handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
107            readlink_by_handle.3; do
108                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
109                 echo ".so path_to_handle.3" \
110                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
111 done
112
113 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
114 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
115
116 ln -sf %{_libdir}/libhandle.so.1.0.1 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc doc/{CHANGES,CREDITS,README.*}
127 %attr(755,root,root) %{_sbindir}*
128 %attr(755,root,root) %{_bindir}/*
129 %{!?_with_static:%attr(755,root,root) /lib/lib*.so.*.*}
130 %{_mandir}/man[185]/*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %{_mandir}/man3/*
135 %{_includedir}/disk
136 %{_includedir}/xfs
137 %{_libexecdir}/*.la
138 %attr(755,root,root) %{_libexecdir}/*.so
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libexecdir}/*.a
This page took 0.098375 seconds and 4 git commands to generate.