]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
up to 6.4.0
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  debug_asserts
4 %bcond_without  scrub
5 #
6 Summary:        Tools for the XFS filesystem
7 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
8 Name:           xfsprogs
9 Version:        6.4.0
10 Release:        1
11 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
12 Group:          Applications/System
13 Source0:        https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.xz
14 # Source0-md5:  81c09e5ea47412c3a109a316cf4dd39d
15 Source1:        xfs_lsprojid
16 Patch0:         %{name}-miscfix-v2.patch
17 Patch1:         %{name}-pl.po-update.patch
18 # Patch1-md5:   ec989fa2cc45cb5ff8b4cba2b5eb0fa7
19 URL:            https://xfs.wiki.kernel.org/
20 # for <attr/attributes.h>
21 BuildRequires:  attr-devel
22 BuildRequires:  autoconf >= 2.69
23 BuildRequires:  automake
24 BuildRequires:  bash
25 BuildRequires:  device-mapper-devel
26 BuildRequires:  gettext-tools
27 BuildRequires:  glibc-static
28 BuildRequires:  inih-devel
29 BuildRequires:  libblkid-devel
30 # without .la file so that -static-libtool-libs won't take libedit.a
31 BuildRequires:  libedit-devel >= 3.1-1.20191231.1
32 BuildRequires:  libicu-devel
33 BuildRequires:  libtool
34 BuildRequires:  libuuid-devel
35 BuildRequires:  libuuid-static
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpm >= 4.4.9-56
38 BuildRequires:  rpmbuild(macros) >= 1.402
39 %{?with_scrub:BuildRequires:    systemd-devel}
40 BuildRequires:  userspace-rcu-devel
41 BuildRequires:  userspace-rcu-static
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 Obsoletes:      xfsprogs-initrd < 3.1.11-2
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %if "%{pld_release}" == "ac"
49 # libtool in ac doesn't do the reordering of args properly
50 %define         filterout_ld -Wl,--as-needed
51 %endif
52
53 %description
54 A set of commands to use the XFS filesystem, including mkfs.xfs.
55
56 XFS is a high performance journaling filesystem which originated on
57 the SGI IRIX platform. It is completely multi-threaded, can support
58 large files and large filesystems, extended attributes, variable block
59 sizes, is extent based, and makes extensive use of Btrees
60 (directories, extents, free space) to aid both performance and
61 scalability.
62
63 This implementation is on-disk compatible with the IRIX version of
64 XFS.
65
66 %description -l pl.UTF-8
67 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
68
69 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
70 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
71 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
72 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
73 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
74
75 %package scrub
76 Summary:        xfs_scrub - XFS online check and repair feature (EXPERIMENTAL!)
77 Summary(pl.UTF-8):      xfs_scrub - sprawdzanie i naprawianie zamontowanego systemu plików XFS (EKSPERYMENTALNE!)
78 Group:          Applications/System
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       systemd-units >= 38
81
82 %description scrub
83 xfs_scrub is an XFS online check and repair feature.
84
85 WARNING: EXPERIMENTAL, use at your own risk!
86
87 %description scrub -l pl.UTF-8
88 xfs_scrub służy do sprawdzania i naprawiania zamontowanego systmeu
89 plików XFS w locie.
90
91 UWAGA: EXPERIMENTALNE, użycie na własne ryzyko!
92
93 %package devel
94 Summary:        Header files and libraries to develop XFS software
95 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       libuuid-devel
99 Requires:       linux-libc-headers
100
101 %description devel
102 Header files and libraries to develop software which operates on XFS
103 filesystems.
104
105 %description devel -l pl.UTF-8
106 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
107 operującego na systemie plików XFS.
108
109 %package static
110 Summary:        Static XFS software libraries
111 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 Static XFS software libraries.
117
118 %description static -l pl.UTF-8
119 Biblioteki statyczne do XFS.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125
126 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' scrub/xfs_scrub_all.in tools/xfsbuflock.py
127
128 %build
129 %{__aclocal} -I m4
130 %{__autoconf}
131 %configure \
132         DEBUG="%{?with_debug_asserts:-DDEBUG}%{!?with_debug_asserts:-DNDEBUG}" \
133         OPTIMIZER="%{rpmcflags}" \
134         --enable-blkid \
135         --enable-editline \
136         --enable-gettext \
137         --enable-libicu \
138         --disable-lto \
139         %{?with_scrub:--enable-scrub=yes}
140
141 %{__make} \
142         V=1
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT/etc/cron.d
147
148 DIST_ROOT=$RPM_BUILD_ROOT
149 DIST_INSTALL=$(pwd)/install.manifest
150 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
151 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
152
153 %{__make} install \
154         DIST_MANIFEST="$DIST_INSTALL"
155 %{__make} install-dev \
156         DIST_MANIFEST="$DIST_INSTALL_DEV"
157
158 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
159
160 # adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
161 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
162          $RPM_BUILD_ROOT%{_libdir}/libhandle.so
163 # adjust library path used at link time
164 %{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
165         $RPM_BUILD_ROOT%{_libdir}/libhandle.la
166 # already in /usr
167 %{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
168
169 # install cron file
170 %if %{with scrub}
171 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
172 %else
173 %{__rm} $RPM_BUILD_ROOT/%{_libdir}/%{name}/xfs_scrub_all.cron
174 %endif
175
176 # (config file paths are specified in libfrog/projects.c)
177 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
178 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
179
180 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
181
182 %find_lang %{name}
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %post scrub
191 %systemd_reload
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc README doc/{CHANGES,CREDITS}
196 %config(noreplace) %verify(not md5 mtime size) /etc/projects
197 %config(noreplace) %verify(not md5 mtime size) /etc/projid
198 %attr(755,root,root) /sbin/fsck.xfs
199 %attr(755,root,root) /sbin/mkfs.xfs
200 %attr(755,root,root) /sbin/xfs_repair
201 %attr(755,root,root) %{_sbindir}/xfs_*
202 %if %{with scrub}
203 %exclude %{_sbindir}/xfs_scrub*
204 %endif
205 %attr(755,root,root) /%{_lib}/libhandle.so.*.*
206 %attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
207 %{_datadir}/%{name}
208 %dir %{_libdir}/%{name}
209 %if %{with scrub}
210 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
211 %endif
212 %{_mandir}/man5/projects.5*
213 %{_mandir}/man5/projid.5*
214 %{_mandir}/man5/xfs.5*
215 %{_mandir}/man8/fsck.xfs.8*
216 %{_mandir}/man8/mkfs.xfs.8*
217 %{_mandir}/man8/xfs_*.8*
218 %if %{with scrub}
219 %exclude %{_mandir}/man8/xfs_scrub*.8*
220 %endif
221
222 %if %{with scrub}
223 %files scrub
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_sbindir}/xfs_scrub
226 %attr(755,root,root) %{_sbindir}/xfs_scrub_all
227 %{systemdunitdir}/xfs_scrub@.service
228 %{systemdunitdir}/xfs_scrub_all.service
229 %{systemdunitdir}/xfs_scrub_all.timer
230 %{systemdunitdir}/xfs_scrub_fail@.service
231 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
232 %{_mandir}/man8/xfs_scrub.8*
233 %{_mandir}/man8/xfs_scrub_all.8*
234 %endif
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/libhandle.so
239 %{_libdir}/libhandle.la
240 %{_includedir}/xfs
241 %{_mandir}/man2/ioctl_xfs_ag_geometry.2*
242 %{_mandir}/man2/ioctl_xfs_bulkstat.2*
243 %{_mandir}/man2/ioctl_xfs_fsbulkstat.2*
244 %{_mandir}/man2/ioctl_xfs_fscounts.2*
245 %{_mandir}/man2/ioctl_xfs_fsgeometry.2*
246 %{_mandir}/man2/ioctl_xfs_fsgetxattr.2*
247 %{_mandir}/man2/ioctl_xfs_fsgetxattra.2*
248 %{_mandir}/man2/ioctl_xfs_fsinumbers.2*
249 %{_mandir}/man2/ioctl_xfs_fssetxattr.2*
250 %{_mandir}/man2/ioctl_xfs_getbmap.2*
251 %{_mandir}/man2/ioctl_xfs_getbmapa.2*
252 %{_mandir}/man2/ioctl_xfs_getbmapx.2*
253 %{_mandir}/man2/ioctl_xfs_getresblks.2*
254 %{_mandir}/man2/ioctl_xfs_goingdown.2*
255 %{_mandir}/man2/ioctl_xfs_inumbers.2*
256 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
257 %{_mandir}/man2/ioctl_xfs_setresblks.2*
258 %{_mandir}/man3/*handle.3*
259 %{_mandir}/man3/xfsctl.3*
260
261 %files static
262 %defattr(644,root,root,755)
263 %{_libdir}/libhandle.a
This page took 0.96157 seconds and 4 git commands to generate.