]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- add link to libhandle.so
[packages/xfsprogs.git] / xfsprogs.spec
1 # conditional build
2 #  --with static
3 Summary:        Tools for the XFS filesystem
4 Summary(pl):    Narzêdzia do systemu plików XFS
5 Name:           xfsprogs
6 Version:        2.0.1
7 Release:        2
8 License:        GPL
9 Group:          Applications/System
10 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-install-sh.patch
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bash
16 BuildRequires:  e2fsprogs-devel
17 URL:            http://oss.sgi.com/projects/xfs/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 A set of commands to use the XFS filesystem, including mkfs.xfs.
22
23 XFS is a high performance journaling filesystem which originated on
24 the SGI IRIX platform. It is completely multi-threaded, can support
25 large files and large filesystems, extended attributes, variable block
26 sizes, is extent based, and makes extensive use of Btrees
27 (directories, extents, free space) to aid both performance and
28 scalability.
29
30 This implementation is on-disk compatible with the IRIX version of
31 XFS.
32
33 %description -l pl
34 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
35
36 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
37 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
38 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
39 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
40 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
41
42 %package devel
43 Summary:        Header files and libraries to develop XFS software
44 Summary(pl):    Pliki nag³ówkowe i biblioteki
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}
47
48 %description devel
49 Header files and libraries to develop software which operates on XFS
50 filesystems.
51
52 %description devel -l pl
53 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
54 operuj±cego na systemie plików XFS.
55
56 %package static
57 Summary:        Static XFS software libraries
58 Summary(pl):    Biblioteki statyczne do XFS
59 Group:          Development/Libraries
60
61 %description static
62 Static XFS software libraries.
63
64 %description static -l pl
65 Biblioteki statyczne do XFS.
66
67 %prep
68 %setup  -q
69 %patch0 -p1
70 %patch1 -p1
71
72 %build
73 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
74 OPTIMIZER="%{rpmcflags}"
75 export DEBUG OPTIMIZER
76 aclocal
77 autoconf
78 %configure \
79         %{!?_with_static:--enable-shared-uuid=yes} \
80         %{?_with_static:--disable-shared --disable-shared-uuid}
81
82 %{__make} \
83         %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 DIST_ROOT="$RPM_BUILD_ROOT"
89 DIST_INSTALL=`pwd`/install.manifest
90 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
91 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
92 %{?_with_static:cp include/builddefs include/builddefs.tmp}
93 %{?_with_static:sed -e 's/\.lai/.la/' include/builddefs.tmp > include/builddefs}
94 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
95 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
96
97 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
98            fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
99            handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
100            readlink_by_handle.3; do
101                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
102                 echo ".so man3/path_to_handle.3" \
103                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
104 done
105
106 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
107 echo ".so man8/xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
108 ln -sf /lib/libhandle.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libhandle.so
109
110 gzip -9nf doc/{CHANGES,CREDITS,README.*}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc doc/*.gz
121 %attr(755,root,root) /sbin/*
122 %attr(755,root,root) %{_sbindir}/*
123 %{!?_with_static:%attr(755,root,root) /lib/lib*.so*}
124 %{_mandir}/man[185]/*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %{_mandir}/man3/*
129 %{_includedir}/xfs
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/*.a
This page took 0.04396 seconds and 4 git commands to generate.