]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 4.19.0
[packages/xfsprogs.git] / xfsprogs.spec
1 %bcond_without  debug_asserts
2 #
3 Summary:        Tools for the XFS filesystem
4 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
5 Name:           xfsprogs
6 Version:        4.19.0
7 Release:        1
8 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
9 Group:          Applications/System
10 Source0:        https://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
11 # Source0-md5:  955b3dad9cbe01d6b21a562cc0100e04
12 Source1:        xfs_lsprojid
13 Patch0:         %{name}-miscfix-v2.patch
14 Patch1:         %{name}-pl.po-update.patch
15 URL:            http://www.xfs.org/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  bash
19 BuildRequires:  gettext-tools
20 BuildRequires:  glibc-static
21 BuildRequires:  libblkid-devel
22 BuildRequires:  libtool
23 BuildRequires:  libuuid-devel
24 BuildRequires:  libuuid-static
25 BuildRequires:  readline-devel
26 BuildRequires:  rpm >= 4.4.9-56
27 BuildRequires:  rpmbuild(macros) >= 1.402
28 BuildRequires:  sed >= 4.0
29 Obsoletes:      xfsprogs-initrd
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %if "%{pld_release}" == "ac"
33 # libtool in ac doesn't do the reordering of args properly
34 %define         filterout_ld -Wl,--as-needed
35 %endif
36
37 %description
38 A set of commands to use the XFS filesystem, including mkfs.xfs.
39
40 XFS is a high performance journaling filesystem which originated on
41 the SGI IRIX platform. It is completely multi-threaded, can support
42 large files and large filesystems, extended attributes, variable block
43 sizes, is extent based, and makes extensive use of Btrees
44 (directories, extents, free space) to aid both performance and
45 scalability.
46
47 This implementation is on-disk compatible with the IRIX version of
48 XFS.
49
50 %description -l pl.UTF-8
51 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
52
53 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
54 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
55 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
56 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
57 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
58
59 %package scrub
60 Summary:        xfs_scrub - XFS online check and repair feature (EXPERIMENTAL!)
61 Summary(pl.UTF-8):      xfs_scrub - sprawdzanie i naprawianie zamontowanego systemu plików XFS (EKSPERYMENTALNE!)
62 Group:          Applications/System
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       systemd-units >= 38
65
66 %description scrub
67 xfs_scrub is an XFS online check and repair feature.
68
69 WARNING: EXPERIMENTAL, use at your own risk!
70
71 %description scrub -l pl.UTF-8
72 xfs_scrub służy do sprawdzania i naprawiania zamontowanego systmeu
73 plików XFS w locie.
74
75 UWAGA: EXPERIMENTALNE, użycie na własne ryzyko!
76
77 %package devel
78 Summary:        Header files and libraries to develop XFS software
79 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       libuuid-devel
83
84 %description devel
85 Header files and libraries to develop software which operates on XFS
86 filesystems.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
90 operującego na systemie plików XFS.
91
92 %package static
93 Summary:        Static XFS software libraries
94 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static XFS software libraries.
100
101 %description static -l pl.UTF-8
102 Biblioteki statyczne do XFS.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108
109 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' scrub/xfs_scrub_all.in tools/xfsbuflock.py
110
111 %build
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %configure \
115         DEBUG="%{?with_debug_asserts:-DDEBUG}%{!?with_debug_asserts:-DNDEBUG}" \
116         OPTIMIZER="%{rpmcflags}" \
117         --enable-lto=no \
118         --enable-blkid \
119         --enable-gettext \
120         --enable-readline
121
122 %{__make} -j1 \
123         V=1
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT/etc/cron.d
128
129 DIST_ROOT=$RPM_BUILD_ROOT
130 DIST_INSTALL=$(pwd)/install.manifest
131 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
132 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
133
134 %{__make} install \
135         DIST_MANIFEST="$DIST_INSTALL"
136 %{__make} install-dev \
137         DIST_MANIFEST="$DIST_INSTALL_DEV"
138
139 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
140
141 # adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
142 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
143          $RPM_BUILD_ROOT%{_libdir}/libhandle.so
144 # adjust library path used at link time
145 %{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
146         $RPM_BUILD_ROOT%{_libdir}/libhandle.la
147 # already in /usr
148 %{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
149
150 # install cron file
151 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
152
153 # (config file paths are specified in libfrog/projects.c)
154 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
155 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
156
157 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
158
159 %find_lang %{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post   -p /sbin/ldconfig
165 %postun -p /sbin/ldconfig
166
167 %post scrub
168 %systemd_reload
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc README doc/{CHANGES,CREDITS}
173 %config(noreplace) %verify(not md5 mtime size) /etc/projects
174 %config(noreplace) %verify(not md5 mtime size) /etc/projid
175 %attr(755,root,root) /sbin/fsck.xfs
176 %attr(755,root,root) /sbin/mkfs.xfs
177 %attr(755,root,root) /sbin/xfs_repair
178 %attr(755,root,root) %{_sbindir}/xfs_*
179 %attr(755,root,root) /%{_lib}/libhandle.so.*.*
180 %attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
181 %dir %{_libdir}/%{name}
182 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
183 %{_mandir}/man5/projects.5*
184 %{_mandir}/man5/projid.5*
185 %{_mandir}/man5/xfs.5*
186 %{_mandir}/man8/fsck.xfs.8*
187 %{_mandir}/man8/mkfs.xfs.8*
188 %{_mandir}/man8/xfs_*.8*
189 %exclude %{_mandir}/man8/xfs_scrub*.8*
190
191 %files scrub
192 %defattr(644,root,root,755)
193 %attr(755,root,root) /sbin/xfs_scrub
194 %attr(755,root,root) /sbin/xfs_scrub_all
195 %{systemdunitdir}/xfs_scrub@.service
196 %{systemdunitdir}/xfs_scrub_all.service
197 %{systemdunitdir}/xfs_scrub_all.timer
198 %{systemdunitdir}/xfs_scrub_fail@.service
199 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
200 %{_mandir}/man8/xfs_scrub.8*
201 %{_mandir}/man8/xfs_scrub_all.8*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libhandle.so
206 %{_libdir}/libhandle.la
207 %{_includedir}/xfs
208 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
209 %{_mandir}/man3/*handle.3*
210 %{_mandir}/man3/xfsctl.3*
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/libhandle.a
This page took 0.053583 seconds and 4 git commands to generate.