]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated to 2.7.11, removed obsolete cflags,xfs_db-segv patches
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # link statically with \-luuid
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl):    Narzêdzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        2.7.11
9 Release:        1
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
13 # Source0-md5:  d4a78fced98c0f3f32627a473e8e0a59
14 Source1:        %{name}-pl.po
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch1:         %{name}-install-sh.patch
17 Patch2:         %{name}-sharedlibs.patch
18 Patch3:         %{name}-po.patch
19 URL:            http://oss.sgi.com/projects/xfs/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bash
23 BuildRequires:  gettext-devel
24 BuildRequires:  libtool
25 BuildRequires:  libuuid-devel
26 %{?with_static:BuildRequires:   libuuid-static}
27 %{?with_static:BuildRequires:   sed >= 4.0}
28 Obsoletes:      libxfs1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sbindir        /sbin
32 %define         _bindir         /usr/sbin
33 %define         _libdir         /%{_lib}
34 %define         _libexecdir     /usr/%{_lib}
35
36 %description
37 A set of commands to use the XFS filesystem, including mkfs.xfs.
38
39 XFS is a high performance journaling filesystem which originated on
40 the SGI IRIX platform. It is completely multi-threaded, can support
41 large files and large filesystems, extended attributes, variable block
42 sizes, is extent based, and makes extensive use of Btrees
43 (directories, extents, free space) to aid both performance and
44 scalability.
45
46 This implementation is on-disk compatible with the IRIX version of
47 XFS.
48
49 %description -l pl
50 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
51
52 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
53 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
54 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
55 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
56 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
57
58 %package devel
59 Summary:        Header files and libraries to develop XFS software
60 Summary(pl):    Pliki nag³ówkowe i biblioteki
61 Group:          Development/Libraries
62 Requires:       libuuid-devel
63 Requires:       %{name} = %{version}-%{release}
64 Obsoletes:      libxfs1-devel
65
66 %description devel
67 Header files and libraries to develop software which operates on XFS
68 filesystems.
69
70 %description devel -l pl
71 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
72 operuj±cego na systemie plików XFS.
73
74 %package static
75 Summary:        Static XFS software libraries
76 Summary(pl):    Biblioteki statyczne do XFS
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static XFS software libraries.
82
83 %description static -l pl
84 Biblioteki statyczne do XFS.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92
93 cp %{SOURCE1} po/pl.po
94
95 %build
96 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
97 OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
98 export DEBUG OPTIMIZER
99 rm -f aclocal.m4
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %configure \
103         %{!?with_static:--enable-shared-uuid=yes} \
104         %{?with_static:--disable-shared --disable-shared-uuid}
105
106 %{__make} \
107         %{?with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 DIST_ROOT="$RPM_BUILD_ROOT"
113 DIST_INSTALL=`pwd`/install.manifest
114 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
115 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
116 %{?with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
117
118 %{__make} install \
119         DIST_MANIFEST="$DIST_INSTALL"
120 %{__make} install-dev \
121         DIST_MANIFEST="$DIST_INSTALL_DEV"
122
123 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
124         fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
125         handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
126         readlink_by_handle.3; do
127                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
128                 echo ".so path_to_handle.3" \
129                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
130 done
131
132 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
133 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
134
135 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
136          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
137 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
138         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
139 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
140         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
141 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
142         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
143
144 %{__sed} -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
145         $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xfs,xlog}.la
146
147 %find_lang %{name}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc README doc/{CHANGES,CREDITS}
158 %attr(755,root,root) %{_sbindir}/*
159 %attr(755,root,root) %{_bindir}/*
160 %{!?with_static:%attr(755,root,root) /%{_lib}/lib*.so.*.*}
161 %{_mandir}/man[185]/*
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{_mandir}/man3/*
166 %{_includedir}/disk
167 %{_includedir}/xfs
168 %if %{without static}
169 %{_libexecdir}/*.la
170 %attr(755,root,root) %{_libexecdir}/*.so
171 %endif
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libexecdir}/*.a
This page took 0.071525 seconds and 4 git commands to generate.