]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- massive attack, adding Source-md5
[packages/xfsprogs.git] / xfsprogs.spec
1 # conditional build
2 #  --with static
3 Summary:        Tools for the XFS filesystem
4 Summary(pl):    Narzêdzia do systemu plików XFS
5 Name:           xfsprogs
6 Version:        2.3.9
7 Release:        1
8 License:        GPL
9 Group:          Applications/System
10 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
11 # Source0-md5: 54aa76cfa24e8b3d3dec9432269fbc5a
12 Patch0:         %{name}-miscfix-v2.patch
13 Patch1:         %{name}-install-sh.patch
14 Patch2:         %{name}-sharedlibs.patch
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  bash
18 BuildRequires:  libtool
19 BuildRequires:  e2fsprogs-devel
20 %{?_with_static:BuildRequires:  e2fsprogs-static}
21 URL:            http://oss.sgi.com/projects/xfs/
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23 Obsoletes:      libxfs1
24
25 %define         _sbindir        /sbin
26 %define         _bindir         /usr/sbin
27 %define         _libdir         /lib
28 %define         _libexecdir     /usr/lib
29
30 %description
31 A set of commands to use the XFS filesystem, including mkfs.xfs.
32
33 XFS is a high performance journaling filesystem which originated on
34 the SGI IRIX platform. It is completely multi-threaded, can support
35 large files and large filesystems, extended attributes, variable block
36 sizes, is extent based, and makes extensive use of Btrees
37 (directories, extents, free space) to aid both performance and
38 scalability.
39
40 This implementation is on-disk compatible with the IRIX version of
41 XFS.
42
43 %description -l pl
44 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
45
46 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
47 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
48 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
49 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
50 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
51
52 %package devel
53 Summary:        Header files and libraries to develop XFS software
54 Summary(pl):    Pliki nag³ówkowe i biblioteki
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}
57 Obsoletes:      libxfs1-devel
58
59 %description devel
60 Header files and libraries to develop software which operates on XFS
61 filesystems.
62
63 %description devel -l pl
64 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
65 operuj±cego na systemie plików XFS.
66
67 %package static
68 Summary:        Static XFS software libraries
69 Summary(pl):    Biblioteki statyczne do XFS
70 Group:          Development/Libraries
71
72 %description static
73 Static XFS software libraries.
74
75 %description static -l pl
76 Biblioteki statyczne do XFS.
77
78 %prep
79 %setup  -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83
84 %build
85 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
86 OPTIMIZER="%{rpmcflags}"
87 export DEBUG OPTIMIZER
88 %{__aclocal}
89 %{__autoconf}
90 %configure \
91         %{!?_with_static:--enable-shared-uuid=yes} \
92         %{?_with_static:--disable-shared --disable-shared-uuid}
93
94 %{__make} \
95         %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 DIST_ROOT="$RPM_BUILD_ROOT"
101 DIST_INSTALL=`pwd`/install.manifest
102 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
103 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
104 %{?_with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
105 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
106 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
107
108 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
109            fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
110            handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
111            readlink_by_handle.3; do
112                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
113                 echo ".so path_to_handle.3" \
114                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
115 done
116
117 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
118 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
119
120 ln -sf %{_libdir}/libhandle.so.1.0.1 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
121 ln -sf %{_libdir}/libdisk.so.0.0.0 $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
122 ln -sf %{_libdir}/libxfs.so.0.0.0 $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
123 ln -sf %{_libdir}/libxlog.so.0.0.0 $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc doc/{CHANGES,CREDITS,README.*}
134 %attr(755,root,root) %{_sbindir}*
135 %attr(755,root,root) %{_bindir}/*
136 %{!?_with_static:%attr(755,root,root) /lib/lib*.so.*.*}
137 %{_mandir}/man[185]/*
138
139 %files devel
140 %defattr(644,root,root,755)
141 %{_mandir}/man3/*
142 %{_includedir}/disk
143 %{_includedir}/xfs
144 %{!?_with_static:%{_libexecdir}/*.la}
145 %attr(755,root,root) %{_libexecdir}/*.so
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libexecdir}/*.a
This page took 0.033476 seconds and 3 git commands to generate.