]> git.pld-linux.org Git - packages/xerces-c.git/blob - xerces-c.spec
- added support for iso-8859-2
[packages/xerces-c.git] / xerces-c.spec
1 Summary:        XML parser
2 Summary(pl):    Parser XML
3 Name:           xerces-c
4 Version:        2.2.0
5 %define ver     %(echo %{version} | tr . _)
6 Release:        1
7 License:        Apache
8 Group:          Applications/Publishing/XML
9 Source0:        http://xml.apache.org/dist/xerces-c/stable/%{name}-src%{ver}.tar.gz
10 Patch0:         %{name}-iso88592.patch
11 URL:            http://xml.apache.org/
12 BuildRequires:  autoconf
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 XML parser.
18
19 %description -l pl
20 Parser XML.
21
22 %package devel
23 Summary:        %{name} header files
24 Summary(pl):    Pliki nag³ówkowe %{name}
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}
27
28 %description devel
29 %{name} header files.
30
31 %description devel -l pl
32 Pliki nag³ówkowe %{name}.
33
34 %package doc
35 Summary:        Extensive %{name} documentation
36 Summary(pl):    Obszerna dokumentacja %{name}
37 Group:          Documentation
38
39 %description doc
40 Extensive %{name} documentation and examples.
41
42 %description doc -l pl
43 Obszerna dokumentacja oraz przyk³ady %{name}.
44
45 %prep
46 %setup -q -n xerces-c-src%{ver}
47 %patch0 -p1
48
49 %build
50 ## What a shit!!!
51 XERCESCROOT=`pwd`; export XERCESCROOT
52 cd src/xercesc
53 %{__autoconf}
54 chmod 755 runConfigure
55 ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthread \
56         -z%(echo %{rpmcflags} | sed -e 's/\(.\) \+\(.\)/\1 -z\2/g')
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_examplesdir}/%{name}-%{version}}
63
64 # Only one file?
65 install lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
66
67 # I put all stuff from that dir, maybe some can be omitted
68 cp -a include/xercesc $RPM_BUILD_ROOT%{_includedir}
69
70 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc LICENSE.txt credits.txt
81 %attr(755,root,root) %{_libdir}/lib*.so
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/*
86
87 %files doc
88 %defattr(644,root,root,755)
89 %doc doc/html
90 %{_examplesdir}/%{name}-%{version}
This page took 0.039318 seconds and 4 git commands to generate.