]> git.pld-linux.org Git - packages/xerces-c.git/blob - xerces-c.spec
- strict internal deps
[packages/xerces-c.git] / xerces-c.spec
1 %define ver     %(echo %{version} | tr . _)
2 Summary:        XML parser
3 Summary(pl):    Analizator sk³adniowy XML-a
4 Name:           xerces-c
5 Version:        2.7.0
6 Release:        2
7 License:        Apache
8 Group:          Applications/Publishing/XML
9 Source0:        http://www.apache.org/dist/xml/xerces-c/source/%{name}-src_%{ver}.tar.gz
10 # Source0-md5:  04169609449a8846bc1e6891c04cadf4
11 Patch0:         %{name}-iso88592.patch
12 Patch1:         %{name}-link.patch
13 Patch2:         %{name}-opt.patch
14 Patch3:         %{name}-lib64.patch
15 URL:            http://xml.apache.org/
16 BuildRequires:  autoconf
17 BuildRequires:  libstdc++-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 XML parser.
22
23 %description -l pl
24 Analizator sk³adniowy XML-a.
25
26 %package devel
27 Summary:        %{name} header files
28 Summary(pl):    Pliki nag³ówkowe %{name}
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       libstdc++-devel
32
33 %description devel
34 %{name} header files.
35
36 %description devel -l pl
37 Pliki nag³ówkowe %{name}.
38
39 %package doc
40 Summary:        Extensive %{name} documentation
41 Summary(pl):    Obszerna dokumentacja %{name}
42 Group:          Documentation
43
44 %description doc
45 Extensive %{name} documentation and examples.
46
47 %description doc -l pl
48 Obszerna dokumentacja oraz przyk³ady %{name}.
49
50 %prep
51 %setup -q -n %{name}-src_%{ver}
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55 %ifarch %{x8664}
56 %patch3 -p1
57 %endif
58
59 %build
60 ## What a shit!!!
61 XERCESCROOT=`pwd`; export XERCESCROOT
62 cd src/xercesc
63 %{__autoconf}
64 chmod 755 runConfigure
65 ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthread \
66         -z%(echo %{rpmcflags} | sed -e 's/\(.\) \+\(.\)/\1 -z\2/g')
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %{__make} -C src/xercesc install \
75         XERCESCROOT=`pwd` \
76         PREFIX=%{_prefix} \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc LICENSE.txt credits.txt
90 %attr(755,root,root) %{_libdir}/lib*.so.*.*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/lib*.so
95 %{_includedir}/*
96
97 %files doc
98 %defattr(644,root,root,755)
99 %doc doc/html
100 %{_examplesdir}/%{name}-%{version}
This page took 0.429036 seconds and 4 git commands to generate.