]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- twisted.protocols.http has moved to twisted.web.http.
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0.2
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 Patch0:         %{name}-twisted.patch
17 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
18 #Requires:      python-Twisted
19 Requires:       python-TwistedWeb
20 Requires:       ZopeInterface
21 BuildRequires:  curl-devel
22 BuildRequires:  python-devel
23 BuildRequires:  python-Twisted
24 BuildRequires:  bridge-utils
25 BuildRequires:  transfig
26 BuildRequires:  libidn-devel
27 BuildRequires:  zlib-devel
28 BuildRequires:  X11-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  tetex-format-latex
31 BuildRequires:  tetex-latex-psnfss
32 BuildRequires:  tetex-dvips
33 ExclusiveArch:  %{ix86}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This package contains the Xen hypervisor and Xen tools, needed to run
38 virtual machines on x86 systems, together with the kernel-xen*
39 packages. Information on how to use Xen can be found at the Xen
40 project pages.
41
42 Virtualisation can be used to run multiple versions or multiple Linux
43 distributions on one system, or to test untrusted applications in a
44 sandboxed environment. Note that the Xen technology is still in
45 development, and this RPM has received extremely little testing. Don't
46 be surprised if this RPM eats your data, drinks your coffee or makes
47 fun of you in front of your friends.
48
49 %description -l pl
50 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
51 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
52 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
53 projektu.
54
55 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
56 dystrybucji Linuksa na jednym systemie lub do testowaania nie
57 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
58 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
59 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
60 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
61
62 %package devel
63 Summary:        Header files for xen
64 Summary(pl):    Pliki nag³ówkowe xena
65 Group:          Development/Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67
68 %description devel
69 Header files for xen.
70
71 %description devel -l pl
72 Pliki nag³ówkowe xena.
73
74 %package static
75 Summary:        Static xen libraries
76 Summary(pl):    Statyczne biblioteki xena
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
79
80 %description static
81 Static xen libraries.
82
83 %description static -l pl
84 Statyczne biblioteki xena.
85
86 %package doc
87 Summary:        Xen documentation
88 Summary(pl):    Dokumentacja xena
89 Group:          Applications/System
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91
92 %description doc
93 Xen documentation.
94
95 %description doc -l pl
96 Dokumentacja xena.
97
98 %prep
99 %setup -q -n xen-2.0
100 %patch0 -p1 
101 chmod -R u+w .
102 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
103
104 %build
105 CFLAGS="%{rpmcflags}" \
106 CXXFLAGS="%{rpmcflags}" \
107 %{__make} xen tools docs \
108         CC="%{__cc}" \
109         CXX="%{__cxx}"
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install-xen install-tools install-docs \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
118 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
119 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
120
121 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
122
123 #install -d $RPM_BUILD_ROOT%{_mandir}
124 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
125
126 #install -d doc-html-install/{interface,user}
127 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
128 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
129
130 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
131
132 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
133 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
134 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
135
136 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
137 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
138
139 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
140 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
141 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/ldconfig
148 /sbin/chkconfig --add xend
149 /sbin/chkconfig --add xendomains
150
151 %postun -p /sbin/ldconfig
152
153 %preun
154 if [ "$1" = "0" ]; then
155 #       if [ -f /var/lock/subsys/xend ]; then
156 #               /etc/rc.d/init.d/xend stop 1>&2
157 #       fi
158         /sbin/chkconfig --del xend
159 #       if [ -f /var/lock/subsys/xendomains ]; then
160 #               /etc/rc.d/init.d/xendomains stop 1>&2
161 #       fi
162         /sbin/chkconfig --del xendomains
163 fi
164
165 %files
166 %defattr(644,root,root,755)
167 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
168 %doc COPYING ChangeLog README docs/misc/*
169 /boot/%{name}-%{version}-syms
170 /boot/%{name}-%{version}.gz
171 /boot/%{name}.gz
172 %attr(754,root,root) /etc/rc.d/init.d/*
173 %dir %{_sysconfdir}/xen
174 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
175 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
176 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
177 %dir %{_sysconfdir}/xen/auto
178 %dir %{_sysconfdir}/xen/scripts
179 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
180 %attr(755,root,root) %{_bindir}/*
181 %attr(755,root,root) %{_sbindir}/*
182 %attr(755,root,root) %{_libdir}/lib*.so.*
183 %{_libdir}/python/%{name}
184 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
185 %{_mandir}/man?/*
186 %dir %{_sharedstatedir}/xen
187 %dir %{_sharedstatedir}/xen/sv
188 %dir %{_sharedstatedir}/xen/xend-db
189 %dir %{_sharedstatedir}/xen/xend-db/domain
190 %dir %{_sharedstatedir}/xen/xend-db/vnet
191
192 %files devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/lib*.so
195 %{_includedir}/*
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/lib*.a
200
201 %files doc
202 %defattr(644,root,root,755)
203 %dir %{_datadir}/xen
204 %{_datadir}/xen/*.pdf
This page took 0.051148 seconds and 4 git commands to generate.