]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- stable on HEAD, devel on DEVEL...
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.6
8 Release:        0
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/xen-%{version}-src.tgz
13 # Source0-md5:  fcb4ea295b1ecbf7890d48bf721896a8
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
17 BuildRequires:  curl-devel
18 BuildRequires:  python-devel
19 BuildRequires:  python-Twisted
20 BuildRequires:  bridge-utils
21 BuildRequires:  transfig
22 BuildRequires:  libidn-devel
23 BuildRequires:  zlib-devel
24 BuildRequires:  X11-devel
25 BuildRequires:  ncurses-devel
26 BuildRequires:  tetex-format-latex
27 BuildRequires:  tetex-latex-psnfss
28 BuildRequires:  tetex-dvips
29 ExclusiveArch:  %{ix86}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This package contains the Xen hypervisor and Xen tools, needed to run
34 virtual machines on x86 systems, together with the kernel-xen*
35 packages. Information on how to use Xen can be found at the Xen
36 project pages.
37
38 Virtualisation can be used to run multiple versions or multiple Linux
39 distributions on one system, or to test untrusted applications in a
40 sandboxed environment. Note that the Xen technology is still in
41 development, and this RPM has received extremely little testing. Don't
42 be surprised if this RPM eats your data, drinks your coffee or makes
43 fun of you in front of your friends.
44
45 %description -l pl
46 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
47 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
48 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
49 projektu.
50
51 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
52 dystrybucji Linuksa na jednym systemie lub do testowaania nie
53 zaufanych aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e
54 technologia Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany.
55 Nie nale¿y byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê
56 czy bêdzie siê wy¶miewa³ w obecno¶ci przyjació³.
57
58 %package devel
59 Summary:        Header files for xen
60 Summary(pl):    Pliki nag³ówkowe xena
61 Group:          Development/Libraries
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63
64 %description devel
65 Header files for xen.
66
67 %description devel -l pl
68 Pliki nag³ówkowe xena.
69
70 %package static
71 Summary:        Static xen libraries
72 Summary(pl):    Statyczne biblioteki xena
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
75
76 %description static
77 Static xen libraries.
78
79 %description static -l pl
80 Statyczne biblioteki xena.
81
82 %package doc
83 Summary:        Xen documentation
84 Summary(pl):    Dokumentacja xena
85 Group:          Applications/System
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87
88 %description doc
89 Xen documentation.
90
91 %description doc -l pl
92 Dokumentacja xena.
93
94 %prep
95 %setup -q -n xen-2.0
96 chmod -R u+w .
97 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
98
99 %build
100 CFLAGS="%{rpmcflags}" \
101 CXXFLAGS="%{rpmcflags}" \
102 %{__make} xen tools docs \
103         CC="%{__cc}" \
104         CXX="%{__cxx}"
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install-xen install-tools install-docs \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
113 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
114 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
115
116 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
117
118 #install -d $RPM_BUILD_ROOT%{_mandir}
119 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
120
121 #install -d doc-html-install/{interface,user}
122 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
123 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
124
125 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
126
127 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
128 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
129 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
130
131 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
132 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 /sbin/ldconfig
139 /sbin/chkconfig --add xend
140 /sbin/chkconfig --add xendomains
141
142 %postun -p /sbin/ldconfig
143
144 %preun
145 if [ "$1" = "0" ]; then
146 #       if [ -f /var/lock/subsys/xend ]; then
147 #               /etc/rc.d/init.d/xend stop 1>&2
148 #       fi
149         /sbin/chkconfig --del xend
150 #       if [ -f /var/lock/subsys/xendomains ]; then
151 #               /etc/rc.d/init.d/xendomains stop 1>&2
152 #       fi
153         /sbin/chkconfig --del xendomains
154 fi
155
156 %files
157 %defattr(644,root,root,755)
158 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
159 %doc COPYING ChangeLog README docs/misc/*
160 /boot/%{name}-%{version}-syms
161 /boot/%{name}-%{version}.gz
162 /boot/%{name}.gz
163 %attr(754,root,root) /etc/rc.d/init.d/*
164 %dir %{_sysconfdir}/xen
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
166 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
167 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
168 %dir %{_sysconfdir}/xen/auto
169 %dir %{_sysconfdir}/xen/scripts
170 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
171 %attr(755,root,root) %{_bindir}/*
172 %attr(755,root,root) %{_sbindir}/*
173 %attr(755,root,root) %{_libdir}/lib*.so.*
174 %{_libdir}/python/%{name}
175 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
176 %{_mandir}/man?/*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/lib*.so
181 %{_includedir}/*
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/lib*.a
186
187 %files doc
188 %defattr(644,root,root,755)
189 %dir %{_datadir}/xen
190 %{_datadir}/xen/*.pdf
This page took 0.050884 seconds and 4 git commands to generate.