]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- fixes xen Python scripts' headers (#!/usr/bin/python instead of #!/usr/bin/env)
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        3.0.2
8 Release:        0.1
9 Epoch:          0
10 License:        GPL
11 Group:          Applications/System
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/%{name}-%{version}-src.tgz
13 # Source0-md5:  544eab940a0734a55459d648e5c3b224
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
17 BuildRequires:  XFree86-devel
18 BuildRequires:  curl-devel
19 BuildRequires:  libidn-devel
20 BuildRequires:  ncurses-devel
21 BuildRequires:  python-Twisted
22 BuildRequires:  python-devel
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 BuildRequires:  tetex-dvips
26 BuildRequires:  tetex-format-latex
27 BuildRequires:  tetex-latex-psnfss
28 BuildRequires:  transfig
29 BuildRequires:  which
30 BuildRequires:  zlib-devel
31 Requires(post,preun):   /sbin/chkconfig
32 Requires:       ZopeInterface
33 Requires:       bridge-utils
34 Requires:       losetup
35 Requires:       python-TwistedWeb
36 Requires:       rc-scripts
37 Requires:       kernel(xen) = %{version}
38 ExclusiveArch:  %{ix86}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This package contains the Xen hypervisor and Xen tools, needed to run
43 virtual machines on x86 systems, together with the kernel-xen*
44 packages. Information on how to use Xen can be found at the Xen
45 project pages.
46
47 Virtualisation can be used to run multiple versions or multiple Linux
48 distributions on one system, or to test untrusted applications in a
49 sandboxed environment. Note that the Xen technology is still in
50 development, and this RPM has received extremely little testing. Don't
51 be surprised if this RPM eats your data, drinks your coffee or makes
52 fun of you in front of your friends.
53
54 %description -l pl
55 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
56 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
57 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
58 projektu.
59
60 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
61 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
62 aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e technologia
63 Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany. Nie nale¿y
64 byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê czy bêdzie
65 siê wy¶miewa³ w obecno¶ci przyjació³.
66
67 %package devel
68 Summary:        Header files for xen
69 Summary(pl):    Pliki nag³ówkowe xena
70 Group:          Development/Libraries
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72
73 %description devel
74 Header files for xen.
75
76 %description devel -l pl
77 Pliki nag³ówkowe xena.
78
79 %package static
80 Summary:        Static xen libraries
81 Summary(pl):    Statyczne biblioteki xena
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
84
85 %description static
86 Static xen libraries.
87
88 %description static -l pl
89 Statyczne biblioteki xena.
90
91 %package doc
92 Summary:        Xen documentation
93 Summary(pl):    Dokumentacja xena
94 Group:          Applications/System
95 Requires:       %{name} = %{epoch}:%{version}-%{release}
96
97 %description doc
98 Xen documentation.
99
100 %description doc -l pl
101 Dokumentacja xena.
102
103 %prep
104 %setup -q
105
106 chmod -R u+w .
107 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
108
109 %build
110 CFLAGS="%{rpmcflags}" \
111 CXXFLAGS="%{rpmcflags}" \
112 %{__make} xen tools docs \
113         CC="%{__cc}" \
114         CXX="%{__cxx}"
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install-xen install-tools install-docs \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
123 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
124 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
125
126 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
127
128 #install -d $RPM_BUILD_ROOT%{_mandir}
129 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
130
131 #install -d doc-html-install/{interface,user}
132 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
133 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
134
135 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
136
137 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
138 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
139 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
140
141 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
142 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
143
144 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
145 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
146 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet,migrate}
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post
152 /sbin/ldconfig
153 /sbin/chkconfig --add xend
154 /sbin/chkconfig --add xendomains
155
156 %postun -p /sbin/ldconfig
157
158 %preun
159 if [ "$1" = "0" ]; then
160         %service xend stop
161         /sbin/chkconfig --del xend
162
163         %service xendomains stop
164         /sbin/chkconfig --del xendomains
165 fi
166
167 %files
168 %defattr(644,root,root,755)
169 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
170 %doc COPYING ChangeLog README docs/misc/*
171 /boot/%{name}-%{version}-syms
172 /boot/%{name}-%{version}.gz
173 /boot/%{name}.gz
174 %attr(754,root,root) /etc/rc.d/init.d/*
175 %dir %{_sysconfdir}/xen
176 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
177 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
178 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
179 %dir %{_sysconfdir}/xen/auto
180 %dir %{_sysconfdir}/xen/scripts
181 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
182 %attr(755,root,root) %{_bindir}/*
183 %attr(755,root,root) %{_sbindir}/*
184 %attr(755,root,root) %{_libdir}/lib*.so.*
185 %{_libdir}/python/%{name}
186 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
187 %{_mandir}/man?/*
188 %dir %{_sharedstatedir}/xen
189 %dir %{_sharedstatedir}/xen/sv
190 %dir %{_sharedstatedir}/xen/xend-db
191 %dir %{_sharedstatedir}/xen/xend-db/domain
192 %dir %{_sharedstatedir}/xen/xend-db/vnet
193 %dir %{_sharedstatedir}/xen/xend-db/migrate
194
195 %files devel
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_libdir}/lib*.so
198 %{_includedir}/*
199
200 %files static
201 %defattr(644,root,root,755)
202 %{_libdir}/lib*.a
203
204 %files doc
205 %defattr(644,root,root,755)
206 %dir %{_datadir}/xen
207 %{_datadir}/xen/*.pdf
This page took 0.066691 seconds and 3 git commands to generate.