]> git.pld-linux.org Git - packages/xca.git/blob - xca.spec
- updated to 2.6.0
[packages/xca.git] / xca.spec
1 Summary:        A GUI for handling X509 certificates, RSA keys, PKCS#10 Requests
2 Summary(pl.UTF-8):      GUI do obsługi certyfikatów X509, kluczy RSA, żądań PKCS#10
3 Name:           xca
4 Version:        2.6.0
5 Release:        1
6 Epoch:          1
7 License:        BSD
8 Group:          Applications/Communications
9 Source0:        https://github.com/chris2511/xca/releases/download/RELEASE.%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  be2ffca8a86d1ab564e5bd6f1040d383
11 Patch0:         cmake.patch
12 URL:            https://hohnstaedt.de/xca/
13 BuildRequires:  Qt5Sql-devel >= 5.14.0
14 BuildRequires:  Qt5Widgets-devel >= 5.14.0
15 BuildRequires:  cmake >= 3.16
16 BuildRequires:  libltdl-devel
17 BuildRequires:  openssl-devel >= 1.1.1
18 BuildRequires:  pkgconfig
19 BuildRequires:  qt5-build >= 5.14.0
20 BuildRequires:  qt5-linguist >= 5.14.0
21 BuildRequires:  python3-Sphinx
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Graphical certification authority is an interface for managing RSA
26 keys and certificates, and the creation and signing of PKCS#10
27 requests. It uses the OpenSSL library and a Berkeley DB for key and
28 certificate storage. It supports importing and exporting keys and PEM
29 DER PKCS8 certificates, signing and revoking of PEM DER PKCS12, and
30 the selection of x509v3 extensions. A tree view of certificates is
31 presented.
32
33 %description -l pl.UTF-8
34 Graficzne CA to interfejs do zarządzania kluczami RSA i certyfikatami,
35 tworzenia i podpisywania żądań PKCS#10. Używa biblioteki OpenSSL i
36 bazy Berkeley DB do przechowywania kluczy i certyfikatów. Obsługuje
37 importowanie i eksportowanie kluczy i certyfikatów PEM DER PKCS8,
38 podpisywanie i anulowanie PEM DER PKCS12 oraz wybór rozszerzeń x509v3.
39 Pokazywane jest drzewo certyfikatów.
40
41 %package -n bash-completion-xca
42 Summary:        Bash completion for xca commands
43 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń xca
44 Group:          Applications/Shells
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       bash-completion >= 2.0
47 %{?noarchpackage}
48
49 %description -n bash-completion-xca
50 Bash completion for xca commands.
51
52 %description -n bash-completion-xca -l pl.UTF-8
53 Bashowe uzupełnianie parametrów dla poleceń xca.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60
61 install -d build
62 cd build
63 %cmake \
64         ..
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/xca,%{_desktopdir},%{_mandir}/man1}
70
71 %{__make} -C build install/fast \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %update_mime_database
79
80 %postun
81 %update_mime_database
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS COPYRIGHT changelog README.md
86 %attr(755,root,root) %{_bindir}/xca
87 %{_datadir}/xca
88 %{_desktopdir}/xca.desktop*
89 %{_mandir}/man1/xca.1*
90 %{_docdir}/xca
91 %{_datadir}/metainfo/de.hohnstaedt.xca.metainfo.xml
92 %{_datadir}/mime/packages/xca.xml
93 %{_iconsdir}/hicolor/*/*/*.png
94 %{_pixmapsdir}/xca-32x32.xpm
95
96 %files -n bash-completion-xca
97 %defattr(644,root,root,755)
98 %{bash_compdir}/xca
This page took 0.099636 seconds and 4 git commands to generate.