]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- BR enca
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports 
6 #    only libXrandr 1.1 - with no gamma support)
7 #  - add and/or fix users/groups permissions
8 #  - didvide to subpackages?
9 #  - check how it works with external python libraries
10 #
11 # Conditional build:
12 %bcond_with     external_python
13
14 Summary:        XBMC
15 Name:           xbmc
16 Version:        10.0
17 Release:        0.1
18 License:        GPL v3
19 Group:          Applications/Multimedia
20 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
21 # Source0-md5:  728fb514e5f43f27bb880305061b4e72
22 URL:            http://xbmc.org
23 Patch0:         %{name}-nobash.patch
24 Patch1:         %{name}-python27.patch
25 Patch2:         %{name}-libpng14.patch
26 BuildRequires:  SDL_image-devel
27 BuildRequires:  SDL_mixer-devel
28 BuildRequires:  a52dec-libs-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  avahi-devel
33 BuildRequires:  boost-devel
34 BuildRequires:  bzip2-devel
35 BuildRequires:  cmake
36 BuildRequires:  curl-devel
37 BuildRequires:  dbus-devel
38 BuildRequires:  enca
39 BuildRequires:  enca-devel
40 BuildRequires:  faac-devel
41 BuildRequires:  faad2-devel
42 BuildRequires:  ffmpeg-devel
43 BuildRequires:  flac-devel
44 BuildRequires:  fontconfig-devel
45 BuildRequires:  freetype-devel
46 BuildRequires:  fribidi-devel
47 BuildRequires:  gawk
48 BuildRequires:  gettext-autopoint
49 BuildRequires:  gettext-devel
50 BuildRequires:  glew-devel
51 BuildRequires:  gperf
52 BuildRequires:  gtk+-devel
53 BuildRequires:  hal-devel
54 BuildRequires:  jasper-devel
55 BuildRequires:  libao-devel
56 BuildRequires:  libcdio-devel
57 BuildRequires:  libdts-devel
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libmad-devel
60 BuildRequires:  libmicrohttpd-devel
61 BuildRequires:  libmodplug-devel
62 BuildRequires:  libmms-devel
63 BuildRequires:  libmpeg2-devel
64 BuildRequires:  libogg-devel
65 BuildRequires:  libpng-devel
66 BuildRequires:  libsamplerate-devel
67 BuildRequires:  libsmbclient-devel
68 BuildRequires:  libtiff-devel
69 BuildRequires:  libtool
70 BuildRequires:  libvdpau-devel
71 BuildRequires:  libvorbis-devel
72 BuildRequires:  lzo-devel
73 BuildRequires:  mysql-devel
74 %ifarch %{ix86}
75 BuildRequires:  nasm
76 %endif
77 BuildRequires:  openssl-devel
78 BuildRequires:  pcre-cxx-devel
79 BuildRequires:  pkgconfig
80 BuildRequires:  pulseaudio-devel
81 BuildRequires:  python-devel
82 BuildRequires:  rpm-pythonprov
83 # used internally
84 BuildRequires:  sed >= 4.0
85 BuildRequires:  sqlite3-devel
86 BuildRequires:  unzip
87 BuildRequires:  wavpack-devel
88 BuildRequires:  xmms-devel
89 BuildRequires:  xorg-lib-libXinerama-devel
90 BuildRequires:  xorg-lib-libXrandr-devel
91 BuildRequires:  xorg-lib-libXtst-devel
92 BuildRequires:  zip
93 BuildRequires:  zlib-devel
94 Requires:       lsb-release
95 Requires:       xorg-app-xdpyinfo
96 Requires:       /usr/bin/glxinfo
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %description
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 enca -L none -x ISO8859-1 xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
105 %patch1 -p1
106 #%patch2 -p1
107
108 %build
109 ./bootstrap
110 %configure \
111         --disable-debug \
112         --enable-external-libraries \
113         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
128
129 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
130 %attr(755,root,root) %{_bindir}/*
131 %{_datadir}/%{name}
132 %attr(755,root,root) %{_libdir}/%{name}
133 %{_docdir}/%{name}
134 %{_desktopdir}/%{name}.desktop
135 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
136 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
137 %{_datadir}/xsessions/XBMC.desktop
This page took 0.159115 seconds and 5 git commands to generate.