]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- rel up
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #  - check how it works with external python libraries
11 #
12 # Conditional build:
13 %bcond_with     external_python
14 %bcond_without  goom
15
16 Summary:        XBMC
17 Name:           xbmc
18 Version:        10.1
19 Release:        0.2
20 License:        GPL v3
21 Group:          Applications/Multimedia
22 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
23 # Source0-md5:  391398126cb86a4f6fbd0b7037997d84
24 Source1:        goom_icon.png
25 # Source1-md5:  8c0ffe2055f2cfde1189687d12a68aa8
26 URL:            http://xbmc.org
27 Patch0:         %{name}-nobash.patch
28 Patch1:         %{name}-python27.patch
29 Patch2:         %{name}-subtitle_tags.patch
30 Patch3:         %{name}-goom_enable.patch
31 Patch4:         %{name}-fpsrate.patch
32 BuildRequires:  SDL_image-devel
33 BuildRequires:  SDL_mixer-devel
34 BuildRequires:  a52dec-libs-devel
35 BuildRequires:  alsa-lib-devel
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  avahi-devel
39 BuildRequires:  boost-devel
40 BuildRequires:  bzip2-devel
41 BuildRequires:  cmake
42 BuildRequires:  curl-devel
43 BuildRequires:  dbus-devel
44 BuildRequires:  enca-devel
45 BuildRequires:  faac-devel
46 BuildRequires:  faad2-devel
47 BuildRequires:  ffmpeg-devel
48 BuildRequires:  flac-devel
49 BuildRequires:  fontconfig-devel
50 BuildRequires:  freetype-devel
51 BuildRequires:  fribidi-devel
52 BuildRequires:  gawk
53 BuildRequires:  gettext-autopoint
54 BuildRequires:  gettext-devel
55 BuildRequires:  glew-devel
56 BuildRequires:  gperf
57 BuildRequires:  gtk+-devel
58 BuildRequires:  hal-devel
59 BuildRequires:  jasper-devel
60 BuildRequires:  libao-devel
61 BuildRequires:  libcdio-devel
62 BuildRequires:  libdts-devel
63 BuildRequires:  libjpeg-devel
64 BuildRequires:  libmad-devel
65 BuildRequires:  libmicrohttpd-devel
66 BuildRequires:  libmms-devel
67 BuildRequires:  libmodplug-devel
68 BuildRequires:  libmpeg2-devel
69 BuildRequires:  libogg-devel
70 BuildRequires:  libpng-devel
71 BuildRequires:  libsamplerate-devel
72 BuildRequires:  libsmbclient-devel
73 BuildRequires:  libtiff-devel
74 BuildRequires:  libtool
75 BuildRequires:  libvdpau-devel
76 BuildRequires:  libvorbis-devel
77 BuildRequires:  lzo-devel
78 BuildRequires:  mysql-devel
79 %ifarch %{ix86}
80 BuildRequires:  nasm
81 %endif
82 BuildRequires:  openssl-devel
83 BuildRequires:  pcre-cxx-devel
84 BuildRequires:  pkgconfig
85 BuildRequires:  pulseaudio-devel
86 BuildRequires:  python-devel
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  rpmbuild(macros) >= 1.566
89 # used internally
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel
92 BuildRequires:  unzip
93 BuildRequires:  wavpack-devel
94 BuildRequires:  xmms-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXrandr-devel
97 BuildRequires:  xorg-lib-libXtst-devel
98 BuildRequires:  zip
99 BuildRequires:  zlib-devel
100 Requires:       /usr/bin/glxinfo
101 Requires:       SDL >= 1.2.14-5
102 Requires:       lsb-release
103 Requires:       xorg-app-xdpyinfo
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %description
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %undos xbmc/lib/libPython/xbmcmodule/xbmcaddonmodule.cpp
112 %patch1 -p1
113 %patch2 -p1
114 %patch3 -p1
115 %patch4 -p1
116
117 %build
118 ./bootstrap
119 %configure \
120         --disable-debug \
121         --enable-external-libraries \
122         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python \
123         --%{?with_goom:en}%{!?with_goom:dis}able-goom
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131         install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/xbmc/addons/visualization.goom/icon.png
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
139
140 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
141 %attr(755,root,root) %{_bindir}/*
142 %{_datadir}/%{name}
143 %attr(755,root,root) %{_libdir}/%{name}
144 %{_docdir}/%{name}
145 %{_desktopdir}/%{name}.desktop
146 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
147 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
148 %{_datadir}/xsessions/XBMC.desktop
This page took 0.066173 seconds and 5 git commands to generate.