]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- added libcrystalhd-devel to shorten TODO
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  goom    # build without goom visualisation
10 %bcond_with     hal                     # build with HAL
11
12 Summary:        XBMC is a free and open source media-player and entertainment hub
13 Name:           xbmc
14 Version:        12.2
15 Release:        2
16 License:        GPL v2+ and GPL v3+
17 Group:          Applications/Multimedia
18 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
19 # Source0-md5:  489f3877decae4e265ece54f9eaef0ba
20 URL:            http://xbmc.org/
21 BuildRequires:  Mesa-libGLU-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 BuildRequires:  SDL_image-devel
25 BuildRequires:  SDL_mixer-devel
26 BuildRequires:  alsa-lib-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  avahi-devel
30 BuildRequires:  bluez-libs-devel >= 4.99
31 BuildRequires:  boost-devel
32 BuildRequires:  bzip2-devel
33 BuildRequires:  cmake
34 BuildRequires:  curl-devel
35 BuildRequires:  dbus-devel
36 BuildRequires:  ffmpeg-devel
37 BuildRequires:  flac-devel
38 BuildRequires:  fontconfig-devel
39 BuildRequires:  freetype-devel
40 BuildRequires:  fribidi-devel
41 BuildRequires:  gawk
42 BuildRequires:  gettext-autopoint
43 BuildRequires:  gettext-devel
44 BuildRequires:  glew-devel
45 BuildRequires:  gperf
46 %if %{with hal}
47 BuildRequires:  hal-devel
48 %endif
49 BuildRequires:  jasper-devel
50 BuildRequires:  libass-devel
51 BuildRequires:  libbluray-devel
52 BuildRequires:  libcdio-devel
53 BuildRequires:  libcec-devel
54 BuildRequires:  libcrystalhd-devel
55 BuildRequires:  libgcrypt-devel
56 BuildRequires:  libjpeg-devel
57 BuildRequires:  libmad-devel
58 BuildRequires:  libmicrohttpd-devel
59 BuildRequires:  libmodplug-devel
60 BuildRequires:  libmpeg2-devel
61 BuildRequires:  libogg-devel
62 BuildRequires:  libplist-devel
63 BuildRequires:  libpng-devel
64 BuildRequires:  librtmp-devel
65 BuildRequires:  libsamplerate-devel
66 BuildRequires:  libsmbclient-devel
67 BuildRequires:  libssh-devel
68 BuildRequires:  libtiff-devel
69 BuildRequires:  libtool
70 BuildRequires:  libva-devel
71 BuildRequires:  libva-glx-devel
72 BuildRequires:  libvdpau-devel
73 BuildRequires:  libvorbis-devel
74 BuildRequires:  lzo-devel
75 BuildRequires:  mysql-devel
76 %ifarch %{ix86}
77 BuildRequires:  nasm
78 %endif
79 BuildRequires:  openssl-devel
80 BuildRequires:  pcre-cxx-devel
81 BuildRequires:  pcre-devel
82 BuildRequires:  pkgconfig
83 BuildRequires:  pulseaudio-devel
84 BuildRequires:  python-devel >= 2.4
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.566
87 # used internally
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel
90 BuildRequires:  tinyxml-devel
91 BuildRequires:  udev-devel
92 BuildRequires:  unzip
93 BuildRequires:  xorg-lib-libX11-devel
94 BuildRequires:  xorg-lib-libXext-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXt-devel
99 BuildRequires:  xorg-lib-libXtst-devel
100 BuildRequires:  yajl-devel
101 BuildRequires:  zip
102 BuildRequires:  zlib-devel
103 #https://github.com/sahlberg/libnfs
104 #BuildRequires: libnfs-devel
105 #http://sites.google.com/site/alexthepuffin/home
106 #BuildRequires: afpfs-ng-devel
107 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
108 #https://github.com/albertz/shairport
109 #BuildRequires: libshairport
110 Requires:       /usr/bin/glxinfo
111 Requires:       SDL >= 1.2.14-5
112 Requires:       lsb-release
113 Requires:       xorg-app-xdpyinfo
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %description
117 XBMC media center is a free cross-platform media-player jukebox and
118 entertainment hub. XBMC can play a spectrum of of multimedia formats,
119 and featuring playlist, audio visualizations, slideshow, and weather
120 forecast functions, together third-party plugins.
121
122 %prep
123 %setup -q
124
125 %build
126 ./bootstrap
127 %configure \
128         --disable-debug \
129         --enable-external-libraries \
130         --enable-pulse \
131         --enable-udev \
132         --disable-libusb \
133         --disable-nfs \
134         --disable-afpclient \
135         --disable-airtunes \
136         %{__enable_disable goom} \
137         %{__enable_disable hal}
138
139 LIBS="-lpthread"
140 %{__make} V=1
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/*
153 %{_datadir}/%{name}
154 %attr(755,root,root) %{_libdir}/%{name}
155 %{_docdir}/%{name}
156 %{_desktopdir}/%{name}.desktop
157 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
158 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
159 %{_datadir}/xsessions/XBMC.desktop
This page took 0.041813 seconds and 5 git commands to generate.