]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- source address updated
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports 
6 #    only libXrandr 1.1 - with no gamma support)
7 #  - add and/or fix users/groups permissions
8 #  - didvide to subpackages?
9 #  - check how it works with external python libraries
10 #
11 # Conditional build:
12 %bcond_with     external_python
13
14 Summary:        XBMC
15 Name:           xbmc
16 Version:        10.0
17 Release:        0.1
18 License:        GPL v3
19 Group:          Applications/Multimedia
20 Source0:        http://www.softliste.de/xbmc/releases/source/%{name}-%{version}.tar.gz
21 # Source0-md5:  728fb514e5f43f27bb880305061b4e72
22 URL:            http://xbmc.org
23 Patch0:         %{name}-nobash.patch
24 Patch1:         %{name}-python27.patch
25 Patch2:         %{name}-libpng14.patch
26 BuildRequires:  SDL_image-devel
27 BuildRequires:  SDL_mixer-devel
28 BuildRequires:  a52dec-libs-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  avahi-devel
33 BuildRequires:  boost-devel
34 BuildRequires:  bzip2-devel
35 BuildRequires:  cmake
36 BuildRequires:  curl-devel
37 BuildRequires:  dbus-devel
38 BuildRequires:  enca-devel
39 BuildRequires:  faac-devel
40 BuildRequires:  faad2-devel
41 BuildRequires:  ffmpeg-devel
42 BuildRequires:  flac-devel
43 BuildRequires:  fontconfig-devel
44 BuildRequires:  freetype-devel
45 BuildRequires:  fribidi-devel
46 BuildRequires:  gawk
47 BuildRequires:  gettext-autopoint
48 BuildRequires:  gettext-devel
49 BuildRequires:  glew-devel
50 BuildRequires:  gperf
51 BuildRequires:  gtk+-devel
52 BuildRequires:  hal-devel
53 BuildRequires:  jasper-devel
54 BuildRequires:  libao-devel
55 BuildRequires:  libcdio-devel
56 BuildRequires:  libdts-devel
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libmad-devel
59 BuildRequires:  libmicrohttpd-devel
60 BuildRequires:  libmodplug-devel
61 BuildRequires:  libmms-devel
62 BuildRequires:  libmpeg2-devel
63 BuildRequires:  libogg-devel
64 BuildRequires:  libpng-devel
65 BuildRequires:  libsamplerate-devel
66 BuildRequires:  libsmbclient-devel
67 BuildRequires:  libtiff-devel
68 BuildRequires:  libtool
69 BuildRequires:  libvdpau-devel
70 BuildRequires:  libvorbis-devel
71 BuildRequires:  lzo-devel
72 BuildRequires:  mysql-devel
73 %ifarch %{ix86}
74 BuildRequires:  nasm
75 %endif
76 BuildRequires:  openssl-devel
77 BuildRequires:  pcre-cxx-devel
78 BuildRequires:  pkgconfig
79 BuildRequires:  pulseaudio-devel
80 BuildRequires:  python-devel
81 BuildRequires:  rpm-pythonprov
82 # used internally
83 BuildRequires:  sed >= 4.0
84 BuildRequires:  sqlite3-devel
85 BuildRequires:  unzip
86 BuildRequires:  wavpack-devel
87 BuildRequires:  xmms-devel
88 BuildRequires:  xorg-lib-libXinerama-devel
89 BuildRequires:  xorg-lib-libXrandr-devel
90 BuildRequires:  xorg-lib-libXtst-devel
91 BuildRequires:  zip
92 BuildRequires:  zlib-devel
93 Requires:       lsb-release
94 Requires:       xorg-app-xdpyinfo
95 Requires:       /usr/bin/glxinfo
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %description
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 #%patch2 -p1
105
106 %build
107 ./bootstrap
108 %configure \
109         --disable-debug \
110         --enable-external-libraries \
111         --%{?with_external_python:en}%{!?with_external_python:dis}able-external-python
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
126
127 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
128 %attr(755,root,root) %{_bindir}/*
129 %{_datadir}/%{name}
130 %attr(755,root,root) %{_libdir}/%{name}
131 %{_docdir}/%{name}
132 %{_desktopdir}/%{name}.desktop
133 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
134 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
135 %{_datadir}/xsessions/XBMC.desktop
This page took 0.091932 seconds and 5 git commands to generate.