]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- added -libpng14.patch
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix install - add DESTDIR support
6 #  - don't put binary in %{_datadir} and fix start scripts
7 #
8 Summary:        XBMC
9 Name:           xbmc
10 Version:        9.11
11 Release:        0.1
12 License:        GPL v3
13 Group:          Applications/Multimedia
14 Source0:        http://downloads.sourceforge.net/project/xbmc/XBMC%20Source%20Code/Camelot%20-%209.11/%{name}-%{version}.tar.gz
15 # Source0-md5:  9a68ac1e2f44a54cc3803fcdb1265767
16 URL:            http://xbmc.org
17 Patch0:         %{name}-nobash.patch
18 Patch1:         %{name}-libpng14.patch
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  a52dec-libs-devel
22 BuildRequires:  alsa-lib-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  avahi-devel
26 BuildRequires:  boost-devel
27 BuildRequires:  bzip2-devel
28 BuildRequires:  cmake
29 BuildRequires:  curl-devel
30 BuildRequires:  dbus-devel
31 BuildRequires:  enca-devel
32 BuildRequires:  esound-devel
33 BuildRequires:  faac-devel
34 BuildRequires:  faad2-devel
35 BuildRequires:  ffmpeg-devel
36 BuildRequires:  flac-devel
37 BuildRequires:  fontconfig-devel
38 BuildRequires:  freetype-devel
39 BuildRequires:  fribidi-devel
40 BuildRequires:  gawk
41 BuildRequires:  gettext-devel
42 BuildRequires:  glew-devel
43 BuildRequires:  gperf
44 BuildRequires:  gtk+-devel
45 BuildRequires:  hal-devel
46 BuildRequires:  jasper-devel
47 BuildRequires:  libao-devel
48 BuildRequires:  libcdio-devel
49 BuildRequires:  libdts-devel
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libmad-devel
52 BuildRequires:  libmms-devel
53 BuildRequires:  libmpeg2-devel
54 BuildRequires:  libogg-devel
55 BuildRequires:  libpng-devel
56 BuildRequires:  libsamplerate-devel
57 BuildRequires:  libsmbclient-devel
58 BuildRequires:  libtiff-devel
59 BuildRequires:  libtool
60 BuildRequires:  libvdpau-devel
61 BuildRequires:  libvorbis-devel
62 BuildRequires:  lzo-devel
63 BuildRequires:  mysql-devel
64 %ifarch %{ix86}
65 BuildRequires:  nasm
66 %endif
67 BuildRequires:  openssl-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  pulseaudio-devel
70 BuildRequires:  python-devel
71 BuildRequires:  rpm-pythonprov
72 # used internally
73 BuildRequires:  sed >= 4.0
74 BuildRequires:  sqlite3-devel
75 BuildRequires:  unzip
76 BuildRequires:  wavpack-devel
77 BuildRequires:  xmms-devel
78 BuildRequires:  xorg-lib-libXinerama-devel
79 BuildRequires:  xorg-lib-libXrandr-devel
80 BuildRequires:  xorg-lib-libXtst-devel
81 BuildRequires:  zip
82 BuildRequires:  zlib-devel
83 Requires:       lsb-release
84 Requires:       xorg-app-xdpyinfo
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %description
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 ./bootstrap
96 %configure \
97         --disable-debug \
98         --enable-external-libraries \
99         --enable-external-python
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         prefix=$RPM_BUILD_ROOT%{_prefix}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 #doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
114
115 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
116 %attr(755,root,root) %{_bindir}/*
117 %{_datadir}/%{name}
118 %attr(755,root,root) %{_datadir}/%{name}/xbmc.bin
119 %attr(755,root,root) %{_datadir}/%{name}/xbmc-xrandr
120 %{_desktopdir}/%{name}.desktop
121 %{_pixmapsdir}/%{name}.png
122 %{_datadir}/xsessions/XBMC.desktop
This page took 0.061817 seconds and 5 git commands to generate.