]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
Up to 12.1, format-security.patch applied upstream
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - fix nvidia vs. libXrandr >= 1.2 conflict (nvidia drivers still supports
6 #    only libXrandr 1.1 - with no gamma support; it causes application crash
7 #    on XRRSetCrtcGamma function called by SDL_SetVideoMode)
8 #  - add and/or fix users/groups permissions
9 #  - split to subpackages?
10 #
11 # Conditional build:
12 %bcond_without  goom    # build without goom visualisation
13 %bcond_with     hal                     # build with HAL
14
15 Summary:        XBMC is a free and open source media-player and entertainment hub
16 Name:           xbmc
17 Version:        12.1
18 Release:        1
19 License:        GPL v2+ and GPL v3+
20 Group:          Applications/Multimedia
21 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
22 # Source0-md5:  8955473f84cb2a0513c0f3efd7e68843
23 URL:            http://xbmc.org/
24 BuildRequires:  Mesa-libGLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  SDL_image-devel
28 BuildRequires:  SDL_mixer-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  avahi-devel
33 BuildRequires:  bluez-libs-devel >= 4.99
34 BuildRequires:  boost-devel
35 BuildRequires:  bzip2-devel
36 BuildRequires:  cmake
37 BuildRequires:  curl-devel
38 BuildRequires:  dbus-devel
39 BuildRequires:  ffmpeg-devel
40 BuildRequires:  flac-devel
41 BuildRequires:  fontconfig-devel
42 BuildRequires:  freetype-devel
43 BuildRequires:  fribidi-devel
44 BuildRequires:  gawk
45 BuildRequires:  gettext-autopoint
46 BuildRequires:  gettext-devel
47 BuildRequires:  glew-devel
48 BuildRequires:  gperf
49 %if %{with hal}
50 BuildRequires:  hal-devel
51 %endif
52 BuildRequires:  jasper-devel
53 BuildRequires:  libass-devel
54 BuildRequires:  libbluray-devel
55 BuildRequires:  libcdio-devel
56 BuildRequires:  libgcrypt-devel
57 BuildRequires:  libjpeg-devel
58 BuildRequires:  libmad-devel
59 BuildRequires:  libmicrohttpd-devel
60 BuildRequires:  libmodplug-devel
61 BuildRequires:  libmpeg2-devel
62 BuildRequires:  libogg-devel
63 BuildRequires:  libplist-devel
64 BuildRequires:  libpng-devel
65 BuildRequires:  librtmp-devel
66 BuildRequires:  libsamplerate-devel
67 BuildRequires:  libsmbclient-devel
68 BuildRequires:  libssh-devel
69 BuildRequires:  libtiff-devel
70 BuildRequires:  libtool
71 BuildRequires:  libva-devel
72 BuildRequires:  libvdpau-devel
73 BuildRequires:  libvorbis-devel
74 BuildRequires:  lzo-devel
75 BuildRequires:  mysql-devel
76 %ifarch %{ix86}
77 BuildRequires:  nasm
78 %endif
79 BuildRequires:  openssl-devel
80 BuildRequires:  pcre-cxx-devel
81 BuildRequires:  pcre-devel
82 BuildRequires:  pkgconfig
83 BuildRequires:  pulseaudio-devel
84 BuildRequires:  python-devel >= 2.4
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.566
87 # used internally
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel
90 BuildRequires:  tinyxml-devel
91 BuildRequires:  udev-devel
92 BuildRequires:  unzip
93 BuildRequires:  xorg-lib-libX11-devel
94 BuildRequires:  xorg-lib-libXext-devel
95 BuildRequires:  xorg-lib-libXinerama-devel
96 BuildRequires:  xorg-lib-libXmu-devel
97 BuildRequires:  xorg-lib-libXrandr-devel
98 BuildRequires:  xorg-lib-libXt-devel
99 BuildRequires:  xorg-lib-libXtst-devel
100 BuildRequires:  yajl-devel
101 BuildRequires:  zip
102 BuildRequires:  zlib-devel
103 #https://github.com/sahlberg/libnfs
104 #BuildRequires: libnfs-devel
105 #http://sites.google.com/site/alexthepuffin/home
106 #BuildRequires: afpfs-ng-devel
107 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
108 #https://github.com/albertz/shairport
109 #BuildRequires: libshairport
110 #http://www.broadcom.com/support/crystal_hd/
111 #BuildRequires: crystalhd-devel
112 #http://libcec.pulse-eight.com/
113 #BuildRequires: libcec-devel >= 1.1.0
114 Requires:       /usr/bin/glxinfo
115 Requires:       SDL >= 1.2.14-5
116 Requires:       lsb-release
117 Requires:       xorg-app-xdpyinfo
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %description
121 XBMC media center is a free cross-platform media-player jukebox and
122 entertainment hub. XBMC can play a spectrum of of multimedia formats,
123 and featuring playlist, audio visualizations, slideshow, and weather
124 forecast functions, together third-party plugins.
125
126 %prep
127 %setup -q
128
129 %build
130 ./bootstrap
131 %configure \
132         --disable-debug \
133         --enable-external-libraries \
134         --enable-udev \
135         --disable-libcec \
136         --disable-libusb \
137         --disable-nfs \
138         --disable-afpclient \
139         --disable-airtunes \
140         --disable-crystalhd \
141         %{__enable_disable goom} \
142         %{__enable_disable hal}
143
144 %{__make} V=1
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/*
157 %{_datadir}/%{name}
158 %attr(755,root,root) %{_libdir}/%{name}
159 %{_docdir}/%{name}
160 %{_desktopdir}/%{name}.desktop
161 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
162 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
163 %{_datadir}/xsessions/XBMC.desktop
This page took 0.078423 seconds and 5 git commands to generate.