]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- added bcond without cec
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  cec     # build without cec support
10 %bcond_without  goom    # build without goom visualisation
11 %bcond_with     hal     # build with HAL
12
13 Summary:        XBMC is a free and open source media-player and entertainment hub
14 Name:           xbmc
15 Version:        12.2
16 Release:        3
17 License:        GPL v2+ and GPL v3+
18 Group:          Applications/Multimedia
19 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
20 # Source0-md5:  489f3877decae4e265ece54f9eaef0ba
21 URL:            http://xbmc.org/
22 BuildRequires:  Mesa-libGLU-devel
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  SDL_image-devel
25 BuildRequires:  SDL_mixer-devel
26 BuildRequires:  alsa-lib-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  avahi-devel
30 BuildRequires:  bluez-libs-devel >= 4.99
31 BuildRequires:  boost-devel
32 BuildRequires:  bzip2-devel
33 BuildRequires:  cmake
34 BuildRequires:  curl-devel
35 BuildRequires:  dbus-devel
36 BuildRequires:  ffmpeg-devel
37 BuildRequires:  flac-devel
38 BuildRequires:  fontconfig-devel
39 BuildRequires:  freetype-devel
40 BuildRequires:  fribidi-devel
41 BuildRequires:  gawk
42 BuildRequires:  gettext-autopoint
43 BuildRequires:  gettext-devel
44 BuildRequires:  glew-devel
45 BuildRequires:  gperf
46 %{?with_hal:BuildRequires:      hal-devel}
47 BuildRequires:  jasper-devel
48 BuildRequires:  jre
49 BuildRequires:  libass-devel
50 BuildRequires:  libbluray-devel >= 0.2.1
51 BuildRequires:  libcap-devel
52 BuildRequires:  libcdio-devel
53 %{?with_cec:BuildRequires:      libcec-devel}
54 %ifarch i686 pentium4 athlon %{x8664}
55 BuildRequires:  libcrystalhd-devel
56 %endif
57 BuildRequires:  libgcrypt-devel
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libmad-devel
60 BuildRequires:  libmicrohttpd-devel
61 BuildRequires:  libmodplug-devel
62 BuildRequires:  libmpeg2-devel
63 BuildRequires:  libogg-devel
64 BuildRequires:  libplist-devel
65 BuildRequires:  libpng-devel
66 BuildRequires:  librtmp-devel
67 BuildRequires:  libsamplerate-devel
68 BuildRequires:  libsmbclient-devel
69 BuildRequires:  libssh-devel
70 BuildRequires:  libtiff-devel
71 BuildRequires:  libtool
72 BuildRequires:  libva-devel
73 BuildRequires:  libva-glx-devel
74 BuildRequires:  libvdpau-devel
75 BuildRequires:  libvorbis-devel
76 BuildRequires:  lzo-devel
77 BuildRequires:  mysql-devel
78 %ifarch %{ix86}
79 BuildRequires:  nasm
80 %endif
81 BuildRequires:  openssl-devel
82 BuildRequires:  pcre-cxx-devel
83 BuildRequires:  pkgconfig
84 BuildRequires:  pulseaudio-devel
85 BuildRequires:  python-devel >= 2.4
86 BuildRequires:  rpm-pythonprov
87 BuildRequires:  rpmbuild(macros) >= 1.566
88 # used internally
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel
91 BuildRequires:  swig
92 BuildRequires:  taglib-devel >= 1.8
93 BuildRequires:  tinyxml-devel
94 BuildRequires:  udev-devel
95 BuildRequires:  unzip
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXext-devel
98 BuildRequires:  xorg-lib-libXinerama-devel
99 BuildRequires:  xorg-lib-libXmu-devel
100 BuildRequires:  xorg-lib-libXrandr-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 BuildRequires:  xorg-lib-libXtst-devel
103 BuildRequires:  yajl-devel
104 BuildRequires:  zip
105 BuildRequires:  zlib-devel
106 #https://github.com/sahlberg/libnfs
107 #BuildRequires: libnfs-devel
108 #http://sites.google.com/site/alexthepuffin/home
109 #BuildRequires: afpfs-ng-devel
110 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
111 #https://github.com/albertz/shairport
112 #BuildRequires: libshairport
113 Requires:       /usr/bin/glxinfo
114 Requires:       SDL >= 1.2.14-5
115 Requires:       lsb-release
116 Requires:       xorg-app-xdpyinfo
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 XBMC media center is a free cross-platform media-player jukebox and
121 entertainment hub. XBMC can play a spectrum of of multimedia formats,
122 and featuring playlist, audio visualizations, slideshow, and weather
123 forecast functions, together third-party plugins.
124
125 %prep
126 %setup -q
127
128 %build
129 ./bootstrap
130 %configure \
131         --disable-debug \
132         --enable-external-libraries \
133         --enable-pulse \
134         --enable-udev \
135         --disable-libusb \
136         --disable-nfs \
137         --disable-afpclient \
138         --disable-airtunes \
139         %{__enable_disable goom} \
140         %{__enable_disable hal} \
141         %{__enable_disable libcec}
142
143 LIBS="-lpthread"
144 %{__make} V=1
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/*
157 %{_datadir}/%{name}
158 %attr(755,root,root) %{_libdir}/%{name}
159 %{_docdir}/%{name}
160 %{_desktopdir}/%{name}.desktop
161 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
162 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
163 %{_datadir}/xsessions/XBMC.desktop
This page took 0.071964 seconds and 5 git commands to generate.