]> git.pld-linux.org Git - packages/xbmc.git/blob - xbmc.spec
- i486 doesn't have libcrystalhd-devel
[packages/xbmc.git] / xbmc.spec
1 #
2 # TODO:
3 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
4 #  - fix linking argument order
5 #  - add and/or fix users/groups permissions
6 #  - split to subpackages?
7 #
8 # Conditional build:
9 %bcond_without  goom    # build without goom visualisation
10 %bcond_with     hal                     # build with HAL
11
12 Summary:        XBMC is a free and open source media-player and entertainment hub
13 Name:           xbmc
14 Version:        12.2
15 Release:        3
16 License:        GPL v2+ and GPL v3+
17 Group:          Applications/Multimedia
18 Source0:        http://mirrors.xbmc.org/releases/source/%{name}-%{version}.tar.gz
19 # Source0-md5:  489f3877decae4e265ece54f9eaef0ba
20 URL:            http://xbmc.org/
21 BuildRequires:  Mesa-libGLU-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel
24 BuildRequires:  SDL_image-devel
25 BuildRequires:  SDL_mixer-devel
26 BuildRequires:  alsa-lib-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  avahi-devel
30 BuildRequires:  bluez-libs-devel >= 4.99
31 BuildRequires:  boost-devel
32 BuildRequires:  bzip2-devel
33 BuildRequires:  cmake
34 BuildRequires:  curl-devel
35 BuildRequires:  dbus-devel
36 BuildRequires:  ffmpeg-devel
37 BuildRequires:  flac-devel
38 BuildRequires:  fontconfig-devel
39 BuildRequires:  freetype-devel
40 BuildRequires:  fribidi-devel
41 BuildRequires:  gawk
42 BuildRequires:  gettext-autopoint
43 BuildRequires:  gettext-devel
44 BuildRequires:  glew-devel
45 BuildRequires:  gperf
46 %if %{with hal}
47 BuildRequires:  hal-devel
48 %endif
49 BuildRequires:  jasper-devel
50 BuildRequires:  libass-devel
51 BuildRequires:  libbluray-devel
52 BuildRequires:  libcdio-devel
53 BuildRequires:  libcec-devel
54 %ifarch i686 pentium4 athlon %{x8664}
55 BuildRequires:  libcrystalhd-devel
56 %endif
57 BuildRequires:  libgcrypt-devel
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libmad-devel
60 BuildRequires:  libmicrohttpd-devel
61 BuildRequires:  libmodplug-devel
62 BuildRequires:  libmpeg2-devel
63 BuildRequires:  libogg-devel
64 BuildRequires:  libplist-devel
65 BuildRequires:  libpng-devel
66 BuildRequires:  librtmp-devel
67 BuildRequires:  libsamplerate-devel
68 BuildRequires:  libsmbclient-devel
69 BuildRequires:  libssh-devel
70 BuildRequires:  libtiff-devel
71 BuildRequires:  libtool
72 BuildRequires:  libva-devel
73 BuildRequires:  libva-glx-devel
74 BuildRequires:  libvdpau-devel
75 BuildRequires:  libvorbis-devel
76 BuildRequires:  lzo-devel
77 BuildRequires:  mysql-devel
78 %ifarch %{ix86}
79 BuildRequires:  nasm
80 %endif
81 BuildRequires:  openssl-devel
82 BuildRequires:  pcre-cxx-devel
83 BuildRequires:  pcre-devel
84 BuildRequires:  pkgconfig
85 BuildRequires:  pulseaudio-devel
86 BuildRequires:  python-devel >= 2.4
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  rpmbuild(macros) >= 1.566
89 # used internally
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel
92 BuildRequires:  tinyxml-devel
93 BuildRequires:  udev-devel
94 BuildRequires:  unzip
95 BuildRequires:  xorg-lib-libX11-devel
96 BuildRequires:  xorg-lib-libXext-devel
97 BuildRequires:  xorg-lib-libXinerama-devel
98 BuildRequires:  xorg-lib-libXmu-devel
99 BuildRequires:  xorg-lib-libXrandr-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 BuildRequires:  xorg-lib-libXtst-devel
102 BuildRequires:  yajl-devel
103 BuildRequires:  zip
104 BuildRequires:  zlib-devel
105 #https://github.com/sahlberg/libnfs
106 #BuildRequires: libnfs-devel
107 #http://sites.google.com/site/alexthepuffin/home
108 #BuildRequires: afpfs-ng-devel
109 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
110 #https://github.com/albertz/shairport
111 #BuildRequires: libshairport
112 Requires:       /usr/bin/glxinfo
113 Requires:       SDL >= 1.2.14-5
114 Requires:       lsb-release
115 Requires:       xorg-app-xdpyinfo
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %description
119 XBMC media center is a free cross-platform media-player jukebox and
120 entertainment hub. XBMC can play a spectrum of of multimedia formats,
121 and featuring playlist, audio visualizations, slideshow, and weather
122 forecast functions, together third-party plugins.
123
124 %prep
125 %setup -q
126
127 %build
128 ./bootstrap
129 %configure \
130         --disable-debug \
131         --enable-external-libraries \
132         --enable-pulse \
133         --enable-udev \
134         --disable-libusb \
135         --disable-nfs \
136         --disable-afpclient \
137         --disable-airtunes \
138         %{__enable_disable goom} \
139         %{__enable_disable hal}
140
141 LIBS="-lpthread"
142 %{__make} V=1
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %files
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/*
155 %{_datadir}/%{name}
156 %attr(755,root,root) %{_libdir}/%{name}
157 %{_docdir}/%{name}
158 %{_desktopdir}/%{name}.desktop
159 %{_iconsdir}/hicolor/256x256/apps/%{name}.png
160 %{_iconsdir}/hicolor/48x48/apps/%{name}.png
161 %{_datadir}/xsessions/XBMC.desktop
This page took 0.093119 seconds and 5 git commands to generate.